Reply
tutorr60
Follower

Netgear Orbi RBR20 and Ecovac Deebot connectivity issues

Hello.  I am at my wits end on connecting my Ecovac Deebot N79S to my wifi network.  I have gone back and forth with Deebot support.  The Deebot will NOT work on a 5.0GHz network and requires a 2.4GHz.  I was them I had 2 other Deebots on my network that works fine.  I have 3-+ devices on this Orbi and many are 2.4GHz.  The Deebot person told me to go to the furthest point in my home to make sure I was guaranteed a 2.4GHz connection.  I even went outside where I was almost assured I would be on the 2.4GHz channel.  I spoke to a Netgear Orbi support person and they told me the Orbi would not provide a 5GHz signal to the Deebot, since it does support anything but 2.4GHz.  The Deebot support also asked me to get the MAC address of the robot and add it to the Orbu routers and this it should override any connection concerns.  A Orbi support person told today that was NOT possible and that you shouldn't have to do this!  

 

I guess my questions are: 

Can you disable 5GHz channel on the Orbi?

Can you add a MAC access to the ACL List.  

 

Any support would be greatly appreciated.  

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 1 of 3
plemans
Guru

Re: Netgear Orbi RBR20 and Ecovac Deebot connectivity issues

What most have had luck with is to turn down the broadcast power on the 5ghz signal during setup or you can try disabling the 5ghz ssid broadcast for setup.  Once setup, you can turn it back up/on.

https://community.netgear.com/t5/Orbi/Kindle-Paperwhite-not-found-my-Orbi-RBR40/m-p/1711049/highligh...

https://community.netgear.com/t5/Orbi/orbi-20-cannot-connect-Swann-Camera/m-p/1822441/highlight/true...

 

Take a look at these posts for more details. 

CM2000-> RAX200-> GS716v2-> EX8000
Message 2 of 3
CrimpOn
Sensei

Re: Netgear Orbi RBR20 and Ecovac Deebot connectivity issues


@tutorr60 wrote:

I was them I had 2 other Deebots on my network that works fine.


Perhaps autocorrect garbled the post.  Did you mean to say that you already have 2 Deebots working on your network and that this third Deebot will not connect?  Are they the same model?

 

While lots of "2.4G only" devices connect easily to mesh networks, such as Orbi, the concensus appears to be that some vendors have poorly programmed their smartphone setup applications. What seems to be the case is that when the smartphone is connected to WiFi at 5G, the app is either (a) unable to locate the 2.4G only device, (b) badgers the user about 2.4G to the point that they simply give up (I just pressed "Continue" until it finished on one smart plug.), or (c) communicates the actual MAC address of the Orbi 5G WiFi rather than the SSID and password.

 

So, the goal appears to be to make the smartphone connect to Orbi at 2.4G, set up the 2.4G only device, and then "everybody is happy."  People are suggesting methods to get the smartphone connected at 2.4G rather than 5G:

 

  • Travel so far from the Orbi that the 5G signal is so much lower than the 2.4G signal that the phone connects to 2.4G.
    This can be a challenge.  How far away from the house do you go?
  • Turn down the 5G transmit level so that it is so much lower than the 2.4G signal that the phone connects to 2.4G.
    This is sort of the same problem.  What if 25% is not "low enough"?
  • Temporarily stop the Orbi from transmitting the 5G SSID.
    This one seems to be pretty successful.

Please try this procedure:

 

  • Navigate to the Orbi Advanced Tab->Advanced Setup->Wireless Settings.
    Uncheck the 5G box "Enable SSID Broadcast"
    Click "Apply"
  • On the smartphone, navigate to the WiFi control panel.
    Disconnect from the Orbi and "forget" the Orbi WiFi.  (this clears the password)
  • On the smartphone, search for nearby WiFi networks and select the Orbi from the list.
  • Enter the Orbi WiFi password and connect.
  • (At this point if you connected to the Orbi web interface or used the Orbi app, it should show the smartphone connected at 2.4G.)
  • Open the smartphone app and set up the device.
  • Once the device says it is set up, go again to the Attached Devices or Orbi app and verify that the device has connected.
  • Now that the task is complete, navigate back to the Orbi Advanced Tab->Advanced Setup->Wireless Settings, check the box "Enable SSID Broadcast" for 5G and click "Apply"
  • The smartphone can be left connected to the Orbi at 2.4G or can be reconnected to 5G, either be doing the "forget" process or turning the phone off and back on again.  (with the password being saved, the phone will select from whichever Orbi SSID is best).

The part that seems to confuse people is that the actual device never has contact with the Orbi 5G or is even aware of the Orbi 5G.  The device has no 5G radio.  It's like a black and white TV watching a color program.  It doesn't matter if the program is color if the TV cannot process color.  "Band Steering" and other factors are not relevant.  What IS relevant is the setup software is written poorly and will cause failure on ANY true mesh network.

 

Sorry to go on (and on).  Please give this a try and comment on whether it worked or not.

I love my Orbi.
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 1063 views
  • 0 kudos
  • 3 in conversation
Announcements