Reply
darryl12123
Aspirant

Orbi RBR50 issue with Sonos Playbar

Hi guys,
Since this morning I've issues with my Sonos playbar. It won't connect over wifi with my Orbi RBR50 which is setup as AP. It was working fine for months. I've tried everything, factory resetting Sonos and Orbi, nothing helps. I updated the firmware on Orbi to the latest (2.5.1.8). In the release notes it says that this firmware version solves compatibility issues with Sonos. But clearly is still have issues.

Does anyone else have issues with Orbi and Sonos?
Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 8
FURRYe38
Guru

Re: Orbi RBR50 issue with Sonos Playbar


What is the distance between the router and satellite(s)? 30 feet is recommended in between RBR and RBS to begin with depending upon building materials when wirelessly connected. https://kb.netgear.com/000036466/How-far-should-I-place-my-Orbi-satellite-from-my-Orbi-router

 

What channels are you using? Auto? Try setting manual channel 1, 6 or 11 on 2.4Ghz and any unused channel on 5Ghz. 

What channels does the Sonos work on. Does it broadcast its own wifi signal any? 


Any Wifi Neighbors near by? If so, how many?

 

Try enabling Beamforming and MIMO(MIMO may or maynot be needed) and WMM. Under Advanced Tab/Advanced Settings/Wireless Settings

Try disabling the following and see:
Armor, Circle, Daisy Chain, Fast Roaming, IPv6 and Set 20/40Mhz Coexistence to 40Mhz only. Save settings and reboot the router and satellite(s).

 

Has a factory reset and setup from scratch been performed since last FW update?

 

I would contact Sonos Mfr and ask for there help and information if any of the suggestions don't work for you. 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 2 of 8
darryl12123
Aspirant

Re: Orbi RBR50 issue with Sonos Playbar

At the moment I've switched off the satelite to rule out it isn't the problem. 

 

Forgot to mention earlier but I said that the Orbi is setup as AP, so the main router is a Nighthawk. I switched on 2.4ghz (on which Sonos works with) on the nighthawk just to test if Sonos was the problem or the Orbi. I factory reset Sonos and connected it to the nighthawk and it worked without any issues! Reconnected again to the Orbi and it won't work wiresly. It does work with an ethernet cable but obviously I want it wiresless.

 

So the problem is at Orbi, not Sonos.

Message 3 of 8
FURRYe38
Guru

Re: Orbi RBR50 issue with Sonos Playbar

Be sure to disable any wifi on the NH router. Try some of the suggestions meantioned for Orbi. 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 4 of 8
darryl12123
Aspirant

Re: Orbi RBR50 issue with Sonos Playbar

At the moment I can't connect wireless at all with the Orbi with Sonos. Sonos app keeps saying wrong password while i'm 100% sure it is the correct password.

The problem is with Orbi as Sonos is working fine wireless with the Nighthawk router, any thoughts?

Message 5 of 8
FURRYe38
Guru

Re: Orbi RBR50 issue with Sonos Playbar

Disable the Security mode on the RBR temporarily. Try to setup and connect the device to the RBR. Does it connect then? Then try enabling WPA and TPIK then connect the device. Then try WPA2 and AES only. 

 

Possible the device is not compatible with Orbi. 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 6 of 8
darryl12123
Aspirant

Re: Orbi RBR50 issue with Sonos Playbar

Thanks for helping out. But I discussed the case with the retailer the Orbi came from and they wanted me to send back the Orbi to have it checked out.

 

I'm don't believe that Orbi is not compatible with Sonos because it worked fine for months, and it is just a Access Point in my case, so it should only be a simple Wifi signal where Sonos has to connect to. 

 

I think the 2.4ghz transmitter in the Orbi for some reason is faulty. It is hard to test for me because all the devices I have connect automatically to the 5ghz wifi. But if there is something wrong with the 2.4ghz that could explain why Sonos can't connect to Orbi but can connect to the Nighthawk router without issues.

 

So I'm sending back the Orbi and wait out the outcome of the investigation.

 

To be continued.

Message 7 of 8
FURRYe38
Guru

Re: Orbi RBR50 issue with Sonos Playbar

Ok, keep us posted. 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1126 views
  • 0 kudos
  • 2 in conversation
Announcements