Discussion stats
  • 20 replies
  • 4443 views
  • 6 kudos
  • 4 in conversation
Announcements

Top Contributors
Reply
Highlighted

Orbi unable to update time v1.8.0.6

Hello all,

After updating to v1.8.0.6 my orbi has been unable to update its system time. I have tried via Advanced->Security->Schedule to change timezones, check and in check adjusting for DST, with no effect. I was able to update the time via telnet with the "date" command, but it doesn't stick after a reboot.

Rebooting sets the system time back to a Unix timestamp of 0 - and it never updates. This is all behind an active Pace gigabit modem with the Wifi AP disabled.

Anyone else having this issue? Any suggestions?

Thanks,
Steve
Message 1 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

Forgot to mention - this also prevents me from connecting to my OpenVPN server, as well as updating my Dynamic DNS entry with MyNetgear.
Message 2 of 21
Highlighted
Virtuoso

Re: Orbi unable to update time v1.8.0.6

FiOS with Orbi in AP mode on v1.8.0.6 here - NTP updates happen daily as expected and update the Orbis properly.

 

Rodney

Message 3 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

Do you know about how long after boot, or local time your time is updated each day?  Thanks

Message 4 of 21
Highlighted
Master

Re: Orbi unable to update time v1.8.0.6

Time synchs to NTP immediately after reboot (~2 sec) then again approximately every 24 hrs thereafter.

Message 5 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

Thanks for your reply.

 

My Orbi does not update after reboot (or ever) - anyone know of the best way to get debug information to Netgear engineering?

 

So far I have only been able to update my Orbi's time via telnet ntpclient command manually.

Message 6 of 21
Highlighted
Master

Re: Orbi unable to update time v1.8.0.6

 


@CaptStevo wrote:

Thanks for your reply.

 

My Orbi does not update after reboot (or ever) - anyone know of the best way to get debug information to Netgear engineering?

 

So far I have only been able to update my Orbi's time via telnet ntpclient command manually.


 

I noticed mine was set on the wrong time zone and wasn't tracking DST.  When I applied those settings it synch'd via NTP immediately.

 

Stupid questions, but:

Are you certain the router is set to log NTP synchs (this can be unchecked)?

Could something on the network (firewall, your ISP, etc) be blocking NTP to or from the Orbi router? I know you said you set it manually, but did you synch to the same server Orbi uses by default?

 

Message 7 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

Well, you were right.  It took a bit to nail the cause down, but AT&T blocks outbound UDP connections on port 123.  This is apparently to cut down on DDoS attacks - but it renders the Orbi unable to update its time.

 

I have seen other posts in the Netgear forums that indicate that Netgear engineers were able to create firmware versions that could update timestamps without depending on port 123.  If Netgear sees this, I'd be willing to help solve the issue!  I may have to return my Orbi if I can't use it with AT&T.

 

I was able to confirm that using a non-standard NTP port updates the Orbi's time flawlessly.  Logging in via telnet and executing: 

ntpclient -h "time-g.netgear.com" -b "time-h.netgear.com" -i 15 -m 60 -p 123 -s

...fails (using port 123).

 

When I tried the same command, with a non-standard NTP port: 

ntpclient -h "time-g.netgear.com" -b "time-h.netgear.com" -i 15 -m 60 -p 1238 -s

...it worked flawlessly.

 

I've been attempting to find a workaround for two days now.  Perhaps I can execute a cronjob to update the time correctly, but I don't believe it will survive a reboot.

Message 8 of 21
Highlighted
Master

Re: Orbi unable to update time v1.8.0.6

I'm glad my comments helped you determine the cause of the problem.

 

If you cannot change the command Orbi uses to synch, one thing you might be able to do is setup your own ntp server on your LAN, using a Windows box, a Linux machine, Raspberry Pi, etc. Then direct the Orbi to that server on the LAN.  You could potentially do that by adding a fixed-IP entry for the LAN ntp server in Orbi with the host name time-g.netgear.com.

 

As long as Orbi would resolve time-g.netgear.com to the LAN IP it should work. I'm not sure whether Orbi's internal name resolution would pick it up properly though.

 

I believe Windows can serve as an NTP server natively.

Message 9 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

Until Netgear adds an option to use an alternative port to sync with NTP servers, this problem will persist.  My research indicates that UDP NTP traffic is now blocked by several ISPs, so this problem will continue to pop up until Netgear addresses this issue.

 

My only potential solution would be to have a machine act as a DNS server as well as an NTP server - quite the workaround that most users will not be able to do.

 

Thanks for all the help so far.  I'll update if Netgear contacts me.

Message 10 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

"You could potentially do that by adding a fixed-IP entry for the LAN ntp server in Orbi with the host name time-g.netgear.com."

 

Do you know of a solution to do this?  I didn't see a /etc/hosts file on the Orbi, and looking at the static routes page didn't offer an obvious solution.

Message 11 of 21
Highlighted
Master

Re: Orbi unable to update time v1.8.0.6

 

DHCP address reservation via the GUI.  See page 64 of the user manual. (http://www.downloads.netgear.com/files/GDC/RBK50/Orbi_UM_EN.pdf)

 

Reserving an IP address should setup Orbi's DNS to resolve the entered host name to the LAN IP address.

 

I know this would work on other routers, but I'm running my Orbi in AP mode, so I cannot test it.

Message 12 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

Unfortunately I don't see a way to specify a host name for a reserved IP address.  Looks like it's up to Netgear to offer a solution.  Thanks for your help!

Message 13 of 21
Highlighted
Virtuoso

Re: Orbi unable to update time v1.8.0.6

Post removed because I replied to the wrong message

 

Rodney

Message 14 of 21
Highlighted
Master

Re: Orbi unable to update time v1.8.0.6

 

 


@CaptStevo wrote:

Unfortunately I don't see a way to specify a host name for a reserved IP address.  Looks like it's up to Netgear to offer a solution.  Thanks for your help!


 

Do you not have the "Device Name" field in the GUI?

 

Capture2.PNG

Message 15 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

Correct me if I'm wrong, but isn't that field for device name just a way to save a custom name for the connected device, not an actual host name?
Message 16 of 21
Highlighted
Master

Re: Orbi unable to update time v1.8.0.6

 

I don't know for certain, because I'm using Orbi in AP mode and this function is disabled.  However, on other routers when you specify the device name when reserving an IP address, the router's DNS will then resolve that name to the reserved IP address.

 

Message 17 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

Thanks st_shaw. I have tried to reserve my local server to an IP address with one of netgear's NTP server addresses, but it still resolves to the actual IP address Netgear uses. It was worth a shot.

Until Netgear offers a solution via a firmware update, the Orbi's functions that are dependent on time will be crippled.

I have yet to hear from anyone from Netgear. Thanks again.
Message 18 of 21
Highlighted
Master

Re: Orbi unable to update time v1.8.0.6

 

You sound like you know your way around networking.  From reading your post, though, it sounds like you used the public IP address of the netgear time server.  If so, that would be incorrect.

 

What you want to do is assign the domain name "time-g.netgear.com" to a local IP address on your LAN, e.g. 192.168.1.10.

 

If the Orbi GUI would accept it (a big IF) then you would use 192.168.1.10 as the reserved IP address and time-g.netgear.com as the "Device Name".

 

I just tried this on my network to see if it would work.  It took all of abot 10 seconds to alias the domain time-g.netgear.com to my Linux server at 192.168.1.10.  The trick works perfectly.  If I ping the netgear time server, I get directed to the local Linux host.

 

ping time-g.netgear.com

Pinging time-g.netgear.com [192.168.1.10] with 32 bytes of data
Reply from 192.168.1.10: bytes=32 time<1ms TTL=64
Reply from 192.168.1.10: bytes=32 time<1ms TTL=64
Reply from 192.168.1.10: bytes=32 time<1ms TTL=64
Reply from 192.168.1.10: bytes=32 time<1ms TTL=64

Ping statistics for 192.168.1.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

 

That's using my Ubiquiti Edgerouter.  The trick should work on many other routers. I just can't easily try it with my Orbi.

 

You could also setup a separate DNS server on your LAN to accomplish the same thing. That could be a bit of work though.

Message 19 of 21
Highlighted
Apprentice

Re: Orbi unable to update time v1.8.0.6

I have had the same issue with AT&T on all of my Netgear routers.  I just use Telnet and issue a date command to fix it manually.  It sucks but it works.  It is odd because some instances the Orbi will get the correct date/time after a reboot (which is only when I update the firmware).

 

Telnet command:    date -s 2017.03.17-16:11-0800

                                           (Date)-(Time)-(Timezone)

 

I might have to give st_shaw's recommendation a go.

Message 20 of 21
Highlighted

Re: Orbi unable to update time v1.8.0.6

I reached out to Netgear's twitter account to see if they would pass this concern on to engineering.  They told me to create an "idea" topic as that's how they guage customer interest in features/fixes.

 

If you'd like to "vote" that Netgear fix the NTP problem, please add your comment on the topic here: https://community.netgear.com/t5/Idea-Exchange-For-Home/User-Alternate-NTP-Ports/idi-p/1257017#M670

 

Thanks for all your help!  It's up to Netgear to make this simple change!

Message 21 of 21