Reply

Re: Web firmware upgrade for GS108Ev3 failing

MikaelN
Tutor

Web firmware upgrade for GS108Ev3 failing

I wante to upgrade to version 2.00.05 but don't have a Windows machine handy. So I thought I'd use the web interface.

 

After entering "loader mode" on the switch, I uploaded the firmware, only to find the router stuck in this Loader mode with no way of getting out.

 

I tried:

* reboot

* power off/on

* holding factory reset for >1min (no effect at all).

 

What ever I do, I only ever get back to this firmware loader screen. I've seen a similar issue for a previous version (https://community.netgear.com/t5/Managed-Switches/GS108E-Firmware-Upgrade-Issues/td-p/372672) which was solved by using TFTP to upload the firmware. That did not seem to work in my case.

 

Any ideas, or do I need to get hold of a Windows machine and try the utility?

Message 1 of 15

Accepted Solutions
MikaelN
Tutor

Re: Web firmware upgrade for GS108Ev3 failing

And an update: Managed to borrow a Windows machine. The ProSafe utility (latest version) did not even find the switch. Nice!

 

Then I tried the firmware upgrade from chrome on the windows machine, and voila, that actually worked! What on earth could be the issue?

 

So to summarize: firmware upgrade from chrome or firefox on linux failed, Prosafe utility failed to detect switch, Chrome on Windows saved the day.

 

I'm leaving more confused than I was when entering.

View solution in original post

Message 2 of 15

All Replies
MikaelN
Tutor

Re: Web firmware upgrade for GS108Ev3 failing

And an update: Managed to borrow a Windows machine. The ProSafe utility (latest version) did not even find the switch. Nice!

 

Then I tried the firmware upgrade from chrome on the windows machine, and voila, that actually worked! What on earth could be the issue?

 

So to summarize: firmware upgrade from chrome or firefox on linux failed, Prosafe utility failed to detect switch, Chrome on Windows saved the day.

 

I'm leaving more confused than I was when entering.

View solution in original post

Message 2 of 15
JohnRo
NETGEAR Employee Retired

Re: Web firmware upgrade for GS108Ev3 failing

Hello MikaelN, 

 

Welcome to the community! 

 

I understand you are having some issues updating the firmware of your GS108E. There are some factors that can cause the update to fail, like firewalls on the computer, anti-virus programs, network intterruption upon file transfer. These things might cause corruption of the firmware file upon upgrade. Here are some things that you can try if something like this happens again: 

 

1. Make sure you are using the latest version of the utility, you can download it here

2. Reset the switch to "Factory Defaults", push the factory defaults button on the right side of the switch (labelled) for 10 seconds and let it reboot. 

 

Hope it helps! I'll look forward to your update. 

 

Thanks, 

JohnRo
NETGEAR® Community Team
Message 3 of 15
MikaelN
Tutor

Re: Web firmware upgrade for GS108Ev3 failing

My issue was specifically with the web upgrade that does not work. And Factory Reset does not do anything after the device has gotten locked into this bad state. 

 

I did NOT have any luck with the latest tool version. 

Message 4 of 15
JohnRo
NETGEAR Employee Retired

Re: Web firmware upgrade for GS108Ev3 failing

Hi MikaelN, 

 

I see, kind of weird that it did not respond to factory reset. Monitor the switch and if it acts again, I would suggest to contact support in the future. 

 

Thanks, 

JohnRo
NETGEAR® Community Team
Message 5 of 15
Eaglehawk
Apprentice

Re: Web firmware upgrade for GS108Ev3 failing

I'm stuck in the same loader mode on my GSS108E right now too.

 

Factory reset doesn't do anything.

 

I haven't tried loading Chrome, but I've tried Firefox/IE/Edge on two different PCs and no luck making out of the loader mode Smiley Sad

 

The ProSafe utility sees the GSS108E but with a * and when you select it it asks for the firmware but proceeds to timeout after 30 secs.

Message 6 of 15
JohnRo
NETGEAR Employee Retired

Re: Web firmware upgrade for GS108Ev3 failing

Hi @Eaglehawk

 

Welcome to the community! 

 

Make sure you are using the latest version of the utility, download it here. Can you provide a screenshot of it when it times out? Also, I would like to know the OS of the computers you are using. 

 

Looking forward to your response. 

 

Thanks, 

JohnRo
NETGEAR® Community Team
Message 7 of 15
Eaglehawk
Apprentice

Re: Web firmware upgrade for GS108Ev3 failing

Contacted support. Remoted in. Getting a replacement GSS108E.

Message 8 of 15
lexav
Tutor

Re: Web firmware upgrade for GS108Ev3 failing

https://community.netgear.com/t5/forums/replypage/board-id/business-smart-plus-click-switches/messag...

I had exactly the same problem here with a Click GSS108E with firmware 1.0.0.0.


Problem 1: first, the switch software failed to load the new firmware from my TFTP server (my only option since I'm not using Windows). The switch doesn't receive anything although the TFTP server was working correctly (successfully tested it with a TFTP client).

Problem 2: then, whatever I try (hit cancel, turn it off, hard reset to factory defaults, etc), the switch was unable to go back from the firmware upgrade mode to its normal operating mode.

Reason: apparently, when put in upgrade mode, the switch doesn't answer to ARP request anymore. It's not a problem when the firmware file is downloaded from the same machine you used to put the switch into firmware upgrade mode via the web GUI, because in this case your ARP table already contains the switch MAC address. On the other hand, when you use another machine as your TFTP server, that new machine has to know the switch MAC address in order to send the file, and the switch never answers.

Solution to problem 1: manually add you switch MAC address in your TFTP server's ARP table.
Linux: arp -s 192.168.0.239 nn:nn:nn:nn:nn:nn
Windows : arp -s 192.168.0.239 nn-nn-nn-nn-nn-nn
(you can find the ARP address on your switch casing, something akin to A06391aabbcc)

Problem 2 has no solution AFAIK.

Message 9 of 15
lexav
Tutor

Re: Web firmware upgrade for GS108Ev3 failing

> Problem 2 has no solution AFAIK.

 

I mean, the only solution is to succeed in upgrading the firmware.

Message 10 of 15
Eaglehawk
Apprentice

Re: Web firmware upgrade for GS108Ev3 failing

That worked!

 

For the record, I had to use netsh to add the missing entry.

 

netsh interface ipv4 add neighbors "Local Area Connection" 192.168.0.239 00-24-01-d2-3a-bd

 

Substitute the IP address with what you see in ProSafe, and obviously the right MAC address to yours, and "Local Area Connection" to whatever is in your Network setup.

 

Then I ran ProSafe and it upgraded the firmware.

Message 11 of 15
gioz
Aspirant

Re: Web firmware upgrade for GS108Ev3 failing

if i use the arp command in cmd, it doesn't answer anything,

if i use the netsh command, i get "the object just exists"

 

sorry Eaglehawk, what should I put inside "Local Area Connection"?

I'm not an expert Smiley Sad

  

I don't understand also because i can't access the browser interface from any pc/browser but i can with my phone Smiley Sad

with the phone i can see the interface but it is stuck in loader mode and i can't exit that mode Smiley Sad

 

i'm going to hate netgear for that, prosafe amazing software suggested my to upgrade the firmwire and it stopped at 50% - now i have to trash this new switch Smiley Sad

Message 12 of 15
Eaglehawk
Apprentice

Re: Web firmware upgrade for GS108Ev3 failing

In Control Panel, go to "Network and Sharing Center", then click the "Change adapter settings" on the left.

 

Identify the adapter that you should be using (sorry, I can't help you here) use the name (The top line) and use that in the "Local Area Connection".

 

Alternate:

 

In a command prompt, run: ipconfig /all and use the appropriate name for your active adapter.

 

Example:

 

Ethernet adapter <the name to use>

 

or

 

Wireless LAN adapter <the name to use>

Message 13 of 15
hazeii
Aspirant

Re: Web firmware upgrade for GS108Ev3 failing

This issue got me today, so it's still happening. Basically it appears that the Netgear firmware file upload only works on certain browser/OS combinations; however once in 'firmware upload mode' there's no way out without uploading firmware (a factory reset *does not* restore the device to default operation).

 

It can get particularly complicated to sort out if the switch gets an address via DHCP on a different network to the default (e.g. 192.168.1.x), since a reboot in firmware loader mode appears to result in it defaulting back to 192.168.0.239 and *not using DHCP* - giving the appearance of the firmware update having 'bricked' the device.

 

As others have noted, the fix is to use a Windows box with Chrome, and configuring networking as necessary to access the switch using 192.168.0.239.

 

Model: GS108Ev3|ProSAFE 8-port Gigabit Plus Switch
Message 14 of 15
eugirdor
Aspirant

Re: Web firmware upgrade for GS108Ev3 failing

First, thanks to those who were troubleshooting this before as it helped resolve my issue

 

Note: For systems with multiple interfaces or if you have renamed the interface

* Run this from a command prompt with administrator access

netsh interface ipv4 show addresses

* Find the interface with the appropriate network range for your switch (copy the portion after "Configuration for interface")

* Run this command with the name of the interface

netsh interface ipv4 add neighbors "<insert network interface name here>" "<insert switch mac address here>"

Example: netsh interface ipv4 add neighbors "LAN1" "192.168.2.40" "a0-63-91-bb-bb-bb"

 

 

 

Model: GSS108E|ProSAFE 8-port Gigabit Click Switch
Message 15 of 15
Discussion stats
  • 14 replies
  • 22347 views
  • 11 kudos
  • 7 in conversation
Announcements