× The readycloud.netgear.com login issue with the Chrome browser is now fixed. We are actively working on resolving a similar issue with the Safari browser and recommend you use an alternate browser until this error has been resolved.

Reply

Enable SMB 2 on ReadyNas x86 v4.2.31

jgrimm
Aspirant

Enable SMB 2 on ReadyNas x86 v4.2.31

Is it possible to enable SMB 2 on legacy ReadyNas devices running SAMBA 3.6?

Model: RNDU6000 (ReadyNAS Ultra 6)|READYNAS ULTRA 6 (DISKLESS)|EOL
Message 1 of 10

Accepted Solutions
StephenB
Guru

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

If your Windows version gives you a free NFS client, you could also potentially switch to that: https://community.netgear.com/t5/Using-your-ReadyNAS/No-access-to-shares-after-disabling-SMB1-as-rec... Then disable SMB altogether. 

 

You could also try adding the following lines to the [global] section of the /etc/samba/smb.conf file and rebooting the NAS:

min protocol = SMB2

max protocol = SMB2

 

SMB2 support is only "experimental" in your version of SAMBA, so you might run into issues.

 

OR, convert your ultra to run OS 6, and that will give you SMB3 support.

 

View solution in original post

Message 4 of 10

All Replies
mdgm-ntgr
NETGEAR Employee Retired

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

The SMB2 support in Samba 3.6 is experimental, but you can enable it via SSH.

 

I would stick with SMB1 on it.

Message 2 of 10
jgrimm
Aspirant

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

So I have two options:
Go against Microsoft's advice and enable SMB1 on my PC
OR
Go against Netgear's advice and enable SMB2 on my NAS

 

Which option would you recommend?

 

If I want to take my chance with SMB2 on my NAS (as I'm just using it as a backup duplication repository), how I do I enable it via SSH?

 

Thanks.

 

Message 3 of 10
StephenB
Guru

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

If your Windows version gives you a free NFS client, you could also potentially switch to that: https://community.netgear.com/t5/Using-your-ReadyNAS/No-access-to-shares-after-disabling-SMB1-as-rec... Then disable SMB altogether. 

 

You could also try adding the following lines to the [global] section of the /etc/samba/smb.conf file and rebooting the NAS:

min protocol = SMB2

max protocol = SMB2

 

SMB2 support is only "experimental" in your version of SAMBA, so you might run into issues.

 

OR, convert your ultra to run OS 6, and that will give you SMB3 support.

 

View solution in original post

Message 4 of 10
Mickoz
Aspirant

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

Is there a guide on how I would convert to OS 6 from RAIDiator 4.2.31?

Model: ReadyNAS RNDP600U|ReadyNAS Ultra 6 Plus Chassis only
Message 5 of 10
bedlam1
Prodigy

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

 This THREAD covers it and applies to not just an Ultra 6, but read it all and not just the solution, there is information about checking/upgrading Bios which should be done in OS 4

Message 6 of 10
Mickoz
Aspirant

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

Thanks.  I've already upgraded to OS6.  Completely missed the BIOS step, hopefully it doesn't cause any lsting issues.

Do you know if you can still update the BIOS from OS6?

Message 7 of 10
bedlam1
Prodigy

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

No I don't, I suppose you could go back to OS 4.2 to do it then install OS6 again Smiley Sad

Message 8 of 10
mdgm-ntgr
NETGEAR Employee Retired

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

I think the BIOS update for the Ultra 6 was to address a WoL issue. If you're not planning on using that I wouldn't worry about whether the BIOS is out of date or not.

Message 9 of 10
Mickoz
Aspirant

Re: Enable SMB 2 on ReadyNas x86 v4.2.31

Thanks Team,

Its working for now and I must say it looks much nicer than the clunky old interface.  I have not been able to install Plex yet, perhaps I need a reboot.

 

Sorry I didn't find the original thread Smiley Happy

Message 10 of 10
Discussion stats
  • 9 replies
  • 35674 views
  • 3 kudos
  • 5 in conversation
Announcements