× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Have to change LanMan setting to access shares on Win8 & 10

randomnut1
Apprentice

Have to change LanMan setting to access shares on Win8 & 10

Hi,
I have an issue that has been bugging me for a while now. I have a rn104 with the latest OS6 updates on it.

Whenever I build or rebuild a machine, whether on Windows 8.1 or 10, at default settings it cannot access the shares. If I go to \\nas then it keeps prompting for username and password and never gets in.

The fix is to open Secpol, and change the setting Network Security: Lan Manager Authentication Level to Send LM & NTLM, use NTLMv2 session security if negotiated

Once I change that, I can go \\nas , enter username and view the shares normally.

My question is why is this happening? Is there a misconfiguration on the Readynas I can change so these shares just work on a new build without having to change that setting?

thanks
Message 1 of 8
mdgm-ntgr
NETGEAR Employee Retired

Re: Have to change LanMan setting to access shares on Win8 &

Can you provide more detailed steps to reproduce this and some info on your environment?

We haven't seen this issue.

I recently tested running Windows 10 in a VM and connected to an OS6 NAS fine first time.
Message 2 of 8
randomnut1
Apprentice

Re: Have to change LanMan setting to access shares on Win8 &

What in particular would you need?

I don't have anything configured particularly differently. The 104 is connected straight to my netgear r7000 and is not on a domain. OS version is 6.2.4

The issue happens on fresh builds of windows 8.1 or 10 with no special configuration. Just going to \\nasname brings up a username and password box and no credentials work, it just keeps requesting credentials and eventually bombs out.

The share security is set up so 'everyone' has read/write access.

I then have to change that LanMan setting in order to access the shares
Message 3 of 8
StephenB
Guru

Re: Have to change LanMan setting to access shares on Win8 &

What was the setting before you changed it?

My Win7 systems have it set to "Send NTLMv2 response only, refuse LM", which works fine with OS6.
Message 4 of 8
randomnut1
Apprentice

Re: Have to change LanMan setting to access shares on Win8 &

It would have been whatever the bog standard setting in Win8.1 and 10 is, as i'd not deliberately changed it and it happens on fresh builds. These are standalone machines so not like there is a group policy applying to change it to something incompatible.
Message 5 of 8
StephenB
Guru

Re: Have to change LanMan setting to access shares on Win8 &

Did you try "Send NTLMv2 response only, refuse LM"?
Message 6 of 8
randomnut1
Apprentice

Re: Have to change LanMan setting to access shares on Win8 &

I will try it, but my issue really Is why a default standard Win 8 or 10 installation cannot access these shares. Whether I change it to refuse LM or not if that's not the default setting then there must be some misconfiguration on the Nas causing it?

I should point out also that my win 7 machines never had this issue.
Message 7 of 8
StephenB
Guru

Re: Have to change LanMan setting to access shares on Win8 &

I suspect your win 7 machines are using the setting I am suggesting that you try.

I agree that it is best if users don't need to be editing the Windows registry. But if it must be changed for some reason you should aim for the highest security that works, not the lowest.
Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 2764 views
  • 0 kudos
  • 3 in conversation
Announcements