× NETGEAR will be terminating ReadyCLOUD service by April 1st, 2023. For more details click here.
Reply

Mount shared ReadyNAS folder on Ubuntu

markdf001
Aspirant

Mount shared ReadyNAS folder on Ubuntu

Hi! I am having a problem trying to mount an NFS shared folder on Ubuntu 20.04. I have followed the instructions here, as well as several other sites with similiar instructions.

 

The readyNAS 104 has a shared folder 'Videos' with SMB enable and read/write access for all users.

mount -t nfs 192.168.20.251:/data/Videos share

(note the 'share' folder does exist)

and I get

mount.nfs: Operation not permitted

Ive no idea whats going on, its been a couple of days and I just cant work it out.

 

 

Model: ReadyNAS-OS6|
Message 1 of 16
Sandshark
Sensei

Re: Mount shared ReadyNAS folder on Ubuntu

OK, you say the share is SMB, but you are attempting to mount it via NFS.  Those are two different protocols.  You either have to enable NFS (and the whole NAS, if it's not already on) and set NFS access rights for the share or mount it on the remote system using SMB.  

Message 2 of 16
schumaku
Guru

Re: Mount shared ReadyNAS folder on Ubuntu

Use SMB only. Combining things with NFS is a much to complex plan.

Message 3 of 16
markdf001
Aspirant

Re: Mount shared ReadyNAS folder on Ubuntu

Thanks, I'm almost there! 

sudo mount -t cifs -o username=plex //192.168.20.251 /mnt/local_share

I get 'Password for plex@//192.168.20.251: (press TAB for no echo)"

The user 'plex' has a password of 'plex' but it doesnt work, or the admin password. I must be be missing something basic and very obvious.

 

regards,

 

Mark...

Message 4 of 16
schumaku
Guru

Re: Mount shared ReadyNAS folder on Ubuntu

The shared folder on the NAS (configured for the access for the plex user [or a group including plex]) you want to access from the Ubuntu system isn't there.

 

The access management is based on shared folders, you can't mount the root.

Message 5 of 16
markdf001
Aspirant

Re: Mount shared ReadyNAS folder on Ubuntu

I guess I need to setup a user on ubunto, I'll research that tomorrow as its to late now to concentrate on this 🙂

 

 

Message 6 of 16
Sandshark
Sensei

Re: Mount shared ReadyNAS folder on Ubuntu

If you are going to use SMB, you need a shared folder and user with access to it on the NAS.  That user doesn't need to be the same user as on your Ubuntu system.  You could use the NAS admin user, but that's not usually a good idea.

 

You mount an NFS share without a user name or password.  But you do also need to mount a specific share.  You had the command right in your orignal message, I just don't think you had NFS enabled on the NAS and/or share.  If you expect to do it a lot, you may want to put something in fstab instead.

 

I'm not sure why @schumaku says NFS is too complex.  Certainly not as secure, but actually less difficult than SMB IMHO (at least with a Linux client).  And I prefer to use a native Linux file system for sharing with a Linux system.  The NAS does the "hard part" for you, exporting the NFS share when you set up NFS via the GUI. 

Message 7 of 16
schumaku
Guru

Re: Mount shared ReadyNAS folder on Ubuntu


@Sandshark wrote:

I'm not sure why @schumaku says NFS is too complex.  Certainly not as secure, but actually less difficult than SMB IMHO (at least with a Linux client).

NFS on it's own might be K.I.S.S. but never correct.

How do you suggest to make things correctly matching between (UID, GID; usernames, groups, ... between average consumer Linux setup and last but not least the very different access rights in place by ACLs for SAMBA? And finally not end in a mess....

 

In a mixed environment, SMB is the way to go. In a fully managed Linux or U**x environment (all NFS clients and NFS servers in perfect sync) ideally with LDAP or better no doubt NFS is great.

 

For the average user with various U**x-like workstations SMB is again much easier. Linux desktop environments allow wirking on the network as easy as on a Windows system. You manage the NAS, and you have everything right.

Message 8 of 16
markdf001
Aspirant

Re: Mount shared ReadyNAS folder on Ubuntu

I still cant get it working, I have created a user from https://www.techrepublic.com/article/how-to-add-and-enable-users-for-samba-share/

 

The password for the user is not being accepted, Ive attached a screen capture.

 

I appreciate the suggestions.

 

Message 9 of 16
markdf001
Aspirant

Re: Mount shared ReadyNAS folder on Ubuntu

I have  also added the following to /etc/samba/smb.conf

[share1]
   comment = A Shared Directory
   guest ok = Yes
   path = /share
   read only = No
   valid users = mark


linus user is mark, password is mark

Message 10 of 16
StephenB
Guru

Re: Mount shared ReadyNAS folder on Ubuntu


@markdf001 wrote:

I have  also added the following to /etc/samba/smb.conf

[share1]
   comment = A Shared Directory
   guest ok = Yes
   path = /share
   read only = No
   valid users = mark


linus user is mark, password is mark


Not a good idea, as the ReadyNAS will overwrite those changes.  Always configure shares using the NAS admin web ui.  And they aren't not needed anyway.  Your problem isn't on the NAS, it's the commands you are using on the ubuntu system.

 

One problem is that you are putting a space between the IP address and the /share.  You don't do that.

 

Did you create the mark account on the NAS (using the NAS web ui)?

 

Message 11 of 16
schumaku
Guru

Re: Mount shared ReadyNAS folder on Ubuntu

All you need is a mount point folder on your Linux instance, a shared folder configured on the NAS, the user account on the NAS, and the access granted.


# sudo mkdir /mnt/Plex

# sudo mount -v -t cifs -o username=demo,vers=3.0 //rn516/Video /mnt/Plex
Password for @demo//rn516/Video: *****
mount.cifs kernel mount options: ip=[whatever],unc=\\rn516\Video,vers=3.0,pass=********

#

 

Note:

  • mount point must exist (mkdir ...)
  • only a shared folder can be mounted, not the share root, thus //rn516/Video here
  • specify the highest SMB version supported

 

As the cifs mounter is dumb (sorry Linux friends - Windows is decades ahead in many aspects) you might have to tell the SMB protocol version because your NAS might have been stripped to allow SMB 1.0 .. and just -t cifs would try SMB 1.0 only.

Message 12 of 16
markdf001
Aspirant

Re: Mount shared ReadyNAS folder on Ubuntu

I appreciate the help but still struggling with it

 

I removed the Share entry I created in /etc/samba/smb.conf

user 'mark' created on ReadyNAS 104
user 'mark' created on linux
mount folder on linux called 'share'
ReadyNAS 104 supports SMB v3

sudo mount -v -t cifs -o username=mark,vers=3.0 //192.168.20.251/Video /share

Password for mark@//192.168.20.251/Video: (press TAB for no echo)

I enter the password and get

mount error(1): Operation not permitted

 

Message 13 of 16
schumaku
Guru

Re: Mount shared ReadyNAS folder on Ubuntu

Looks to me as there is an issue will the the configuration of your container. With plain Linux on common distros on bare metal or VMs this does work flawless.
Message 14 of 16
StephenB
Guru

Re: Mount shared ReadyNAS folder on Ubuntu


@markdf001 wrote:

sudo mount -v -t cifs -o username=mark,vers=3.0 //192.168.20.251/Video /share

 


I agree that this should work if mark has network access to the NAS Video share.

 

Perhaps try again with username=admin and use the admin password for the NAS - just to rule out a network access problem.

 

Have you looked in the ubuntu logs?  There likely is more information there.

 

You could also try downloading the full NAS log zip file (from the admin logs page) and see if there are any errors in there.  Not sure exactly where to look, but I'd take a look at dmesg.log, system.log, and kernel.log  

 

 

Message 15 of 16
markdf001
Aspirant

Re: Mount shared ReadyNAS folder on Ubuntu

Thanks to everyone for the help, but due to work I havent been able to get back to this. Hopefully in the next day or two after work I'll have the time.

Message 16 of 16
Top Contributors
Discussion stats
  • 15 replies
  • 3051 views
  • 8 kudos
  • 4 in conversation
Announcements