× NETGEAR will be terminating ReadyCLOUD service by April 1st, 2023. For more details click here.
Reply

RN102 - External USB drive keeps disconnecting after upgrade to 6.9 firmware

bheinz874
Aspirant

RN102 - External USB drive keeps disconnecting after upgrade to 6.9 firmware

I have a 3TB external USB drive connected to my RN102 with 2x2TB drives installed. Since upgrading to 6.9 firmware, the external USB drive keeps disconnecting within a few minutes, and won't reconnect unless I reboot the RN102, and even then only stays connected for a few minutes until it shows as disconnected again. I've tried reformatting the USB drive, and confirmed it works with other devices (MacBook, PC, etc.) with no issues.

Model: RN10211D|ReadyNAS 100 Series 2-Bay
Message 1 of 4
StephenB
Guru

Re: RN102 - External USB drive keeps disconnecting after upgrade to 6.9 firmware

There are some network fixes in 6.9.1 - but those should have affected your internal volume too.

 

Still, it might be worth a try.  The manual upload link is here: https://kb.netgear.com/000051531/ReadyNAS-OS-6-Software-Version-6-9-1

Message 2 of 4
bheinz874
Aspirant

Re: RN102 - External USB drive keeps disconnecting after upgrade to 6.9 firmware

That doesn't seem to help. The drive disconnects after 5 minutes. Any chance I can safely roll back to 6.8.1?

Message 3 of 4
StephenB
Guru

Re: RN102 - External USB drive keeps disconnecting after upgrade to 6.9 firmware

Netgear doesn't recommend it, but I've seen a few posts from folks here who downgraded without problems.

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 467 views
  • 0 kudos
  • 2 in conversation
Announcements