× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973

iDrive on ReadyNAS update


iDrive on ReadyNAS update

4 yeras ago I reviewed iDrive on ReadyNAS, review found here: https://community.netgear.com/t5/Using-your-ReadyNAS-in-Business/iDrive-readynas-review/td-p/1373059 


I am unable to update that thread now, so will provide a 2021 update here.


I did not end up using iDrive for backing up my ReadyNAS since 2017, due to various concerns at that time.  I am today switching from CrashPlan to iDrive for ReadyNAS and will say that I now consider it the superior alternative.  CrashPlan is a really great solution, but Code42 has made it somewhat difficult to get CrashPlan working on a readynas.  I kept it going for as long as I could, even using docker, but then even docker broke with a ReadyNAS OS udpate.  I could probably fix docker but I'm rather tired of messing around with keeping Crashplan working.  


Which brings me to the other mainstream service that can run natively on ReadyNAS, which is iDrive.  I can see that Code42 addressed some of the issues that pointed out in my 2017 review.  This is good news..  Keeping it short and sweet, here are the pros and cons of iDrive to backup ReadyNAS




  1. VERY easy to install onto ReadyNAS and it just works.  The linux implementation of iDrive is a command line scripted solution which basically works on pretty much all linux, including ReadyNAS OS.   iDrive has a web based GUI which you access over the internet and it is able to communicate back to your ReadyNAS from the web and control it.  So you get a GUI if you want or you can run it purely from script.  No special docker or other werid stuff to get it working.  Very easy.

  2. iDrive provides a mail-in option, Its FREE once per year for personal users, to have them mail you a USB drive, you backup to the USB drive and then send it back to them (they cover the shipping cost too).  Then they will upload the data to your account from that USB drive.  I will be able to see my iDrive account with 5T+ of initial backup data from my ReadyNAS in about a week of waiting, vs at least 2 months to upload it over the internet.

  3. Backup some other machines also on the same monthly fee.

  4. Very affordable, the first two years especially as they usually have a 50% discount for first two years, which works out to $5/month for up to 10TB.  



  1. Their upload bandwidth is not that great.  Neither are most other backup services.  

  2. iDrive does not save user and file permissions with files that are backed up!  This actually makes it entirely unsuitable for completely backing up any particular machine, but especially MacOS and Linux machines, it would not be possible, for example, to correctly backup your /etc dir with iDrive.  You could back it up anyway and also backup a text file showing the permissions in an ls  listing so that worst case scenario you could manually restore /etc and set the permissions.  Its better to just think of iDrive as a way to backup other large masses of important irreeplacable files such as photos and other documents which for the most part all have yourself as the user and full permissions in general.  But be advised if you have to restore anything from iDrive, the file and user permissions will be changed in the recovery because they are not part of the backup

  3. Unlike CrashPlan, iDrive does not do any de-duplication.  This can lead to using more actual space for backing up the same stuff, especially over time.  CrashPlan not only does de-duplication but also has unlimited amount of space.  So anyway, just be advised with idrive you will need to do some archive cleanup sometimes, perhaps, or be careful not to store duplicate copies of the same large files.

  4. In the past I had pretty significant CPU hit while running iDrive on ReadyNAS.  However I later remedied this by using "nice" on the script versions of iDrive.  I plan to do that this time too, haven't tested this yet to find out, but something to watch out for.  I think its resolvable.  Anyway, I'm tired of Crashplan simply not working anymore since it is simply not supported officially on ReadyNAS, while is, so I will deal with this.



Message 1 of 4

Re: iDrive on ReadyNAS update

Sorry to bring up this old thread but in case anyone still want to install the iDrive app on a Readynas in 2023 (mine is RN104 on firmware 6.10.8) and run into issue, hopefully this would help, since the Debian Jessie dist is no longer available.   I know there are other threads mentioning about updating the apt sources, but here's the more specific steps I took to make it work somehow.  I don’t know if it’s the proper way but it worked for me.


Initially, I followed the instructions at iDrive website to download the .deb file specific for RN104 (version 2.00.02), uploaded the file on the readynas web gui and tried to install as instructed.  However, it failed with error "System: Cannot install application idrive."   I also tried installing the default iDrive app that was showing on the Available Apps list (version 1.00.x) and it failed with the same error.


Without additional log info, I tried uploading the deb file with scp and access the shell with ssh.  Tried installing the deb file with dpkg, but it failed with dependency issue with missing sudo, despite I’m installing as root user.  Long story short after trying quite a few things, this is what I did to install the idrive app.  It may not be the proper way or may compromise your device, so do it at your own risks.


  1. Edit /etc/apt/sources.list
  • Commented out several sources that no longer work, and added the archive sources for jessie dist, as below:


deb https://apt.readynas.com/packages/readynasos 6.10.8 updates apps main

#deb http://mirrors.kernel.org/debian jessie main

#deb http://security.debian.org/ jessie/updates main

#deb http://ftp.us.debian.org/debian/ jessie-updates main

deb http://archive.debian.org/debian/ jessie main

deb http://archive.debian.org/deian-security/ jessie/updates main


2. Run:  apt-get --allow-unauthenticated -o Acquire::CompressionTypes::Order::=gz update

  • Did this because apt-get update complained about the lack of the Release file and then it’s unauthenticated.  Also I only see bz2 and gz package file on the archive site, so I force it to use one of those compression on the command line.
  • Part of the output message for reference:

W: The repository 'http://archive.debian.org/debian jessie Release' is not signed.

N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.

N: See apt-secure(8) manpage for repository creation and user configuration details.

E: Failed to fetch http://archive.debian.org/deian-security/dists/jessie/updates/main/binary-armel/Packages  404  Not Found [IP: x.y.z.w 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.


3. Run from where you stored your idrive .deb file:

dpkg -i idrive_armel.deb


  • It complained about missing sudo command (even if ran as root), output for reference:

dpkg: dependency problems prevent configuration of idrive:

 idrive depends on sudo; however:

  Package sudo is not installed.

dpkg: error processing package idrive (--install):

 dependency problems - leaving unconfigured

Errors were encountered while processing:  Idrive


4. Run the following to fix the dependencies issue: apt-get install -f

  • If the above source list update was working for you, then you may see similar output

The following additional packages will be installed:  sudo

The following NEW packages will be installed:  sudo

0 upgraded, 1 newly installed, 0 to remove and 19 not upgraded.

1 not fully installed or removed.

Need to get 829 kB of archives.

After this operation, 2,357 kB of additional disk space will be used.

Do you want to continue? [Y/n]

WARNING: The following packages cannot be authenticated!   sudo

Install these packages without verification? [y/N] y

Get:1 http://archive.debian.org/debian jessie/main armel sudo armel 1.8.10p3-1+deb8u5 [829 kB]

Fetched 829 kB in 1s (601 kB/s)

debconf: delaying package configuration, since apt-utils is not installed

Selecting previously unselected package sudo.

dpkg: warning: files list file for package 'libclamav9:armel' missing; assuming package has no files currently installed

(Reading database ... 25204 files and directories currently installed.)

Preparing to unpack .../sudo_1.8.10p3-1+deb8u5_armel.deb ...

Unpacking sudo (1.8.10p3-1+deb8u5) ...

Processing triggers for systemd (230-7~bpo8+2.netgear3) ...

Setting up sudo (1.8.10p3-1+deb8u5) ...


5. After this, you should see the iDrive app on the Installed Apps list on the Readynas web gui.  You may launch from the button and it should show you the login at http://your_nas_ip:7085/IDrive


6. After auth with the local readynas and then the iDrive auth, I was able to perform backup, etc. as intended.


7. If the above fails, perhaps retry step 3 and 4 again, and recheck step 1 and 2 were done properly.

Message 2 of 4

Re: iDrive on ReadyNAS update

So I just want to say that I went through all this a couple years ago, see my original post.  Initially I also did a lot of stuff like you did to install the so called ReadyNAS version of iDrive.  Eventually I had some problems with it, I don't remember what, and I interacted with tech support at idrive and found out about the command line version of iDrive...which is actually completely full featured, but done in a more linux neutral way.  It also includes a web based GUI to configure it....so you really won't be lacking anything.  I highly recommend you consider using that command line version of it.  It's monumentally easier to setup..  Some of the things you did with APT are a bit risky to do on a readynas quite frankly.  I'm glad you have it working though.  Hope that all goes well for you!


The good news is that I have been using iDrive on this ReadyNas for a couple years now and it's working every day quite fine and well.  I seem to recall I somehow sent my hard drive to iDrive at first for them to do a fast initial backup but right now I'm not sure how I did that since I'm using RAID.  I might have had to copy all the stuff I wanted backed up to a USB drive in order to send to them or something like that.  But i saved MONTHS of initial backup time.  Now my nightly backups take only a few minutes or occasionally a few hours.


Message 3 of 4

Re: iDrive on ReadyNAS update

@stickywire wrote:


Without additional log info, I tried uploading the deb file with scp and access the shell with ssh.  Tried installing the deb file with dpkg, but it failed with dependency issue with missing sudo, despite I’m installing as root user.  Long story short after trying quite a few things, this is what I did to install the idrive app.  It may not be the proper way or may compromise your device, so do it at your own risks.


There is a long thread here that includes similar changes to the source list.

Note you can create a conf file to eliminate the need for --allow-unauthenticated.


Post 37 in the thread above has dropbox links to the two files.

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 0 kudos
  • 3 in conversation