Reply

EX7000 (AC1600) Not working properly. Keeps disconnecting and reconnecting

tristiano124
Aspirant

EX7000 (AC1600) Not working properly. Keeps disconnecting and reconnecting

My Netgear EX7000 (AC1600) was working perfectly this morning (November 6, 2018), and all of a sudden stopped working in the early afternoon. I called Netgear customer service, and the guy on the other end of the phone, I think his name was Adam, said it was a problem with my IP address and it would cost $150 to fix. I'm not paying $150 for some guy to mess around with my network, I don't know what is going on, not to mention it's not worth $150. I digress, I used Windows troubleshooter and that managed to fix the problem for a little while, but now my computer keeps switching from a good connection, to limited, and no connection at all. Please help, I need my internet for work and this is unacceptable. Thank you.

Model: EX7000|AC1900 WiFi Range Extender
Message 1 of 6
tristiano124
Aspirant

Re: EX7000 (AC1600) Not working properly. Keeps disconnecting and reconnecting

Side note- All the LED's on the router are lit up as usual, but the 5Ghz one. My PC is connected to ethernet port 1, that is green, the 5Ghz wifi symbol is red, but it also turns orange, the 2.4Ghz LED is green, and the NETGEAR LED is white. Thanks again.

Model: EX7000|AC1900 WiFi Range Extender
Message 2 of 6
DexterJB
NETGEAR Moderator

Re: EX7000 (AC1600) Not working properly. Keeps disconnecting and reconnecting

Hi @tristiano124,

 

Welcome to the community!

 

1. Have you tried bringing the extender closer to the router?

2. What is the firmware version of the extender?

3. Does the issue persist with your other devices that connect to the extender?

 

Regards,

 

Dexter

Community Team

Message 3 of 6
tristiano124
Aspirant

Re: EX7000 (AC1600) Not working properly. Keeps disconnecting and reconnecting

@DexterJB thanks for your reply. Unfortunately, I can't move the extender closer to the router, as my main desktop PC is connected to it via an ethernet cable. Secondly, and sorry if I didn't mention this in my initial post, but I can connect devices to the extenter's 2.4Ghz signal, but I get a limited connection. Also, I'm not sure what firmware version the extender is running, and I don't know how to check, but if an update would get me back up and running that would be awesome.

Model: EX7000|AC1900 WiFi Range Extender
Message 4 of 6
StephenB
Guru

Re: EX7000 (AC1600) Not working properly. Keeps disconnecting and reconnecting


@tristiano124 wrote:

Also, I'm not sure what firmware version the extender is running, and I don't know how to check,

Browse to mywifiext.net from a device connected to the extender network.

 

Let us know the firmware version - but I don't recommend updating it to the current firmware.  There are lots of issues reported with 1.0.1.78.  If you are running something older than 1.0.0.66, then you could try updating it to that.

Message 5 of 6
flyturbo
Apprentice

Re: EX7000 (AC1600) Not working properly. Keeps disconnecting and reconnecting

Same problems with EX8000 and the latest firmware V1.0.1.186 doesm't solve any issues.

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 1333 views
  • 0 kudos
  • 4 in conversation
Announcements