Orbi WiFi 7 RBE973
Reply

Slow speeds with C7000V2

MAYDAYTAY
Tutor

Slow speeds with C7000V2

Hello,

        I am using a C7000v2 – Nighthawk AC1900 WiFi Cable Modem Router on Firmware V1.03.03 with windows and I am not getting the correct download speeds. I tried looking through a lot of threads and found similar issues, but nothing has worked for me and I do not know what to do. I pay for gigabit with Sparklight (Cable One) and I am only getting 90mb download lan. At one point I was getting around 800mbs on lan but not anymore. If someone could help me I would appreciate it!

Model: C7000|Nighthawk - AC1900 WiFi Cable Modem Router
Message 1 of 10
plemans
Guru

Re: Slow speeds with C7000V2

what device (computer/pc) are you testing with? 

Have you checked your port statistics to see if you're connecting at gigabit speeds?

https://kb.netgear.com/24222/How-do-I-display-Internet-port-statistics-on-my-Nighthawk-router

 

Do you have a screensnip of the cable connections page and event logs? 

Message 2 of 10
MAYDAYTAY
Tutor

Re: Slow speeds with C7000V2

Is this what you need? I am using the Genie. Not sure where event logs or cable connections are. Let me know if you can see the picture or not. And I am using a desktop PC

Message 3 of 10
plemans
Guru

Re: Slow speeds with C7000V2

Looks like your desktop is only connected at 10/100mbps speed and not gigabit. 

If the pc is gigabit capable, try replacing the cable between the router/pc with a cat 6 cable. 

 

Message 4 of 10
MAYDAYTAY
Tutor

Re: Slow speeds with C7000V2

I had a sparklight guy come out today to test the connection and he was also getting slow speeds with his device from the router. 

This is the current cable I am using. https://www.amazon.com/gp/product/B07QFDY7YC/ref=ppx_yo_dt_b_asin_title_o08_s00?ie=UTF8&th=1

Message 5 of 10
MAYDAYTAY
Tutor

Re: Slow speeds with C7000V2

I found the event log. Want a screen shot of it?

Message 6 of 10
plemans
Guru

Re: Slow speeds with C7000V2

Your port statistics page is showing a connection speed of 100mbps. 

If its not negotiating a gigabit connection, then you're not going to get faster speeds. 
it could be the cable (which is why I said try a different one), it could be device you're testing with. 

All I know 100%, is that your ethernet connection is only 100mbps. 

That's going to limit your speed. 

 

Message 7 of 10
plemans
Guru

Re: Slow speeds with C7000V2

Also, your 2.4ghz speeds are set at 54mbps. did you disable wmm or using an older wifi standard? Or did you set the speeds on it down?
Message 8 of 10
MAYDAYTAY
Tutor

Re: Slow speeds with C7000V2

I turned on extended upstream transmit power to see what it would be and it appears to have fixed the issue for now.

Message 9 of 10
baisanchez
Aspirant

Re: Slow speeds with C7000V2

how do you turn on extended upstream transmit power
Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 3408 views
  • 2 kudos
  • 3 in conversation
Announcements

Orbi WiFi 7