Discussion stats
  • 7 replies
  • 411 views
  • 3 kudos
  • 3 in conversation
Announcements

Top Contributors
Reply
Highlighted

CM500 Cable Modem Creating Double NAT

Setup: CM500-100NAS on Firmware v1.01.05 Cable Modem

Ethernet out to eero Gateway wireless router

Xbox One five feet from router, connected wirelessly

 

For a couple weeks, I've shown a strict NAT on the xbox, which affects some of the games I play (peer to peer connections). The xbox states UPnP not successful. I worked with eero support and nothing worked to fix it, not even portforwarding everything for the xbox. 

Their tech support ran a diagnostic and said I have a double NAT, and it's not the eero, but my other router (implying I used a modem/router combo, which I do not). 

For my own research, I switched to an old wireless router (Netgear WNDR3400v2) and got the same proble with a strict NAT. This time the Xbox stated "double NAT detected." 

 

To my understanding, a double NAT would mean I have NAT happening on the modem as well as the router. But, my modem is not a router and has no network translating options baked into the settings. There are no other routers or swtiches on the network. It's modem to wireless router to device. 

 

Anyone have ideas as to what is going on? I'm wondering if it's something jacked up on the ISP side. 

 

 

 

 

Model: CM500|16x4 DOCSIS 3.0 Cable Modem
Message 1 of 8

Accepted Solutions
Highlighted
Sensei

Re: CM500 Cable Modem Creating Double NAT

> [...] a double NAT would mean I have NAT happening on the modem as
> well as the router. [...]

 

   Well, somewhere, but a modem can't do it.  Another possibility:

 

      https://en.wikipedia.org/wiki/Carrier-grade_NAT

 

> [...] I'm wondering if it's something jacked up on the ISP side.

 

   Carrier-grade NAT would qualify.

 

   Have you looked at the IP address of the WAN/Internet interface on
your router?  Plug that address into the form at:
https://whois.arin.net/ .  Is it a public address or a private address?

View solution in original post

Message 4 of 8

All Replies
Highlighted
Guru

Re: CM500 Cable Modem Creating Double NAT

What happens if you directly connect the xbox to the modem, with out any router in the middle? 

 

Press and hold the front power button on the xbox until it turns off then release. Then turn it back on. 

You might also try changing ports manually on the xbox as well, see the xbox networking get into a bad state. Change to something else in the xbox drop down menu under advanced settings under networking. 


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.15.32(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 2 of 8
Highlighted

Re: CM500 Cable Modem Creating Double NAT

Thanks for the suggestion.
When I directly connect the Xbox to the Ethernet out from the modem, it still has a strict NAT. In detailed network statistics on the Xbox, it says my network is behind a port-symmetric NAT.

And that’s direct from the modem.
Message 3 of 8
Highlighted
Sensei

Re: CM500 Cable Modem Creating Double NAT

> [...] a double NAT would mean I have NAT happening on the modem as
> well as the router. [...]

 

   Well, somewhere, but a modem can't do it.  Another possibility:

 

      https://en.wikipedia.org/wiki/Carrier-grade_NAT

 

> [...] I'm wondering if it's something jacked up on the ISP side.

 

   Carrier-grade NAT would qualify.

 

   Have you looked at the IP address of the WAN/Internet interface on
your router?  Plug that address into the form at:
https://whois.arin.net/ .  Is it a public address or a private address?

View solution in original post

Message 4 of 8
Highlighted

Re: CM500 Cable Modem Creating Double NAT

That’s really helpful. Everything seems to point to a carrier-grade NAT system.

Using whatsmyip.org and Whois, my ip from my ISP is not the same as the ip on my router.

Looks like I’m up the creek.
Message 5 of 8
Highlighted
Guru

Re: CM500 Cable Modem Creating Double NAT

Power OFF the modem for 1 minute then back on.

Press and hold the front power button on the xbox until it turns off then release. Then turn it back on. 

You might also try changing ports manually on the xbox as well, see the xbox networking get into a bad state. Change to something else in the xbox drop down menu under advanced settings under networking. I have done this a few times then got OPEN NAT after the change.

 

IF this doesn't change anything, I would check with the ISP to see if anything is happening there. Possible xbox service issue as well though I doubt it, 


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.15.32(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 6 of 8
Highlighted

Re: CM500 Cable Modem Creating Double NAT

Final update. With the knowledge I got here, I worked with the ISP. They confirmed they use a network NAT and they needed to “open the NAT” for me. I pieced together they had done upgrades on the area which may have defaulted a previous passthrough.

After they pushed a fix, I had a moderate NAT and I could then port forward the Xbox ports to get an open NAT.

Thanks for the advice!
Message 7 of 8
Highlighted
Guru

Re: CM500 Cable Modem Creating Double NAT

Glad you figured it out and got it working better. 

Enjoy. 


@inky_thoughts wrote:
Final update. With the knowledge I got here, I worked with the ISP. They confirmed they use a network NAT and they needed to “open the NAT” for me. I pieced together they had done upgrades on the area which may have defaulted a previous passthrough.

After they pushed a fix, I had a moderate NAT and I could then port forward the Xbox ports to get an open NAT.

Thanks for the advice!

 


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.15.32(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 8 of 8