Reply

DG834G v2 - firmware update failed, recovery tool doesn't work

jsp_1983
Aspirant

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

Any further ideas at all?

Is the recovery tool the ONLY way of getting the firmware on to the router?
Message 26 of 36
jsp_1983
Aspirant

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

Okay, by connecting the router via ethernet, I can see from ipconfig that the router now has an address of 169.254.71.116 and any attempt to ping another address shows that the router is acknowledging the request, so the router is alive in some form... Is it possible to talk to the router from the command prompt somehow?
Message 27 of 36
jsp_1983
Aspirant

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

^ Ignore that last post... I mixed up the gateway IP with my NIC's automatically-assigned IP.
Message 28 of 36
stevebaker
Aspirant

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

Thanks for the clever words on this forum - I'd like to add my experiences. I attempted to upgrade my 3.01.31 firmware to 3.01.38. During the process the upgrade failed, leaving the router with power and check light blinking alternately.

I downloaded the router upgrade recovery tool but it crashes Vista with a blue screen (as some people have intimated). It also failed to work on an XP virtual machine, leaving me with the only option to resort to an old XP machine.

I concur that the tool does not work unless there is more than one NIC installed on the machine. If only one NIC is installed, the fields on the interface overlay each other and the correct information is not reported on screen, leaving the recovery process to hang. The way I got round this was to temporarily install the legacy Microsoft Loopback driver included with XP (though it sounds like it would have worked with any network driver).

After this the process succeeded and I managed to get 3.01.38 up and running.

I will though find it difficult to buy another Netgear router or recommend one to anyone else until the recovery tool is updated to be Vista compatible and is fixed to work on systems with only one NIC installed. It was my good fortune I was able to lay my hands on an old XP machine and this would not be the case under normal circumstances. If there is another process (even a manual command line one) that works to recover the router from Vista this would be fine, but the current tool really isn't fit for purpose IMHO. I've fed this back to customer support, will report back here if I hear anything useful.
Message 29 of 36
chriswestscfc
Novice

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

I too had a problem with the tool. I managed to get around it in the end.

Went to see a customer who has just cancelled Sky broadband and took on another ISP. They sent out a non wireless router so he wanted to use the Netgear with the new ISP. Now I had never done it before, but I new it could be done. Sky have there own firmware written into the router, so you have no username & password box for your ppp connection. The way round it is to flash it.

Firstly each step I tried I always had it in recovery mode (reset/power on then alternate flashing lights)

1. Tried using tool on customers Vista laptop - No good
2. Returned to office and setup on testbench pc running xp, one network card, got the overlaying screens. - No good
3. Setup static address on pc - No good
4. Tried on my desktop pc running xp, 1 wireless nic, 1 wired with static ip, couldn't find the router - No good.
5. On the basis of more than one nic making the screen go normal I went back to the worbench machine with the single nic, and plugged in a usb to ethernet adapter so it now had 2 nic's. Ran the program, screens fine, found the router, flashed it and am now just about to take it back to the customer.

Cancelling sky broadband myself next month, so I now know how to make use of my old router !

Hope this helps
Message 30 of 36
pendulumx
Aspirant

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

I also encountered the same problems upgrading the firmware from 3.01.31 to 3.01.38 on my DG834G V2. The web update failed through no fault of my own causing the orange and green lights to flash alternately.

None of my computers could run the Recovery Utility - as the user interface was buggy and the program did not work. However once adding a second network adapter (I chose to follow stevebaker and temporarily install the Windows Loopback Adapter - it only takes a couple of minutes) the Recovery Utility ran fine and successfully recovered and updated my router to the latest firmware. The recovery program works in XP once it can see there are 2 or more network adapters installed!!!

I am very thankful to all the previous posters who came up with this solution, as I damn nearly threw my router in the bin once the recovery utility didn't work.
Message 31 of 36
ajdavidsome
Aspirant

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

To All the Australians that tried to upgrade their firmware from V.3.01.32 which for me was stable, and tried to ugrade to the new firmware Version 3.01.38 (UK).

For some it works for me I ended up with the same issues as above with the on light flashing green, and the tick flashing orange after an attempted upgrade.

what I did was get my cross-over network cable and plug it into my laptop ethernet port in the Laptop running XP.

I then downloaded the recovery program to my desktop + my original Firmware V.3.01.32.

In the Firmware folder once un zipped there is just an .ini file.

I copied this .ini file into the recovery folder which I also inzipped. There were many othe files in there. I double clicked upgradewizard.exe with my .ini file in the same directory.

I was then given 3 options to choose which netork to use. I clicked the one that is in my laptop. NOT the one that says WG834G e.t.c.

I was then given a 2nd page with 1 firmware option on it something like 003323242. I chose this then comtinued.

The program did it's stuff and I was up and running again.

At first I did choose the netgear network cable option, but figured that you need to select the network adapter of your computer.

You also need to do this with 1 computer and a cross-over cable.

Am not sure if this works with all O.S's but I just happened to have XP on my laptop.

The power button stopped flashing green, and the tick stopped flashing orange.

Hope this helps anyone else with the same prob

Everything is good now.

p.s. I'm not even going to try to upgrade firmware again unless is specifically for AU. I learnt my lesson
Message 32 of 36
innie808
Novice

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

Hi,

I recently got caught with the Failed Firmware download to a DG834N.

I successfully recovered using the utility on Windows 7.

Here it is step by step.


    After many bluescreens and frozen Wizard Gui, i can only put it down to maybe the wizard has to run in the c:\ and also XP Compatibility mode.
Message 33 of 36
sunniecoast
Aspirant

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

vkapartz wrote:
I registered to post my experience, in case it helps someone: In short, nothing worked until I powered on the router, keeping the reset button pressed.

I have a DG384v4 but I don't believe it makes any difference. Tried just one PC and one NIC, Windows 98 (crashed) and Windows XP SP3 (worked). A dynamic or static IP didn't seem to matter (I got a dynamic one from the router, in the range 192.168.1.100 to at least 192.168.1.102, even when not working). Placement of the upgrade utility, in short or long paths, didn't seem to have any effect either. I removed other network interfaces and services on the specific one, but the wizard still couldn't find the router.

After I tried the power on - reset thing, the recovery procedure worked like a charm Smiley Happy


Thanks for this. You just saved another DG384G (v4) from being thrown into the garbage, after a bad firmware update. I did the following and my router was revived:-

0. Downloaded Netgear Recovery Utility from http://kb.netgear.com/app/answers/detail/a_id/263. Downloaded latest firmware for my router from Netgear http://kb.netgear.com/app/products/list/p3/161 site/. Make sure you pick correct version for your router.

1. Disconnected everything except the router's power and one PC via ethernet cable. Powered down router

2. Set a static IP address on my PC that was in the same subnet as the router had been before it crashed. My router had been set to 192.168.1.1, so I set my PC's address to 192.168.1.2 , via Control Panel -> Network Connections -> Local Area Connection -> Right click properties -> Scroll down to Internet Protocol (TCP/IP) -> Click Properties -> Click 'Use the following IP Address' -> type in 192.168.1.2 for IP Address; 255.255.255.0 for Subnet mask; 192.168.1.1 for Default gateway; and 192.168.1.1 for Preferred DNS Server.

Note if your router was set to Netgear's default IP address (192.168.0.1), all of the above would be 192.168.0.x instead of 192.168.1.x

3. Held in reset button at back of router with biro point while powering up router as suggested by vkapartz

4. Ran Netgear Recovery Utility, after making sure I had placed a copy of the latest firmware file in the same folder as the recovery utility program. The program asked me for which network adaptor the router was connected to (ie which NIC in my PC). I clicked next and it then scanned for a few seconds and found a device. I clicked next and it uploaded the firmware to the router after wiping its "Eeprom". This took a couple of minutes. Step 3 above was the key to this working - I'd tried the Netgear Recovery Utility earlier today without Step 3 and the program hadn't been able to find the router.

Router is now working again perfectly and I can access via web interface on 192.168.1.1 again. Smiley Happy
Message 34 of 36
vkapartz
Aspirant

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

I'm really glad my previous post helped people. Here's an updated guide, that should work every time. I have succesfully unbricked a DG384v4 and a DGN1000, on Windows XP and on Windows 7 using the following procedure:

1. Use the updated recovery utility files

Netgear's recovery utility uses very old net libraries from PCAUSA, dated April 2001. I have managed to locate, and it wasn't easy, the latest libraries/drivers that will work with the utility. These are versioned 5.3.16.58 and dated March 2004. Later libraries from PCAUSA won't work, the API was changed.

Updated files: http://www.MegaShare.com/3789809

======
2. Make sure your router is in recovery mode

Power off the router or disconnect its power. Press the reset button. Keep the reset button pressed, and power on the router again. Some lights should flash to indicate the router is now in recovery mode. Release the reset button.

======
3. Make sure your PC has two network cards listed in the registry

A bug prevents the utility from running, if only one network adapter was ever present in your system. This is easy to fix. Launch Registry Editor, and check HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkCards. If it contains one subkey, then just duplicate the subkey and its contents, under a different name/number.

======
4. Upload a working firmware

You should already have a working firmware for your router. Place it in the utility folder. Start UpgradeWizard and follow the prompts.
Message 35 of 36
Timoth27
Aspirant

Re: DG834G v2 - firmware update failed, recovery tool doesn't work

hay everyone i have been thrying to get this to work for hours but i seem to have a slightly different problem in that once i select a nic (3 are showing) and click next i get a pop up saying i need to run the RmDrv app and then try again which i have but no joySmiley SadSmiley Sad any ideas :confused::confused:

thanks

tim
Message 36 of 36
Top Contributors
Discussion stats
Announcements

Orbi WiFi 6E