Reply
Highlighted
Follower

Router can't find HP Printer

I don't see this problem so perhaps I'm in the wrong place. I have an HP 3520 printer and an N600 router (Acer laptop and with Windows 8). The problem I'm having is to get the router to see the printer. I have downloaded and used the NetGear genie and have also used the HP wizard. The computer recognizes the printer with an USB cable and the computer recognizes the NetGear router and has wireless internet, but can't see the printer. I have tried the NetGear process of attaching the printer with a USB cable and pressing the WPS button while the printer is in wireless search mode (blinking blue light) but the router still doesn't see the printer. Since NetGear router needs to recognize the printer before the computer and operating system comes into play, I'm fairly sure the problem is between the router and printer independent of the computer. The printer has a MAC address with no SSID or IP #. Any ideas how to make this work??
Message 1 of 3
Highlighted
Mentor

Re: Router can't find HP Printer

If you can't get your HP wirelessly equipped printer to authenticate with a wireless network that other devices are working with, your first point of support should be HP tech support. HP has specific procedures to be followed when connecting their printers. Please also note, that if you installed the printer drivers using USB, you may need to uninstall that printer and reinstall it once you have connected it to the network.

Give a man a fish, feed him for a day
Teach a man to fish, feed him for life.
Message 2 of 3
Highlighted
Aspirant

Re: Router can't find HP Printer

Had one laptop stopped seeing my HP printer, had been working just fine, but hadn't used in a while. Figured out the problem for me was that I had installed AVG Antivirus 2014 trial edition on that one. (A different laptop still worked fine seeing my HP printer, on that one had installed simply AVG Antivirus 2014 free.edition). If I disabled the firewall completely through AVG on the one that couldn't see my printer, all of a sudden, it recognized it just fine. Re-enabling the firewall gave me the problem right back. Turns out the AVG trial edition takes over the laptop's firewall completely, and even though digging deeper, it states that USB Control Center is a recognized application and should work, it simply doesn't. The solution is to downgrade to the Free version, which can be done through Control Panel, Programs and Features. Double click on AVG program and will give you the option to downgrade without uninstalling. If you have already paid for the full featured version, good luck, check with AVG if you can. In my case, if I disabled the AVG firewall, I could not find a way to reactivate the Windows Firewall. Hope this helped.
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 12338 views
  • 0 kudos
  • 3 in conversation
Announcements