[WNDR3700v5] Cannot ping other devices on local network


[WNDR3700v5] Cannot ping other devices on local network

I am using the WNDR3700v5 as a wireless router (not in access point mode), but cannot contact any of the other devices on the local network.

I have these devices connected:
1. Ubuntu laptop (wired)
2. Android phone (wireless)
3. Android tablet (wireless)
4. Amazon Fire TV Stick (wireless)
5. Chromecast (wireless)

Devices 1-4 can connect to the Internet fine, and I'm having no problems there. However, from the laptop, I cant ping either the phone or tablet. Likewise from the phone I cant ping the laptop or tablet.

This breaks my Chromecast (which I cant setup because of this), and also my Amazon Fire TV stick (the remote app on my phone doesn't work - but I can use it with the normal remote).

I have seen some posts about turning off Wireless isolation, but cannot find any setting for this in the router settings, and from a chat with customer support last night they indicated that given the router is configured in router mode (not access point) then it should be off.

Does anyone know how to fix this problem? This is essential functionality for a router, and I will have to return it if there isn't a way to fix it.

Message 1 of 6
NETGEAR Employee Retired

Re: [WNDR3700v5] Cannot ping other devices on local network

What you describe sounds like the ‘Wireless Isolation’ function, but I can’t find it in the manual. It would normally be in the Wireless Settings page for most routers.
Working on behalf of Netgear
My name is Andy
Message 2 of 6

Re: [WNDR3700v5] Cannot ping other devices on local network

I spent a couple of hours with tech support tonight, and in the end we managed to fix it by:

1. Download the firmware (the same version as already on the router as there isn't a new one available):
2. Extract and apply the .img file to the router via Advanced > Administration > Firmware Update
3. Perform a hard reset, by poking and holding a pin into the reset hole of the router for a minute, then unplug for 10 seconds.
4. When the router is powered back up, you will need to set it up all over again. If it has your old settings, you didn't do 3 correctly, so try again.

Then it started working properly again. Don't know why that fixed it, but it did.
Message 3 of 6

Re: [WNDR3700v5] Cannot ping other devices on local network

Thank you for posting this solution! My problems were identical to yours. After many hours of troubleshooting this post saved the day!


And by the way Netgear: 1. How come this problem isn't anywhere listed on your site? (at least I haven't been able to find it), and 2. Why did the autoupdate firmware function off the router not see that there is an update: which solves a serious security bypass allowing the attacker to gain unauthorized access to the system? 3. Why does Netgear allow a not properly working router to leave the factory, is there some quality check issue here?


Not a very good "first impression"


Message 4 of 6
NETGEAR Employee Retired

Re: [WNDR3700v5] Cannot ping other devices on local network

I apologize for any inconvenience this may have caused you.

Firmware upgrade should have solved the problem. However, for some reasons or maybe due to some network interruptions it did not work the first time you uploaded the firmware that's why re-flashing/reset had solved the problem.

I will forward this to our engineering team about the auto firmware update.

This should be working as soon as they have a new firmware release.


Again, I apologize for any inconvenience and thank you for your update.

NETGEAR Community Team
Message 5 of 6
NETGEAR Employee Retired

Re: [WNDR3700v5] Cannot ping other devices on local network

I would like to let you know that the Auto-Firmware update is fixed.

For all other users you may now use the Auto-Firmware update button to upgrade the firmware of the router to the latest version.

Thank you!

NETGEAR Community Team
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 1 kudo
  • 4 in conversation

Orbi WiFi 6E