Discussion stats
  • 6 replies
  • 10589 views
  • 0 kudos
  • 7 in conversation
Announcements

Reply
Highlighted
Follower

WNDR4500v2 slow speeds with Comcast

A Comcast Tec just left my home after 3 hours. After much work, it was determined that the router is the problem. I have Comcast Xfinity Blast (with download speeds up to 50mps). The router is connected via ethernet cable to an iMac desktop running OS 10.6.8. My Comcast service is running through a Motorola Arris 6141 Cable Modem, which is connected via ethernet cable to the router.

When the router is taken out of the loop, my download speed is around 40-59mps. When the router is connected, my speed drops to 3-5mps. Upload speed is about 9-10mps. I have reset the router, powered everything down and started everything up. I have updated the routers firmware. My wireless devices performed at the same levels with the router out and back in. Also, when I remove the ethernet from my computer and connect wirelessly (through the iMacs AirPort, performance is unchanged, (still at 3-5mps).

It seems as though the router is either not completely compatible with the Arris 6141 cable modem or Comcast, or both. Comcast is a large company, perhaps someone else has experienced this problem. I played with the MTU settings with no change. Any help would be greatly appreciated. Thank you,
Message 1 of 7
Highlighted
Tutor

Re: WNDR4500v2 slow speeds with Comcast

It sounds like the modem and router cannot negotiate an ethernet link above the slowest 10 Mbps for some reason. If you haven't already, I would try a different ethernet cable between the modem and router to see if that fixes the problem (one surely rated cat5e or cat6). Otherwise it does seem to be an incompatibility with that particular modem, unfortunately.
Message 2 of 7
Highlighted
Tutor

Re: WNDR4500v2 slow speeds with Comcast

Turn off your IPv6 and see how it runs then
I had that issue with Comcast with IPv6, disconnected router and plugged the arris cable modem directly on Pc, taking the router that had been working fine for a period of 2 years now, and I still had slow (read less than 1.5MB speeds and many (error 404) dns errors, so on my 4500 v1 (still using it) and speed where crap, turned it off and I get 50MB speed again.. I think Comcast is mucking DNS and IPv6 and the netgear system is perhaps a little flaky to re initialize the information to get out there... I use the DNS from Google 8.8.8.8 and 8.8.4.4 and that solved my dns errors, so many here mentioned faults and blamed netgear but after my reviewing of issues and my solutions seem to point finger at comcast
Patrick Bureau

Computer Network Administrator since 1985.

Linux Administrator since 1990
Message 3 of 7
Highlighted

Re: WNDR4500v2 slow speeds with Comcast

I have 3 4500's v1 & v2 behind Moto SB6120s Comcast Blast. All receive 120 Down / 12 Up. IPv6 is enabled everywhere using the listed FW's, Comcast DNS 75.75.75.75, 75.75.75.76 and Default MTU. No Issues at all.


The 6141 is certified
http://mydeviceinfo.comcast.net/


While I am using earlier models, they share the same DOCSIS 3 standard and use similar channel bonding technologies.


You can review your modems performance by visiting http://192.168.100.1/


Beyond that, I'd look at cabling, or forcing the modem to get a new IP. Given the age of this thread... The OP has probably solved his issue or moved on.
~Comcast 1 Gbps/50 Mbps SB8200 > R8000P
~R8000P FW:1.4.1.50 ~R7000 FW:1.0.9.42
~R6400 FW:1.0.1.52 ~Orbi-AC3000 FW:2.5.1.8
~EX3700 FW:1.0.0.78

Message 4 of 7
Highlighted
Aspirant

Re: WNDR4500v2 slow speeds with Comcast

What firmware version are you running? I had great speeds when we first bought this router, and then it also dropped like you describe. We also had terrible problems with the router rebooting itself, sometimes several times a day.

After much frustration, and many different fix attempts, I ran across the suggestion to roll the firmware back to V1.0.1.20_1.0.40. And we've had ZERO problems since!

The speeds are as they should be, and no more annoying reboots.
Message 5 of 7
Highlighted

Re: WNDR4500v2 slow speeds with Comcast

I have Comcast extreme 105 with an arris 722g and a wndr4500v2. Only getting 33 or 32 down and 8 or 9 up. Any suggestions I am very frustrated with this right now
Message 6 of 7
Highlighted
NETGEAR Employee Retired

Re: WNDR4500v2 slow speeds with Comcast

What's your subscription plan?

Do you have the latest firmware installed?

After upgrading the firmware, did you reset?

If you haven't had done that, kindly do so by pushing the reset button at the back of the router for 10 seconds.

Resetting the router needs router reconfiguration.

So once you have configured the router, observe your connection.

By the way, how do you measure the speed? Are you using a wired or a wireless pc?

ElaineM
NETGEAR Community Team
Message 7 of 7