Discussion stats
  • 3 replies
  • 0 kudos
  • 1 in conversation

Top Contributors

WNR3500L2 Latest Firmware update still slow to connect to Google

I own two of the WNR3500L2 Routers.  Both have the same problem.  I've just tried again with updated Firmware WNR3500-Lv2-V1.2.0.56_50.0.96.chk Update.  I've setup each router and when I go to Google or Gmail it takes from 2 to 6 minutes of the spinning prompt for the router to get the page's information.  I does it on other URL's also.  I've had previous problems with the previous versions of firmware doing the same thing.  So, I used my old Airlink 101 for more than a year before trying again.  I've still got the same problem ONLY with Netgear Routers.


I've purchased a TP-LINK C1200 Router and it works fine with the same setup.  So, I know It's not my setup, or my Satellite Modem, Computer, or Cables.  It's just a problem with the

Netgear Routers.  Powering OFF & ON or rebooting doesn't help.


How do I get them to work properly?  Does anyone have a functional Unit?  What would cause this?  I know they aren't supported........., and the firmware has an undocumented feature.



Model: WNR3500v2|RangeMax Wireless-N Gigabit Router
Message 1 of 4

Re: WNR3500L2 Latest Firmware update still slow to connect to Google

It appears that a RESET by depressing the RESET button for 20 seconds doesn't

actually do a RESET.  There is a page on the Interent that states to to a 30-30-30 reset.

With Power on the WNR-3500L2 (long enough for it to be finished powering up)

PRESS AND HOLD the RESET button for 30 seconds.  Then pull the power plug, for

30 seconds (while still keeping the RESET Button depressed), then plug power

back in and keep RESET button depressed for another 30 seconds.  This is supposed

to flush the cache and RESET properly.


I did get one of the two working by doing this type of reset.  The other one seems to still

have a problem.  So for it, I did the 30-30-30 and then powered up and re-loaded the firmware (same file it had previously loaded).  Then I loaded a saved configuration.  I haven't had time to test it yet, but I suspect it will still have the sluggish wep page update problem.  (All while the TP-LINK continues to work properly.)  If this doesn't work, I'm going to do the 22-44-12 RESET.  (.22 MAG, .44 MAG, and 12GA. SLUG)


If you are having this problem, and you reset the router, the first thing to look for is

the Wifi being all setup when you enter the admin pages.  Mine continues to have all the settings even after the RESET.  You would think RESET means WIPED back to factory settings.  (The one that works properly seems to have worked after I did a RESET using a slow count to 20.)  But who knows, because I've done so many things trying to get it WIPED

and back functional for both Netgear Routers.


Plus, there have been no suggestions, comments, or answers to my postings.  I'm the ONLY one having problems......Typical.






Message 3 of 4

Re: WNR3500L2 Latest Firmware update still slow to connect to Google

The router that I was having trouble with finally got itself fixed after the above reset.

I just tested it, and it now has about a 2 second delay, which is typical of the others

I am using.


So, the FIX is a 30-30-30 Reset procedure, along with verifying the Wifi was not enabled when accessing the admin setup.  It finally fixed my problem, after 2 years

of trying to get them working.






Message 4 of 4