× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Readynas NV+ v2 cannot map network

thaiZilla
Aspirant

Readynas NV+ v2 cannot map network

Hi All

 

I've had my ReadyNas NV+2 for 6 years. I've had it working on and off over these years, but the last 2, since using Windows 10, i am able to view and access the storage, however i cannot map the drive therefore cannot add or delete files.

 

Its rendered it pretty useless and i'm desperate to get have full use again.

 

I did a OS reintall to get access to the system again, and despite my shares being user controlled and then switched to everyone i still cannot add or delete files.

 

Please can someone take me through this supposidly easy process of mapping the drive like i use to on Windows 7.

 

Thanks

 

Coe

 

Model: RND4210v2|ReadyNAS NV+ v2 2TB (2 X 1TB Desktop)
Message 1 of 7
thaiZilla
Aspirant

Re: Readynas NV+ v2 cannot map network

I have just tried this solution and this doesn't work for me either

 

https://community.netgear.com/t5/Using-your-ReadyNAS-in-Business/I-can-t-map-network-drive-in-Window...

Message 2 of 7
Sandshark
Sensei

Re: Readynas NV+ v2 cannot map network

On my network, using the NAS name in Windows 10 is hit-or-miss, while using the NAS IP always works.  Have you tried doing the mapping using the IP address instead of the NAS name?

 

If that works and you still want to be able to use the name, you can add the IP address to the hosts file.  Of course, both of these rely on the NAS having a fixed IP address, which is best done by reserving one in the router, not by using the NAS static IP setting.

Message 3 of 7
thaiZilla
Aspirant

Re: Readynas NV+ v2 cannot map network

Hi Sandshark

Thanks for the response. I have been using the ip using the following format

\\ip/C

Still not working. This has only ever happened since moving to Windows 10. I can see the nas drive Via Network and view the documents but i can not add or delete to them. I use to map the network and input my username and password to edit add or delete files. Now i can only view them on the network but even that, is a stripped back version of all my data on the NAS drive.

Thanks
Coe
Message 4 of 7
StephenB
Guru

Re: Readynas NV+ v2 cannot map network


@thaiZilla wrote:

\\ip/C


The correct syntax is \\ip\C

 

But there likely is a credentials issue here.   You can only access C if Windows is using the NAS admin credentials.

 

Try running CMD (type it in the search bar) and enter

net use * /delete /y
net use t: \\nas-ip-address\C /user:admin nas-admin-password

The first command disconnects any open SMB sessions, the second attempts to mount the data volume as drive letter T.

 

BTW, this won't work if the NAS is using the default admin password.

Message 5 of 7
thaiZilla
Aspirant

Re: Readynas NV+ v2 cannot map network

Thank you so much, this worked!

 

Is there an explanation to why it was more difficult to map a drive this time? Does this mean i can map each share indepedently as before i had a letter for each share.

 

Its not important to do so, just glad to have full access back!

 

Thanks again!

 

Coe

 

Message 6 of 7
StephenB
Guru

Re: Readynas NV+ v2 cannot map network


@thaiZilla wrote:

 

Is there an explanation to why it was more difficult to map a drive this time? Does this mean i can map each share indepedently as before i had a letter for each share.

 


Windows has gotten stricter about credentials over time, so anonymous/guest access often no longer works.

 

The next step is to open the Windows Credential Manager on the PC, and create credentials for the NAS. 

 

First, delete any existing credentials for the NAS.

 

I recommend setting up two windows credentials - one for the hostname of the NAS, and one for the IP address of the NAS.  Also, I recommend reserving the IP address in your router, so it doesn't change.  The username/password needs to be for a user account set up on the NAS.  While you can use the admin account for this, if you don't want to map the full data volume you should use a different account.  This account can be shared across all your PCs.

 

After that, reboot the PC.  You should then be able to map the shares as you did before.

 

 

Message 7 of 7
Discussion stats
  • 6 replies
  • 1652 views
  • 0 kudos
  • 3 in conversation
Announcements