× Introducing the Orbi 970 Series Mesh System with WiFi 7 technology. For more information visit the NETGEAR Press Room.
Orbi WiFi 7 RBE973
Reply

Netgear xr1000 high ping under load

Freek245
Aspirant

Netgear xr1000 high ping under load

  I recently purchased the xr1000 gaming router because I thought that was the issue I was having with my connection while playing games on my pc was my old router. While this router has a TON more features than my old one, I am able to try and narrow somethings down. I am not the most tech savvy person and this has been a process for me, but I need someone to help me out, and I'm starting to lean towards it being on my ISP end. After every time I do mess with it though and do a connection test it's the same result, good speed, good ping but horrible Ping under load and I have attached some pics of tests I have done. Also, when I do the test, it says my internet is 540ish download when all I have is 300 so whatever that's about.

  

   When I first purchased the router 3 weeks ago, I plugged it in and checked on MW2 and still had a moderate Nat type, did some research online to open Nat with some port forwarding and such and seemed to work. I live in upstate NY and when i did ping test for the game it showed me areas close to mine with a relatively close ping, and on MW2 it showed my geographical location being Poughkeepsie NY. The next day the internet completely shut off, i called my ISP they reset my modem on their end then said it was on my end so, I reset my router to factory settings to fix it, no idea what happened. But my Nat now goes between moderate and open randomly, my geographical location is now High Falls NY, and the closest ping test area now is Oklahoma.

 

  The pc games still work terribly, today I tried messing with a few things like turning off the Armor protection and opening Nat filtering in Wan settings, no dice and now when I do a pin test the closest, I get is France with a NA next to it. every time i do mess with it i do reboot the router to no avail so if anyone can help me I'm open to anything at this point, thank you.

xr1000 gaming router

firmware version 1.0.0.64_1.0.49

DumaOS version 3.1.1

Message 1 of 13

Accepted Solutions
Netduma-Fraser
NetDuma Partner

Re: Netgear xr1000 high ping under load

Yes a lot better, you were spiking into the 100's before, now it's spiking between 10-20ms so you should notice a big difference. Now just fine tune QoS as much as possible and you'll be good to go.

View solution in original post

Message 13 of 13

All Replies
Netduma-Fraser
NetDuma Partner

Re: Netgear xr1000 high ping under load

The router won't affect the in game location that will be down to your ISP and the routing they're putting you on - this will likely resolve itself after a certain amount of time as long as the modem isn't rebooted. What is the model of the modem/router the XR is connected to? Your Ping Test has quite a lot of spikes and that is to do with the ISP. Ping Under Load can be resolved by experimenting with Congestion Control percentages while set to Always, although it will only be as good as the Ping Test which is a baseline test of your connection.
Message 2 of 13
Freek245
Aspirant

Re: Netgear xr1000 high ping under load

Ok, yea like I said I'm not too much of a tech person and i figured that the ISP was responsible for the location just thought I'd add it to see if anyone thought it was weird and to help with my case that it is an ISP issue. So the modem is a ARRIS TM1602A and my provider is Spectrum and they are the wooooorrrssst. I did mess with the congestion control a little bit and seemed like the less I made the percentage the worse the ping got but i will run a few tests again at different percentages and share my results, thank you. I also did athumbnail (5).jpg speed test with ookla I will share results in case that helps (or doesn't), thanks again

Message 3 of 13
Freek245
Aspirant

Re: Netgear xr1000 high ping under load

ok so put on always and set scaler to 70% and got A's across the board but is it still very "spikey"?

Message 4 of 13
Netduma-Fraser
NetDuma Partner

Re: Netgear xr1000 high ping under load

That will be down to the ISP then I think, it's hard to determine what can be resolved with QoS when the baseline is that unstable. The Connection Benchmark test uses the Google servers for the Ping tests so it's possible your connection to these tests isn't very good. Follow this guide and use a local website and lets see what baseline you get that way and we can proceed from there https://support.netduma.com/en/support/solutions/articles/16000074717-how-to-test-your-internet-ping
Message 5 of 13
Freek245
Aspirant

Re: Netgear xr1000 high ping under load

So, I downloaded the ping plotter and have no idea what I'm looking at for the most part lol. I did use local sites that they had suggested like google and twitter, I added YouTube and one Hop does stick out and its lag-63.hiflnyae01h.netops.charter.com I will also add a screen shot of the google results to maybe get a better idea.

Message 6 of 13
Freek245
Aspirant

Re: Netgear xr1000 high ping under load

Did a little more digging and reading on that link you sent me and turns out that the modem i have has a puma 6 CPU which are known to have issues, I am going to bring the modem to my ISP tomorrow and switch it with a different model and show them screenshots of what i have vs what its supposed to be. I will keep you posted if this resolves my issue, thank you.

 

Message 7 of 13
FURRYe38
Guru

Re: Netgear xr1000 high ping under load

There's a long thread over on DSLReports site about Puma6 and it's vulnerabilities. Goes back years. 

Not sure if Intel ever fully addressed it. 

Message 8 of 13
Netduma-Fraser
NetDuma Partner

Re: Netgear xr1000 high ping under load

Great to hear we're making some progress, do keep us posted after the modem switch!
Message 9 of 13
Freek245
Aspirant

Re: Netgear xr1000 high ping under load

So i did go to my ISP and switched to the Ubee E31U2V1 modem and did see improved results. I thought i had downgraded my internet to 300 but was still at 500 so that was a plus lol. I did do Ping test on both the router and ping plotter and even though it is better idk how much better it is. Ill post both results and see what you guys think, i did put the ping plotter screenshot on a spectrum board and they said it was "excellent"

Message 10 of 13
Freek245
Aspirant

Re: Netgear xr1000 high ping under load

sorry had to make another reply i can only post one pic at a time, which you guys prob already know lol, thanks.

Message 11 of 13
FURRYe38
Guru

Re: Netgear xr1000 high ping under load

Yes, way better. 

Message 12 of 13
Netduma-Fraser
NetDuma Partner

Re: Netgear xr1000 high ping under load

Yes a lot better, you were spiking into the 100's before, now it's spiking between 10-20ms so you should notice a big difference. Now just fine tune QoS as much as possible and you'll be good to go.
Message 13 of 13
Discussion stats
  • 12 replies
  • 3589 views
  • 6 kudos
  • 3 in conversation
Announcements

Orbi WiFi 7