Reply

Packet Loss/Lag continues while gaming

DirtySZN
Aspirant

Packet Loss/Lag continues while gaming

So I have been writing posts on Reddit over the course of the last few months as I have been having lag issues/packet loss/ISP problems...

 

As I thought it was my router/modem initially causing the issue, I have yet to find out what is really causing the issue. While playing Fortnite, I am getting severe packet loss(anywhere from 1%-20% & spikes that go all the way up to 80% at times).

My ISP is Xfinity and I live in New Jersey. Like I said at first I thought the issue was because I had a faulty modem/router. I got the brand new CM1000 modem and the brand new XR500 gaming router. That didn't solve the issue.

 

I thought maybe then there is something wrong as far as my ISP. A technician came out to the house, and apparently there was a problem with the line outside of the house in the yard, so they said it should be pretty much fixed after working on it for about 30 minutes.

 

I am still lagging and have bad packet loss while gaming. I checked all of my wires like the ethernet cable, the coaxial cable connected from the outlet to the modem, and since they are almost brand new I know it is not the cables. I have researched cmd commands to see how I am connecting and pinging to google and to my IP address. There is 0% packet loss when I do that.

 

I have updated all drivers in the PC(literally everything). All firmware/updates are up to date as far as my router and modem.

My settings in game are perfectly fine and I am connected to NA East servers in game, as I should be since I'm located in New Jersey. So why could I be having the bad of an issue still??

 

My setup:

Coaxial cable in coaxial port in wall ----> CM1000 modem ----> ethernet cable from CM1000 ----> XR500 router(internet port) ----> another ethernet cable from XR500 ----> gaming PC -

 

Side note: My setup is in my bedroom. I have another setup in my house for my mother's work station in another room with the main Xfinity gateway set up there. So yes, I have 2 different modem/routers in the same house under the same Xfinity account. People say this is what could be causing the issue, but I know it is not the issue because when I connect to the Xfinity gateway via WiFi, I still get the same exact issues. And that is with my setup in my bedroom completely disconnected and not active/running.

 

I also cannot even call Xfinity back over even if they needed to fix something as my mother thinks that I am messing with her internet every time that I call the technician over to fix whatever is wrong. And even though the technician says that there are issues(like in the yard outside), she still doesn't want me to mess with it anymore...

 

So what could be my options here? -

Does a VPN do anything to help?

Are there other tests or similar that I can run to get me a better understanding of what the main source of packet loss is coming from?

Could it just be the servers in general on Fortnite because I can almost tell you that I don't lag as bad in other games such as Call of Duty(almost 100% sure on this one).

 

As an update from the above information; - within the last few days, I have put an extensive amount of time to research what could be happening, but when it comes down to it, I am not a ISP technician that comprehends all of the terminology that is needed to correct the issue. However, I am going to list some of the tests/other things that I researched and the one specific test that I find to be the most valuable below(PingPlotter) -

 

I have a screenshot of my modem(CM1000) event log if needed.

I have a screenshot of my modem's status page - to check the specific signal levels.

I have verified my speed tier that I am subscribed to - meaning that I am supposed to a download/upload of 600/15. I get even more - up to 700/20 most of the time.

I have a screenshot of the traceroute that I ran to comcast.net in the command prompt window.

I inspected all of my wiring/coaxial cable port inside and out to double check that I don't have faulty or damaged equipment for sure.

I have clearly did the obvious and properly reset the network - following everything that is in this link here - https://forums.xfinity.com/t5/Your-Home-Network/Internet-Troubleshooting-Tips/m-p/3310447#M316652 as it was written by an expert troubleshooter that doesn't work for Xfinity though.

 

**I also really notice that I get worse packet loss by a large margin at night/late at night when I game the most(usually after 7/8pm EST through the night).

And from what I have read in Xfinity forums, nobody that has this very similar issue has figured out how to solve it... apparently it has to escalated to the higher ups and that is far from what I am trying to do, but at the end of the day all I want is to not have to worry about his packet loss and lag every single day.

 

Thank you guys so much in advance!

 

Hardware/equipment:

Netgear CM1000 Modem

Netgear Nighthawk XR500 Gaming Router

Brand new custom built gaming PC(everything up to date)

Fully functional/pretty much new, ethernet cables(CAT 6/CAT 5E)

Fully functional/no signs of wear, coaxial cable

Model: CM1000|Ultra-High Speed Cable Modem—DOCSIS® 3.1 Ready, XR500|Nighthawk Pro Gaming Router
Message 1 of 24

Accepted Solutions
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

@defiled669 you're on beta firmware, there will be bugs, that is to be expected.

@DirtySZN okay that's very interesting, the only other way would be to talk to your ISP and see if they can help adjust your routing for better ping. They will likely be hesitant so perhaps you could say something like your a content creator and that this directly impacts your job - saying it affects your work sometimes prompts them to do something when they otherwise wouldn't.

View solution in original post

Message 22 of 24

All Replies
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

Thank you for the extensive write up. Could you get the IP of the Fortnite server from the Geo-Filter please and then run a PingPlotter test and post a screenshot here of the results?
Message 2 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

The sreenshot will be posted below - 

 

But one thing to note is that even though I stated that I am mostly getting the packet loss on Fortnite specifically, I am still getting it in Call of Duty Modern Warfare as well(so I am assuming in any online game this is going to happen - maybe some games worse than others for some reason?; not sure).

Message 3 of 24
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

You're definitely getting some packet loss there. Could you try it with a CoD server as well please and then a normal plot to a local website like a news site please? Could you also do these direct from your modem/hub as well? I assume all these plots are done via ethernet?
Message 4 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

I accidentally hit the solution button, however, clearly the problem is not fixed/resolved. Sorry about that...

 

However, yes all of these are done via ethernet cable. 

 

The first screenshot from Ping Plotter will be connected to my modem AND router via ethernet to the CoD server.

 

More screenshots to follow:...

Message 5 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

Here is a screenshot of using Ping Plotter connected via ethernet to modem AND router to my local news website("Jersey Shore Online").

Message 6 of 24
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

The first one looks like you did it to your own IP address so would suggest removing that. Do you have the CoD plot? Can you do the game ones directly from the modem as well so:

1. Fortnite Plot from router (already provided)
2. Fortnite Plot from modem - not connected to the router
3. CoD Plot from router
4. CoD Plot from modem - not connected to the router
Message 7 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

Here is the Fortnite Ping Plotter results only connected to the modem via ethernet.

 

CoD plot coming up next for both modem and router/modem only; just give me another 20-30 minutes, thanks!

Message 8 of 24
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

Thank you for that, could you also try playing directly connected to the modem as well and see if you experience the same issues?
Message 9 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

So here are all of the results - 

 

The image in this post is the CoD server connected to the modem and router together.

 

As far as playing connected directly to the modem, there is no difference to me whatsoever. I notice overall that I get much more severe packet loss on Fortnite, but I kind of knew that from the start anyway.

In CoD, I am getting the yellow "connection interruption" signal on the screen while playing, however, I do not notice or see any packet loss as I have that feature turned on to see.

Message 10 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

This image is the CoD server plot connected only to the Modem -

Message 11 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

Here is the Fortnite server plot connected to the modem only - 

Message 12 of 24
defiled669
Apprentice

Re: Packet Loss/Lag continues while gaming

the qos is not working along with the bandwidth allocation. geo filters not finding servers. i ran several speed test on my xbox yesterday trying to qos my bandwidth and every time the download and up load would never be adjusted i even set my bandwidth to 10, out of 1000 mbps and still every test came back 800 plus mbps. also noticed that download speed is constricted on the benchmark test can never get it to go past 450 and upload past 750. so these new apps are great to have but only if they are working properly.  another thing i noticed was that benchmark test does not account for qos or bandwith allocation. so its something flawed heavily with qos and bandwidth allocation. geo filter not pinging servers in ping the host. and would suggest on ping heat map an allow and block server option

Model: XR500|Nighthawk Pro Gaming Router
Message 13 of 24
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

Okay that's interesting, for the CoD plots you had 100% loss on both, but as you had it on the modem without the router then indicates there may be an issue there or with your ISP routing. Could you try setting DNS in Internet Setup to 1.1.1.1 & 1.0.0.1 please to see if the routing may be affecting it.

@defiled669 please post beta related issues/queries in the beta forum. Share excess needs to be disabled to do that. Connection Benchmark is being improved on to improve the speeds. That's not a bug, QoS will be implemented with it.
Message 14 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

Sorry about the late response, I am still very much trying to continue this thread...

 

Just as an update, last night I did 2 different things:

 

1. Used a physical pin to fit inside of the reset button hole and reset both my router and modem.

2. I downloaded and installed an application/software called "ExitLag"

 

Now I am not sure which one of these could be possibly helping or if it was a fluke of a night, but I didn't have any packet loss over 1% playing either game(Fortnite and CoD). The instances where there was the 1% packet loss was in Fortnite on 2 seperate occasions of only about 2 seconds each. I felt no lag all night for the first time in months. It felt great, but as I said is it possible it was a fluke and today/tonight I go back to packet loss?

 

My question now would be should I still use the DNS settings your recommended or should I just see if I lag later on today first?

Message 15 of 24
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

It's hard to say what could have resolved it, if both the modem/router having been running for a long while without a reset then it's possible the reset did the trick. However, if it was your ISP routing and exitlag has better routing to the game servers then that could be helping.

What I would do in this situation is try a few games using the following setups:

1. Direct to modem if possible
2. Modem > Router > Device
3. Modem > Router > Device w/DNS changed on router
4. Modem > Router > Device w/exitlag used

Then let us know the results and that will help determine where the cause may lie.
Message 16 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

So just an update as of this morning(8/1/2020). As I was playing Fortnite last night, there was an unfortunate drastic amount of packet loss once again... Since the other night it slowly has gotten worse again and I am very disappointed honestly.

 

I have tried all numbers 1-4 like you asked. With number 4, I no longer have ExitLag as it was a 3 day free trial(will only purchase it if that is for sure going to help me out).

 

I am really confused on where the problem may lie here...

Message 17 of 24
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

Do you have specific results for each test so we can see what was better and so we can see where the issue may lie?
Message 18 of 24
defiled669
Apprentice

Re: Packet Loss/Lag continues while gaming

 outcome was always the same because qos and anti bufferbloat and geofilter are not working, so i had to revert to old os to play games it was so terrible

Model: XR500|Nighthawk Pro Gaming Router
Message 19 of 24
defiled669
Apprentice

Re: Packet Loss/Lag continues while gaming

waiting for supposed update this week

 

Model: XR500|Nighthawk Pro Gaming Router
Message 20 of 24
DirtySZN
Aspirant

Re: Packet Loss/Lag continues while gaming

I do not have any results to go off of. However, I did purchase a month of ExitLag and it seems to have solved the issue over the last 2-3 days - I have experienced very little to no packet loss while using it.

 

My only question would be is there any way I can fix the routing without paying for ExitLag or is that something too far out of my control?

Message 21 of 24
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

@defiled669 you're on beta firmware, there will be bugs, that is to be expected.

@DirtySZN okay that's very interesting, the only other way would be to talk to your ISP and see if they can help adjust your routing for better ping. They will likely be hesitant so perhaps you could say something like your a content creator and that this directly impacts your job - saying it affects your work sometimes prompts them to do something when they otherwise wouldn't.
Message 22 of 24
defiled669
Apprentice

Re: Packet Loss/Lag continues while gaming

i got a great ping, and the only problem im having on this beta is nothing works at all, had to reinstall old version, waiting for update that was supposed to come this week if i read frazzer  right

 

Model: XR500|Nighthawk Pro Gaming Router
Message 23 of 24
Netduma-Fraser
NetDuma Partner

Re: Packet Loss/Lag continues while gaming

No need to keep posting in non beta topics, you will get a new build soon yes. Please post any issues you have just in case we're not aware of them.
Message 24 of 24
Top Contributors
Discussion stats
  • 23 replies
  • 10200 views
  • 1 kudo
  • 3 in conversation
Announcements

Orbi WiFi 6E