Discussion stats
  • 7 replies
  • 2231 views
  • 0 kudos
  • 3 in conversation
Announcements

Top Contributors
Reply
Highlighted
Aspirant

XR500-100NAS v2.2.1.10 DumaOS Not Loaded Endless Cycle

I bought an XR500 the other day (so far, love it - getting ethernet-comparable pings through multiple walls at 60' with MU-MIMO), and I am having trouble getting it to update to the latest firmware. When I first tried to set it up, it was with the smart phone app, and I had some trouble. It started the update during this process, and it seemed to hang. When I connected to the router from a PC to see what was going on, I was greeted with "DumaOS not yet loaded" and the page refreshing every 5-10 seconds or so. I was able to connect to the internet via the default wireless network it was putting out, but couldn't configure anything. I pulled up the following page, and it got DumaOS to load:

https://kb.netgear.com/000053276/How-do-I-fix-R-app-is-not-loaded-yet-Please-try-again-in-a-minute-e...

 

But I prefer to have the latest version of any firmware loaded. I gave it another shot today. Updating via the router's built-in tool results in the "DumaOS not loaded" page. So I rolled back to v2.1.0.4 via the previous instructions, and tried again, this time by uploading the v2.2.1.10 .img to the router from my computer. Same result; white screen, "DumaOS not loaded". So, another rollback, and another attempt to update to v2.2. Updating via the previous link's instructions, but using the v2.2.1.10 firmware results in another "DumaOS not loaded" loop. So, one final rollback. I'm back at v2.1.0.4 for now.

 

I'm starting to think there might be an issue with v2.2.1.10 that prevents DumaOS from running on my particular router. Note: I still have connection to the internet with v2.2.1.10 installed, and I can still load the legacy firmware that seems to run in the background of every installation, it is only Duma that won't load.

 

Let me know if you need any more information to help figure this out.

Message 1 of 8

Accepted Solutions
Highlighted
NetDuma Partner

Re: XR500-100NAS v2.2.1.10 DumaOS Not Loaded Endless Cycle

That won’t affect the cache. If you wipe it it may work. This firmware does work it’s rare that this occurs, downgrade then factory reset and update in the setup wizard

View solution in original post

Message 6 of 8

All Replies
Highlighted
NetDuma Partner

Re: XR500-100NAS v2.2.1.10 DumaOS Not Loaded Endless Cycle

There is a known issue with updating via the app which is being fixed as we speak. I think this set of your issue. Upgrade to the latest firmware then go to routerlogin.net/index.htm and do a factory reset then you’ll be able to access the proper interface and have no issues.
Message 2 of 8
Highlighted
Aspirant

Re: XR500-100NAS v2.2.1.10 DumaOS Not Loaded Endless Cycle

I actually tried that during the last attempt, of loading through the legacy firmware mention in the link in the first post. Whenever Duma didn't load, I tried a factory reset in between. Should have mentioned that earlier, its kind of standard operation for me if a firmware fails to load after being updated.

 

On the final attempt, with everything 'manual', the factory reset actually hung, and took a little playing with it to get it back; second factory reset, hardwired connection to upload v2.1 to the the legacy firmware interface.

Message 3 of 8
Highlighted
NetDuma Partner

Re: XR500-100NAS v2.2.1.10 DumaOS Not Loaded Endless Cycle

Okay then it may be all you need to do is completely wipe the browser cache after updating to access the interface
Message 4 of 8
Highlighted
Aspirant

Re: XR500-100NAS v2.2.1.10 DumaOS Not Loaded Endless Cycle

How can I wipe the cach when nothinig loads during this particular factory reset - it took additional power cycles and factory resets to get it backup and running to the point when I could re-load the firmware back to v2.1?

 

Is it likely that the version that comes after v2.2.1.10 will install 'cleanly' in the XR500?

Message 5 of 8
Highlighted
NetDuma Partner

Re: XR500-100NAS v2.2.1.10 DumaOS Not Loaded Endless Cycle

That won’t affect the cache. If you wipe it it may work. This firmware does work it’s rare that this occurs, downgrade then factory reset and update in the setup wizard

View solution in original post

Message 6 of 8
Highlighted
Prodigy

Re: XR500-100NAS v2.2.1.10 DumaOS Not Loaded Endless Cycle

I would hard reset after the update (download the image) or use the Netgear check for firmware updates in Admin under settings in the Netgear part of the menu do not use the top right hand update symbol on the dashboard. The update bug for that update icon is only fixed with 2.2.1.10. That should get the interface back to where it should be. If this persists even after a hard reset on 2.2.1.10 get in contact with netgear. Hope that helps.

Model: XR500| Nighthawk Pro Gaming Router
Message 7 of 8
Highlighted
Aspirant

Re: XR500-100NAS v2.2.1.10 DumaOS Not Loaded Endless Cycle

So I had the XR-500 do a factory reset (from within DumaOS), and manually configured all the settings during start-up (accidentally left the 'merge both wifi networks in one' checked, and re-split them after setting up, before uploading new firmware - doubt that affected anything though), while it WAS NOT connected to the internet, or anything other than my laptop. Then I manually uploaded firmware v2.2.1.10. DumaOS installed and updated the firmware all on its own, without a single hiccup. I was kind of shocked actually, after wrestling with it for so long. The update v2.3.2.22 went just as smoothly.

 

It seems that the "kind" of reset done seems to affect the outcome of this error. Holding the hardware reset button to do a factory reset doesn't seem to work - the router reset, but updating the firmware fails after this step - but telling the OS to reset the router to factory defaults does seem to work.

Message 8 of 8