Reply

How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

DDavis99
Aspirant

How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

I've been using an R7000 sitting behing my ATT U-Verse router (NVG589) for sometime to provider additional networks at home. Recently I decided to configure things so that I can access two HDDs attached to the USB ports the R7000.  I've tried numerous configuration settings between the two routers and have not been able to get the two HDD to be visible with ReadyCloud.  There are no problems accessing the drives from within the network hosted by the R7000.  From the Netgear ReadyCloud web site the drives are never discovered.  An app I downloaded on have on my PC continues to say the R7000 is Offline.  It certainly isn't offline in regards to my home network.

 

My thinking is that the R7000 does not show up on the internet because it is behind the ATT router and I don't have that router correctly configured to get it to work.

 

Some configuration details:

ATT Router:

IP: 192.168.1.254

Netmask: 255.255.255.0

Start Add: 192.168.1.64

End Add: 192.168.1.253

 

R7000

IP: 192.168.2.1

Netmask: 255.255.255.0

Start Add: 192.168.2.2

End Add: 192.168.2.254

 

I have the R7000 set as a cascaded router on the ATT router as follows:

Router Address: 192.168.1.64  The address assigned to the R7000 by the ATT Router

Network Address: 192.168.2.0

Subnet Mask: 255.255.255.0

 

Also, I can't do away with the ATT router, it runs my TVs and phone line in addition to providing the internet connection.

 

If anyone knows how to make this work I would appreciate the assistance.

 

 

Message 1 of 14
mondenath
Prodigy

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Need more info.

 

How the two routers are connected. Wired/wireless

If wired then you can still use only the R7000 as AP and it will work for connected storage .I believe if you disable DHCP in r7000 is creating problem. This way you can have wired devices connected like tv and other through motorola and wireless devices keep accesing net

 

If you have entire IP range different and try wired for internet from Motorola and then see if you can get access to HDD's.

Message 2 of 14
DDavis99
Aspirant

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

The two routers are wired.  R7000 goes to one of the ATT router's ports.

 

The R7000 is both a wired and wireless AP for two networks, the primary and the guest.  The R7000 is set as DHCP server, I will disable that and see if it makes a difference.

 

The ATT router also has wired and wireless clients.  There has never been a problem accessing the drives connected to the R7000 as long as the client accessing them is on the main network of the R7000, but that is as it should be.

 

As you suggest, I'll try removing the DHCP setting on the R7000 and report back.

 

Thanks

Message 3 of 14
DDavis99
Aspirant

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Changing the DHCP setting on the R7000 didn't made a difference.

 

In the process of doing this and looking at the ATT router settings I noticed something interesting. First, I had not set the R7000 up in the ATT router as a cascaded router until ealier today.  Prior to making that change on the ATT router the R7000 has always shown as a connected device using 192.168.1.64 which is the address I have the ATT router assign to the R7000.  Now, even though the ATT router is still assigning the R7000 router 192.168.1.64, the R7000 now shows as an unknown connected device with 192.168.2.1 as the IP.  The 192.168.2.1 is what I assigned the R7000 in its configuration settings.

 

If I open a browser window and enter 192.168.1.64/shares/ I am taken to a page that gives me access to the connected drives, but the address shown in the page is 192.168.2.1.  If I enter 192.168.2.1/shares I end up at the same page, that shows the 192.168.2.1 address.  If instead of entering the address in the browser window I am on the R7000 configuration page that is for ReadyShare and I click on the HTTPS://192.168.1.64/shares link I end up on a page that does display 192.168.1.64 as the address.

 

I think I will make some changes on the ATT router again.  I would expect that ReadyCloud is trying to connect to 192.168.1.64 and if it does not show as being connected on the ATT router then I don't see how the drives could be accessed via the internet.

Message 4 of 14
TheEther
Guru

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

While you can convert R7000 to AP mode, there is another option:  Enable IP Passthrough mode on the NVG589.  IP Passthrough mode is similar to the DMZ mode on Netgear. The DMZ device inherits the same public IP address as the AT&T router.  I have a R7000 plugged into a NVG589 and IP Passthrough works fine.  There's a pretty good FAQ on setting up IP Passthrough on a NVG589 on dslreports.com.

 

While I have never used ReadyCloud, I'm pretty sure it will work once you enable IP Passthrough.  It's probably not working right now because the NVG589 firewall is blocking access to the R7000.  Moreover, as a cascaded router, the R7000 is going to get a private IP address assigned to its WAN port, so even if the NVG589's firewall was turned off, the R7000 is still unreachable from the Internet.  IP Passthrough mode solves both of these issues.

 

Why use IP Passthrough instead of enabling AP mode on the R7000?  IP Passthrough mode will allow you to use the superior router and firewall features on the R7000.  In addition, you will have the peace of mind of isolating your devices behind the R7000 instead of the NVG589.  AT&T can most likely log into the NVG589, so you never know what they might do on your home network.  Note: If you have also have U-Verse TV, keep the DVRs plugged directly into the NVG589.

Message 5 of 14
DDavis99
Aspirant

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Very good suggestion and information.  However after doing this, the drives on the R7000 still don't show up on ReadyCloud.  But I want to look at the changes again and make sure I didn't miss anything, but that's got to wait until tomorrow.

Thanks

Message 6 of 14
DDavis99
Aspirant

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Still no luck on accessing the drives via internet, however, the IP Passthrough worked just as it should.  I plan on leaving it that way.  The R7000 is getting the public IP assigned to it.

 

Additional things I tried today.

-Removed the two HDDs attached to the R7000 and replaced with one flash drive to make sure there wasn't an issue working with the HDDs.

-Changed the R7000 subnet back to the default of 10.0.0.0 just incase that is what ReadyCloud needed.

-Changed the R7000 router password to match the ReadyCloud account password for the same reason as above.

-Turned off the Firewall on the ATT router.

-Created new shared folders on the flash drive, one at the root of the drive and the other in a subfolder to see if ReadyCloud preferred it one way or the other.

-Have periodically, based on changes made, unregistered the R7000 and regestered it in case that was needed for changes to be seen by ReadyCloud.

 

The ReadyCloud Client app that is on my PC continues to show the R7000 as being Offline.  ReadyCloud continues to fail to find any shares on the R7000.

 

I think I'm throwing in the towel for now.  If I can think of anything else to try in the next couple of days I'll report on it if it woks.  Thanks for the help.

 

Message 7 of 14
TheEther
Guru

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Just to be clear, did you follow the instructions according this video: ReadyCLOUD Storage on NETGEAR Nighthawk Routers

 

You registered the R7000 with ReadyCloud?

 

When you log into https://readycloud.netgear.com, do you see your R7000 at all?

 

Is your R7000 running the latest firmware?

Message 8 of 14
DDavis99
Aspirant

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Yes to the video.

 

Yes to registering the R7000 with ReadyCloud.

 

When I log into my ReadyCloud account I see the R7000 displayed along with the correct serial number, but no folders/shares. Refreshes and discovery tries never find anything.

 

My R7000 says I'm running the latest firmware, it is as follows: V1.0.4.30_1.1.67

 

Maybe I should do a reset on the R7000 to factory settings and start over.

Message 9 of 14
JamesGL
Master

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Hi @DDavis99,

 

Have you tried to use the ReadyCloud App for Windows to access the files? Please check this article below and see if that helps.

 

http://kb.netgear.com/app/answers/detail/a_id/27662/related/1

 

Regards,

 

JamesGL

Community Team

Message 10 of 14
DDavis99
Aspirant

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Okay here is an update and it seems pretty bizarre to me.

 

Yesterday I did the factory reset on the R7000 and reconfigured it.  Upon boot up after the reset it recongnized that it's default subnet of 192.168.1.0 conflicted with the ATT router and automatically switched to 10.0.0.0, that's just for FYI.  After getting the router reconfigured there was no difference from the ReadyCloud point of view.  No shares on the portal and the portal as before was only showing the R7000 icon without showing the usb0 and usb1 icons.  The local ReadyCloud Client app running on my laptop continued to say the R7000 was "Offline".  My Window's Explorer app continued to show and give me access to both HDDs without issue.  I then decided to delete my ReadyCloud account, which I did and that was all I did last night.

 

Today I recreated my ReadyCloud account using the same userID and other account specifics.  Once I did this the local ReadyCloud app could connect to the R7000 but said I had no shares.  The web portal now showed the usb0 and usb1 icons below the R7000 icon, but no shares/folders/files etc.  Still not being sure that some of the issues are related to HDDs that aren't completely compatible I removed one of them and replaced it with a flash drive.  I followed this order for doing that.  First I deleted the share in the ReadyShare tab, then removed the drive using the button to remove the drive safely.  NOW after doing that the local ReadyClient app begins showing the share on the flash drive and when I click on that share in the ReadyCloud client it opens a Window's Explorer instance that gives me access to the drive just as if I had opened the instance straight from my desktop. NOW is when it gets interesting.

 

I then went back to the ReadyCloud web portal and the share shows up there too, but no files are in the share.  I know there are 3 files in the share.  The files show up in all instances of Window's Explorer.  I went ahead and removed the second HDD from R7000 in case it may be causing some type of interference. It does not appear to have made any difference.  I'm scratching my head on why I don't see the files from the portal but I do from the local client app, which seems to be accessing the share through the internet, but that more of a guess than fact.  So as a test, I did a drag and drop from Window's Explorer to the share in the web portal of the 3 files I have in the share and they successfully copied and then showed up in the portal.  But that was without any type of warning that I was coping the same files on top of themselves.  So next I copied a new file from my local drive and put it in the share on the web portal and it shows up in that share on the portal, but DOES NOT show up in the share from my local machine.  I then placed a new file in the share on my local machine and it DOES NOT show up in the share on the web portal.

 

I can only think that the web portal is using different space on the flash drive than shows up on my local machine.  Is that possible???  If so that ends up defeating most of the purpose of making the drive available via the internet.

 

Message 11 of 14
JamesGL
Master

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Hi @DDavis99,

 

Have you tried setting the Motorola to bridge mode and let the R7000 be the only router and DHCP server?

 

Regards,

 

JamesGL

Community Team

Message 12 of 14
Dan001
Aspirant

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

DDavis - Did you give up? I'm having the same issue, but not using ATT I'm on a Cox network. I can access and view the files via my iPhone and iPad, but using a web browser (firefox,Chrome,IE) I only see the router R7000 no sub directories. My Windows App just says off-line. And I see everything via \\readyShare (local network access).

Message 13 of 14
JamesGL
Master

Re: How to configure R7000 sitting behind Motorola NVG589 for ReadyShare/Cloud

Hi @Dan001,

 

I have replied to your other post.

 

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R7000-ReadyCloud-web-access-not-working-iOS-...

 

Regards,

 

JamesGL
Community Team

Message 14 of 14
Top Contributors
Discussion stats
  • 13 replies
  • 6930 views
  • 0 kudos
  • 5 in conversation
Announcements

Orbi WiFi 6E