Reply

R9000

meldgr8t
Aspirant

R9000

I followed the user manual on how to set up for dynamic dns, and it was successful. However, when testing my domain name, I'm getting the message 'The site can't be reached.' I'm getting the same message when testing my domain name from within as well as outside my LAN.
Anyone who can help?
Also, I have another question. Can I use freedns.afraid.org with R9000?
Message 1 of 18
antinode
Guru

Re: R9000

> However, when testing my domain name, I'm getting the message 'The
> site can't be reached.'

   How, exactly, are you "testing my domain name"?  What, exactly, is
emitting this "the message"?

   If you're using a Web browser, but you're not running a Web server,
or if you haven't configured appropriate port forwarding for it, then I
think that I can explain that result.

> Anyone who can help?

   You could, by supplying more information.  If you disclosed your
domain name, for example, then someone else could do a little
exploration.

Message 2 of 18
meldgr8t
Aspirant

Re: R9000

Here's my scenario:

1. My Internet IP address changes periodically (public ip address), that's why I'm setting up for dynamic dns

2. I have a web server (WAMP) at static ip address 192.168.100.100 on port 80, with Wordpress installed on it (for website development and testing)

3. Port Forwarding is set on 192.168.100.100, internal port 80, external port 80.

4. Mobile device and laptop connected to my LAN can browse to my wordpress test site

5. I registered for a free dynamic dns account via R9000, it was successful.

6. Let's just call my registered hostname as 'mytestlan.mynetgear.com'

7. When browsing to my 'mytestlan.mynetgear.com' inside my LAN and outside my LAN, that's when I received the message, 'The site can't be reached'.

Message 3 of 18
antinode
Guru

Re: R9000

> 6. Let's just call my registered hostname as 'mytestlan.mynetgear.com'

   Of course, hiding the real name hides all useful information.

> 7. When browsing to my 'mytestlan.mynetgear.com' inside my LAN and
> outside my LAN, that's when I received the message, 'The site can't be
> reached'.

   So, some Web browser or other.  Have you tried a utility like, say,
"nslookup" or "dig" to see if you can resolve the domain name?  (I'd try
it myself, but I don't know the real domain name.)  Have you tried using
your current public IP address instead of the domain name?

   The first question is whether the problem lies with name resolution
or the actual Web server.  Knowing nothing about your (unspecified) Web
browser, I can't interpret "The site can't be reached".

Message 4 of 18
meldgr8t
Aspirant

Re: R9000

Can you please step me through the process of setting up dynamic dns so that I can access my home network from internet using mynetgear.com host name? It's a nighthawk feature that I'd like to use. Hope you can help me? Thanks.
Message 5 of 18
antinode
Guru

Re: R9000

> Can you please step me through the process [...]

   Not I.  I have a real domain, so I've never needed to deal with
dynamic DNS.  I assumed that filling out the form on the router's Web

site at ADVANCED > Advanced Setup > Dynamic DNS would do the job.

   It can take some time (up to two days?) for DNS information to
propagate around the Internet, so, with no actual experience, I might
not expect it to work immediately.

> [...] Have you tried a utility like, say,
> "nslookup" or "dig" to see if you can resolve the domain name?  [...]

   Still wondering.  It seems to work for someone (I know not whom):

ALP $ nslookup fred.mynetgear.com
[...]
Name:    fred.mynetgear.com
Address:  89.98.5.170

 

ALP $ nslookup 89.98.5.170
[...]
Name:    dhcp-089-098-005-170.chello.nl
Address:  89.98.5.170

Message 6 of 18
meldgr8t
Aspirant

Re: R9000

I have managed to set up one:  rdtlan.mynetgear.com

I have a real domain name:  myrealdomain.co.nz from Domains4less, but without web hosting plan.

I have set up my local web server using xampp on my local pc. The website is accessed via http://rdtlan.mynetgear.com:3030

I want my friends to access my website using myrealdomain.co.nz instead of http://rdtlan.mynetgear.com:3030.

Are you able to help me with this please?

Many thanks,

Rommel

Message 7 of 18
antinode
Guru

Re: R9000

> I have managed to set up one:  rdtlan.mynetgear.com

   Yes, that domain name seems to work.

> I have a real domain name:  myrealdomain.co.nz [...]

   That one does not appear to work (yet?):

ALP $ nslookup myrealdomain.co.nz 8.8.8.8
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

*** google-public-dns-a.google.com can't find myrealdomain.co.nz:
 Non-existent host/domain

> The website is accessed via http://rdtlan.mynetgear.com:3030

   Why port 3030?

> I want my friends to access my website using myrealdomain.co.nz instead
> of http://rdtlan.mynetgear.com:3030.

   If name resolution of myrealdomain.co.nz starts working, then
"http://myrealdomain.co.nz" should get to your (router's WAN/Internet)
IP address on port 80 (or port 443 for "https://[...]").

   To make your Web server accessible from the outside world using the
normal port(s), you'd need to define a port-forwarding rule (or two).
For example:

                          Service  External   Internal   Server
#   Service Name          Type     Ports      Ports      IP Address
1   HTTP                  TCP/UDP  80-80      80-80      <pc_lan_addr>
2   HTTPS                 TCP/UDP  443-443    443-8443   <pc_lan_addr>

I'd guess that that's under ADVANCED > Advanced Setup > Port Forwarding
/ Port Triggering.  That assumes that the Web server on "my local pc" is
listening on the default port(s): 80 (and/or 443).

   Because a port-forwarding rule specifies the LAN IP address of the
target (server) system, that address must be fixed.  That can be done by
reserving a particular address for that system, perhaps under ADVANCED >
Setup > LAN Setup : Address Reservation.

Message 8 of 18
meldgr8t
Aspirant

Re: R9000

sorry, my real domain name is:  need4skills.co.nz

I'm using port 2929

installed xampp as web server on local pc, and wordpress to build my website

Message 9 of 18
antinode
Guru

Re: R9000

> I'm using port 2929

   Ok.  Why port 2929?  You can run your Web server with it listening on
(almost) any port(s) you'd like, but the port-forwarding rule(s) must
specify the actual destination ("Internal") port(s).  Otherwise, the
earlier advice still holds.

Message 10 of 18
meldgr8t
Aspirant

Re: R9000

Can you please simplify.  Reason why I used custom port 2929 is because port 80 is being used.

Message 11 of 18
antinode
Guru

Re: R9000

> Can you please simplify.

   Not much.  What's unclear?

>  Reason why I used custom port 2929 is because port 80 is being used.

   Who says "port 80 is being used"?  When did he say it?  Are you
running another Web server on that system (listening on port 80)?

   I really don't care at which port(s) your Web server listens, but 80
(and/or 443) is/are the default(s).  That's why any port-forwarding rule
for the Web server will normally specify one of these as the external
port number.  Otherwise, the user will need to specify the non-default
port number in a URL ("Smiley Surprisedther_port_number"), and you said that you don't
want that.  Similarly, whichever port the Web server uses, that must be

the destination (server/Internal) port in the port-forwarding rule.

Message 12 of 18
meldgr8t
Aspirant

Re: R9000

 Are you able to step me through the process of setting this up from the beginning using your method?  I'm a bit confused now, but with your help, I believe I'll be able to achieve what you are recommending.  Can you please?

Message 13 of 18
antinode
Guru

Re: R9000

> Are you able to step me through the process of setting this up from
> the beginning using your method?

   Not really.  There are too many variables, and you don't seem to
answer many questions.  I'd expect it to be more practical for you to
try to understand the principles, and then apply them.  One previous
attempt at such an explanation may be found here (although without any
odd-ball port numbers):

      https://community.netgear.com/t5/x/x/m-p/1380137

Message 14 of 18
meldgr8t
Aspirant

Re: R9000

I am trying to follow your suggestion in the process, it seems working now.  All I need help from you now is how to make my url without using the port number as suggested.  Can you please help me along these lines?

Message 15 of 18
antinode
Guru

Re: R9000

> I am trying to follow your suggestion [...]

   Which "your suggestion"?  Do you understand that I CAN'T SEE WHAT
YOU'RE DOING???

> [...] how to make my url without using the port number [...]

> "http://myrealdomain.co.nz" should get to your (router's WAN/Internet)
> IP address on port 80 (or port 443 for "https://[...]").
>
>    To make your Web server accessible from the outside world using the
> normal port(s), you'd need to define a port-forwarding rule (or two).
> For example:
>
>                           Service  External   Internal   Server
> #   Service Name          Type     Ports      Ports      IP Address
> 1   HTTP                  TCP/UDP  80-80      80-80      <pc_lan_addr>
> 2   HTTPS                 TCP/UDP  443-443    443-8443   <pc_lan_addr>

   "http://xxxx" "without using the port number" means using port 80.
The external port in the port-forwarding rule must be "80" if you want
to use port 80.

   If you need more help, then so do I: Copy+paste some actual
information, like the URL you want to use, the port-forwarding rules
which you're defined, and so on.

Message 16 of 18
meldgr8t
Aspirant

Re: R9000

I have defined my port forwarding rule:

http (service name)

Type: tcp

Port: (external and internal both on 2929)

Url:  rdtlan.mynetgear.com:2929 - I can access this website within my LAN as well as outside.  It is working fine, no issue with this.

 

All I'm asking now is if you can assist me make it so that my url is accessed without the port number, e.g., rdtlan.mynetgear.com

If this is taking so much of your time to extend a little help, then  that's fine.  I appreciate your time.  Cheers.

Message 17 of 18
antinode
Guru

Re: R9000

> Port: (external and internal both on 2929)

>    "http://xxxx" "without using the port number" means using port 80.
> The external port in the port-forwarding rule must be "80" if you want
> to use port 80.

Message 18 of 18
Top Contributors
Discussion stats
  • 17 replies
  • 1072 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E