Reply

Spectrum Internet 400mbps with Nighthawk only getting half speed

Whiteferret
Aspirant

Spectrum Internet 400mbps with Nighthawk only getting half speed

Here is the issue that I'm currently experiencing. 

  • I have a Nighthawk AC4000 and am trying to connect to the Spectrum network. I bought the 400mbps service. My PC connections are wired. 
  • When I connect the Nighthawk to the Spectrum Modem, the most speed I'm able to get through it is 200mbps.
  • When I connect the Nighthawk to the Spectrum Router which is then connected to the Spectrum Modem, the Nighthawk gets an IPv4 and IPv6 connection. When I run the Nighthawk's internal speed test it is able to pull 400mbps. When I connect the PC to the Nighthawk in this configuration the PC is still only able to pull 200mpbs. The PC gets an IPv4 address from the Nighthawk.  
  • When I connect my PC to the Spectrum Router which is connected to the Spectrum Modem I'm able to pull the 400mbps, but I get an IPv6 IP address instead of an IPv4 one. 
  • When I connect my PC to the Spectrum Router which is connected to the Spectrum Modem and disable IPv6, it gets an IPv4 address but is only able to pull 200mpbs. 
  • I know the Nighthawk router is capable of much higher speeds. I had it on the Verizon FIOS fiber network and it had no problem handling the gigabit connection and enabling PCs connected to it as well to have those speeds. 

Is it possible to turn off the IPv4 on the WAN side of the Nighthawk and have it only use IPv6 on the WAN, but still have an IPv4 LAN network? Would this solve the speed problem? Has anyone else encountered this problem? Can you configure the Nighthawk AC4000 to just use IPv6 exclusively instead of IPv4?  Help is greatly appreciated. Thanks! 

 

 

Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 1 of 26
Whiteferret
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

Update: QoS is disabled. Traffic meter is also disabled. 

Message 2 of 26
Grolin77
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

I have the same issue!
Message 3 of 26
Whiteferret
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

I'm starting to think that this is an issue with the Nighthawk router and Spectrum's network. When I take my PC and disable IPv6, and connect to Spectrum's Router, I still get my 400mbps+ on IPv4. The router however on the internal speed test still does not go above 200mbps.  

Message 4 of 26
plemans
Guru

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed


@Whiteferret wrote:

Here is the issue that I'm currently experiencing. 

  • I have a Nighthawk AC4000 and am trying to connect to the Spectrum network. I bought the 400mbps service. My PC connections are wired. 
  • When I connect the Nighthawk to the Spectrum Modem, the most speed I'm able to get through it is 200mbps.
  • When I connect the Nighthawk to the Spectrum Router which is then connected to the Spectrum Modem, the Nighthawk gets an IPv4 and IPv6 connection. When I run the Nighthawk's internal speed test it is able to pull 400mbps. When I connect the PC to the Nighthawk in this configuration the PC is still only able to pull 200mpbs. The PC gets an IPv4 address from the Nighthawk.  ----This would be a double-nat situation. 
  • When I connect my PC to the Spectrum Router which is connected to the Spectrum Modem I'm able to pull the 400mbps, but I get an IPv6 IP address instead of an IPv4 one. 
  • When I connect my PC to the Spectrum Router which is connected to the Spectrum Modem and disable IPv6, it gets an IPv4 address but is only able to pull 200mpbs. 
  • I know the Nighthawk router is capable of much higher speeds. I had it on the Verizon FIOS fiber network and it had no problem handling the gigabit connection and enabling PCs connected to it as well to have those speeds. 

Is it possible to turn off the IPv4 on the WAN side of the Nighthawk and have it only use IPv6 on the WAN, but still have an IPv4 LAN network? Would this solve the speed problem? Has anyone else encountered this problem? Can you configure the Nighthawk AC4000 to just use IPv6 exclusively instead of IPv4?  Help is greatly appreciated. Thanks! 

 

 


So when you go spectrum modem------->spectrum router------->PC, you're still getting 200 mbps? But not if it forces a IPv6 address? 

What spectrum modem are you using? 

What firmware is on your R8000P?

have you reset the R8000P and connected it to the spectrum modem and only setup the basic services such as ipv6 and ssid name/password? don't enable any traffic monitoring/qos/etc as they aren't recommended on >250mbps service. 

I'd try the reset as I've read of Qos settings being retain/ctf (cut through forwarding staying disabled even once qos shut off. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 5 of 26
Whiteferret
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

@plemans So the speed issue is not a double nat, because when the router is connected to the Spectrum Modem, the speeds do not change. I did reboots with a powering down between each test to make sure that settings may not be retained. The issue I'm having is that there is no way to disable the IPv4 through the interface for Nighthawk that I can find. 

I ran the test again last night when I go PC > Spectrum Router > Spectrum Modem with IPv6 disabled it initially only gives me 200mpbs. But then after 2 min if I run the test again I get 400+mpbs.  

I'm on the latest version of the Firmware, the update says there are no new versions available. (I'll update the post when I get the number) 

 

I was going to try and do a hard reset back to factory settings for the router tonight to see if that fixes the issue. This was a last resort measure for me because it means I will need to redo the network setup and access control for all the devices I have. 

 

Message 6 of 26
Grolin77
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

I did the hard reset and it didn't fix it!! It's frustrating
Message 7 of 26
plemans
Guru

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

Try this.

spectrum modem------spectrum router (setup for router mode with whatever gave you 400mbps)--------->Nighthawk in AP mode. What speeds do you get? 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 8 of 26
Grolin77
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

I don't have a spectrum router, I refuse their router because I have my own
Message 9 of 26
plemans
Guru

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

have you configured your ipv6 in the nighthawk?

 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 10 of 26
Grolin77
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

I don't know how to do it, I found a guide but it's not for my r7800
Message 11 of 26
plemans
Guru

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

this doesn't list the R7800 but it should be the same process
https://kb.netgear.com/24006/How-do-I-set-up-an-IPv6-Internet-connection-on-my-Nighthawk-router
Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 12 of 26

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

Have you tried adjusting the speed settings on your nighthawk router. I would also check the max speed settings for the 2.4 band and 5 band. Personally I would stick to only using the 5ghz band if possible because its speed cap is over 1000mbps. I have 100mbps service but I have netgear nighthawk r7450 attached to the main router and it created a subnetwork and instead of giving 192.168.0. IP addresses it gave all mine 10.0.0. IP addresses. The one pc is getting 585mbps.
Network products owned WNDR3300 WN3000RPV3 R7450 Dell R610 server A7000
Message 13 of 26
plemans
Guru

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed


@Computersystoms wrote:
Have you tried adjusting the speed settings on your nighthawk router. I would also check the max speed settings for the 2.4 band and 5 band. Personally I would stick to only using the 5ghz band if possible because its speed cap is over 1000mbps. I have 100mbps service but I have netgear nighthawk r7450 attached to the main router and it created a subnetwork and instead of giving 192.168.0. IP addresses it gave all mine 10.0.0. IP addresses. The one pc is getting 585mbps.

The R7800 or R7450 will never hit speeds >1gig over the 5ghz. It'll have a higher link rate but throughput is significantly less. Usually around 55% of link rate. https://www.duckware.com/tech/wifi-in-the-us.html

also if you're running a main router and the R7450 with a different subnet versus running it in AP mode, you're running a double nat. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 14 of 26
Mailnet
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

Upgraded to Spectrum 400mbps and cant get more then 200 mbps on my 

R7900 — Nighthawk X6 AC3000 Tri Band WiFi Gigabit Router

Please HELP !!!


 
Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 15 of 26

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

What is the category of the Ethernet cable because that might be why it you're only getting half the speed for wired connection. category 5e and higher allow faster speeds than category 5 http://ciscorouterswitch.over-blog.com/article-the-different-types-of-ethernet-cables-125299851.html
Network products owned WNDR3300 WN3000RPV3 R7450 Dell R610 server A7000
Message 16 of 26
Mailnet
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

Im getting 400 mbps wired, My issue is with the WIFI speed only getting 200 mbps.

And today, the Spectrum technitian whas here and connected Spectrum Router and showed me im getting 400 mbps on the wifi, but when i switched back to my Netgear router WIFI went sown to 200 mbps - ITS driving me CRAZY (-:

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 17 of 26
Mailnet
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

Just replaced the CAT5 Cable from Modem to Router to CAT5e and still not getting more then 200 mbps....

My router is set for 5gHrz / 1300

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 18 of 26

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

Is the NIC of your devices gigabyte capable
Network products owned WNDR3300 WN3000RPV3 R7450 Dell R610 server A7000
Message 19 of 26
plemans
Guru

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed


@Mailnet wrote:

Im getting 400 mbps wired, My issue is with the WIFI speed only getting 200 mbps.

And today, the Spectrum technitian whas here and connected Spectrum Router and showed me im getting 400 mbps on the wifi, but when i switched back to my Netgear router WIFI went sown to 200 mbps - ITS driving me CRAZY (-:


please start your own thread instead of hopping in on a different thread. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 20 of 26
Mailnet
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

Well, not sure how to check my NIC .... But the laptop im using is HP Spectra i7 Gen 10 (Brand New) . I also checking speed with my iphone which is iphone X.

Hope that answers your question ...?

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 21 of 26
Whiteferret
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

So my issue isn't restricted to Spectrum. I just switched to AT&T gigabit and am still having the same issue. I connect my computer directly and get 1gb download but through the router I don't get more than 250mbs. The router also on it's own internal speed test only get 350mbs down. The only thing I can surmise is that the earlier R8000s do not play well with IPv6 or something has gone wrong with the router. 

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 22 of 26
Whiteferret
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed


@plemans wrote:

Try this.

spectrum modem------spectrum router (setup for router mode with whatever gave you 400mbps)--------->Nighthawk in AP mode. What speeds do you get? 


 

 

I still get the same speeds. It's not going faster than 250-300 mbs. 

Message 23 of 26
Whiteferret
Aspirant

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed


@Whiteferret wrote:

So my issue isn't restricted to Spectrum. I just switched to AT&T gigabit and am still having the same issue. I connect my computer directly and get 1gb download but through the router I don't get more than 250mbs. The router also on it's own internal speed test only get 350mbs down. The only thing I can surmise is that the earlier R8000s do not play well with IPv6 or something has gone wrong with the router. 


If I turn off access control my download speeds double to 500mbs per second. During the speed test it starts off high then just falls over time. I'm suspecting that the router's internals are just starting to fail. 

Message 24 of 26
plemans
Guru

Re: Spectrum Internet 400mbps with Nighthawk only getting half speed

Try installing version 1.4.1.42 of the firmware (think you said r8000P). its the version prior to armor

Then factory reset and setup in ap mode again. 

In ap mode, many features that could be limiting are disabled. its all on the router. 

https://kb.netgear.com/26765/Disabled-Features-on-the-Router-when-set-to-AP-Mode

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 25 of 26
Top Contributors
Discussion stats
  • 25 replies
  • 9165 views
  • 0 kudos
  • 6 in conversation
Announcements

Orbi WiFi 6E