×  Introducing Nighthawk RS700 WiFi 7 (BE) Router. For more details, please visit Nighthawk Tri-Band WiFi 7 Router.

ReadyShare access on Nighthawk RAX20 after rebooting router


ReadyShare access on Nighthawk RAX20 after rebooting router



Have a Nighthawk RAX20 WiFi router. Recently I set up ReadyShare just for testing purposes by plugging in a 128GB USB Thumb Drive. I eventually want to add a USB powered hard drive for a more permanent solution.  


I successfully set up the drive and copied quite a number of files to it.  I was able to set up a mapping like this from the cmd prompt in Windows 10:


net use u: \\readyshare\USB_Storage


I think the first time I used this I was prompted for the user name and password, which is the router login/password.  After that, I was able to use drive letter access to copy files from the Windows explorer.


At some point recently, I rebooted the RAX20. After that, the drive letter access was lost. I tried to remap the drive using the same "net use...." command. I used the same user name and password that I did before. I get a system error 86 message:  The specified network password is not correct.


I went back into the router admin web page and unchecked "require password".  It still gives the same error message.  I don't need to reboot to reflect this change, do I?    I havent tried that yet, but I thought changes made to the router were immediate in cases like this.


Here is the information reported by the admin web page:


AX1800 (RAX20)

Firmware Version V1.0.11.112_2.0.77

Again, I'm using Microsoft Windows 10 Home: 

          Microsoft Windows [Version 10.0.19045.2364]


Funny thing also is that I can access the files in another way by using a URL:




Does anyone know of a way to fix this drive mapping issue so that I can use letters to access the drive once again?








Message 1 of 1
Discussion stats
  • 0 replies
  • 0 kudos
  • 1 in conversation

Orbi WiFi 6E