× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

No LED when powering up

jallison86
Aspirant

No LED when powering up

Came home today to find no Wi-fi from my Orbi system. The base unit appears inert -- when I cycle power no LED lights come on on the top. The power LED is on, so the unit is receiving power. Tried using a paper clip to reset but the power light never changes to amber. Any thoughts?

 

Thanks.

 

- Jeff

Model: RBR50| Orbi AC3000 Tri-band WiFi (Router Only)
Message 1 of 14
FURRYe38
Guru

Re: No LED when powering up

How long did you hold in the reset button? Hold it for 15 seconds at least until the top LED comes on Yellowish/Orange color. When you release the reset button, the top LED should start to blink WHITE. 

 

If you don't see any of this, I would contact NG support and ask for an RMA.

Message 2 of 14
jallison86
Aspirant

Re: No LED when powering up

I've held the reset button for 30+ seconds. I tried holding it down as I cycled power. Nothing. I purchased this unit in April, 2017, just over one year ago. Netgear does not appear to offer any sort of support beyond the $49.99 option. Given the price of the system I certainly hope there is some recourse here beyond simply, "it's dead, throw it away." 

Message 3 of 14
FURRYe38
Guru

Re: No LED when powering up

Might have someone check the power adapter voltage and amps to make sure they are ok. Some adapters can go bad. 

 

You might contact @AmitR or @DarrenM in a PM and see what options you have...

Message 4 of 14
jallison86
Aspirant

Re: No LED when powering up

Checking the adapter output is a good idea. I'll give that a shot. Thanks.

 

- Jeff

Message 5 of 14
FURRYe38
Guru

Re: No LED when powering up

Hope you can get someting going. Let us know how it turns out. 

Message 6 of 14
jallison86
Aspirant

Re: No LED when powering up

Finally got a chance to check the power supply output. It's right on spec -- 12v @ 3.5A. So unfortunately that's not it. Looks like I'm the owner of two very expensive bricks.

Message 7 of 14
FURRYe38
Guru

Re: No LED when powering up

I would contact NG support or @ChristineT and ask for help and information on this. See if an RMA is available to you. Let us know if you find out anything.

 

 


@jallison86 wrote:

@Finally got a chance to check the power supply output. It's right on spec -- 12v @ 3.5A. So unfortunately that's not it. Looks like I'm the owner of two very expensive bricks.




 

Message 8 of 14
DarrenM
Sr. NETGEAR Moderator

Re: No LED when powering up

Hello jallison86

 

I have sent you a PM about your unit.

 

DarrenM

Message 9 of 14
FURRYe38
Guru

Re: No LED when powering up

Thank you Sir.


@DarrenM wrote:

Hello jallison86

 

I have sent you a PM about your unit.

 

DarrenM




 

Message 10 of 14
powdahound
Aspirant

Re: No LED when powering up

I woke up to this exact same issue this morning. Green power LED, no wifi or ethernet activity, and no ring colors on top of the unit. Totally unresponsive to the reset button as well.

 

@DarrenM — Can you help me out as well? Thanks

Model: RBR50| Orbi AC3000 Tri-band WiFi (Router Only)
Message 11 of 14
FURRYe38
Guru

Re: No LED when powering up

Let us know how it turns out.

 

Message 12 of 14
powdahound
Aspirant

Re: No LED when powering up

edit: Nevermind. Found this RMA page via Google: https://kb.netgear.com/1162/How-can-I-get-a-Return-Material-Authorization

 

@ChristineT @DarrenM - Pinging you both here again since I'm not sure how to initiate an RMA request for this hardware which appears to be dead. Is signing up for a paid support plan the "right" way to get help? I'm having the exact same issue as the user who started this thread.

Message 13 of 14
DarrenM
Sr. NETGEAR Moderator

Re: No LED when powering up

Hello Powdahound 

 

I have sent you a PM.

 

DarrenM

Message 14 of 14
Top Contributors
Discussion stats
  • 13 replies
  • 3841 views
  • 2 kudos
  • 4 in conversation
Announcements

Orbi 770 Series