Introducing the Orbi 970 Series Mesh System with WiFi 7(BE) technology. For more information visit the NETGEAR Press Room.

Orbi WiFi 7 RBE973

RBK50 Mesh 2.4Ghz Issue


RBK50 Mesh 2.4Ghz Issue

Hoping for some assistance as after reading these forums and Reddit and trying various settings I am still experiecing issues that I cannot seem to resolve.



My iMac (2012) and MacBook Pro continually connect to my 2.4Ghz network as opposed to the 5Ghz network while other devices in the same room connect and stay connected to the 5Ghz network. I've tried turning down the TX power to 50% and this does something but then the issue is the devices connect to the 5Ghz and then bounce between the two bands which causes disconnects and it causes issues with my older 2.4Ghz devices. The connectivity on the 2.4Ghz band is awful and changes frequently, it can drop right down to 5Mbps and then jump up to 144Mbps which is causing issues on Zoom/Teams etc. 


Ideal State:

Fix the 2.4Ghz random speeds and latency to something more consistent for my older devices

Ensure my Mac's connect only to the 5Ghz band




Region: Europe



  • Disabled 20/40 MHz Coexistence
  • Enable WMM (Wi-Fi multimedia) settings
  • CTS/RTS Threshold = 2347
  • Preamble Mode = Long
  • Transmit Power Control = 100%
  • Channel = Auto (tried 1, 6 and 11 - same issue)


  • Enabled WMM (Wi-Fi multimedia) settings
  • CTS/RTS Threshold = 2347
  • Preamble Mode = Long
  • Transmit Power Control = 100%
  • Channel = 44

Security = WPA2-PSK [AES]

Enabled Daisy-Chain Topology (1 Router + 2 AP's)

Enabled Implicit BEAMFORMING - Boosts WiFi speed, reliability, & range for all mobile devices

Enabled MU-MIMO

Disabled Fast Roaming


Thank you in advance



Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 1 of 4

Re: RBK50 Mesh 2.4Ghz Issue

Try setting 2307 for CTS. 

Try disabling MIMO and Beamforming to see.


If these are the only two devices having problems while others don't, I would contact Apple support as well for help and information regarding there products.

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode  | Wifi Router RBKE963 and RBE973 | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX30/CAX80/CM1100/CM1200/CM2000, Orbi: CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MK93S, R7000, R7800, R7960P, R8000, RAXE500, RAX120v2, RAX50v2, XR450/500/700/1000,

Message 2 of 4

Re: RBK50 Mesh 2.4Ghz Issue

My guess is the solution will be found on the iMac, rather than the Orbi.  Most Windows WiFi adapters have settings for which bands are active.  (I have no iMac, but a search turned up this: https://becomethesolution.com/blogs/mac/macos-how-to-force-connect-to-5ghz-or-2-4ghz-wifi-band-same-... )

I love my Orbi.
Message 3 of 4

Re: RBK50 Mesh 2.4Ghz Issue

Thanks I'm trying this and seeing how it performs during the next day, currently have been monitoring it and while it doesn't appear to have had the desired effect I'll leave it for a little longer

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 2 kudos
  • 3 in conversation

Orbi WiFi 7