Reply
Highlighted
Guide

Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

Since the update to 2.0.0.74, periodically my Internet speed will slow down from the normal 65+Mbps to around 8Mbps and occasionally as slow as 1Mbps (as per speedtest.net), and I'll see ping latency just to the router itself from a wired connection as high as 300ms or even higher. (The cable between the router and the computer doing the testing is a 1 meter cat 6 ethernet cable.) When this happens, pings to other devices on the network do not appear to be affected.

 

It's not specific to any one machine on my network. Rebooting the router resolves the speed issue 100% of the time. I've ruled out my cable modem as the problem by rebooting it first, which changes nothing.

 

I didn't have this issue prior to the 2.0.x.x upgrade.

 

Any suggestions?

Message 1 of 17
Highlighted
Master

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

I would make sure the router and sats are all on the same firmware revision.  Then I'd try a factory reset of the router.

Message 2 of 17
Highlighted
Guide

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

I'll give this a shot. If I backup & restore, will that restore potentially cause whatever issues I'm having now to return?

Message 3 of 17
Highlighted
Master

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

I can't say for sure, but I would setup from scratch if it's not too much trouble. You can always make a backup and only use it if necessary.

Message 4 of 17
Highlighted
Guide

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

I am having this same exact issue. A reboot fixes the issue for a little bit but it comes back. 

Message 5 of 17
Highlighted
Luminary

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

seems to be better after implicit beamforming switched OFF (unticked under advanced wireless and and moved from channel 11 to 6 (not sure which of these fixed it).   Mu-MIMO and fast roaming are still ON (2.0.0.74)

Message 6 of 17
Highlighted
Guide

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

Did you apply that while the issue was occurring?
Message 7 of 17
Highlighted
Guide

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

Sorry for the delayed response, I needed a time when nobody else needed the network to do the setup. 

I did a factory reset and I did reload the configuration settings from a save. I'm going to give it a day or so (this has been happening pretty frequently, so I'd certainly see it at some point over the weekend) and if it comes back, I'll rebuild from scratch. I took screenshots of all the settings so it'll be tedious but I have the info. I'll get back in another couple of days as to whether this worked.

Message 8 of 17
Highlighted
Guide

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

Unfortunately, after the reset to factory default (from the Backup Settings tab) and reloading the saved config, there was no change in behavior. I then did a reset again and this time rebuilt the configuration from scratch. That didn't help either. Within 24 hours (could have been less, I wasn't constantly checking) it had reverted back down to the slow speeds again.

 

What do I do now? Is there another way to some kind of lower-level reset that might help?

 

Is there any chance this could be related to the latest firmware upgrade, since I'm pretty sure that's when I started seeing this issue. Is there a way for me to revert back? This is getting pretty annoying.

Message 9 of 17
Highlighted
Guide

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

Anyone?

Message 10 of 17
Highlighted
Guide

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

I am also having shocking internet since the latest update. It takes forever to open a page and I'm constantly getting kicked off lasptass because it can't connect.

 

I really think this system is awful and I wish I could get my money back.

Message 11 of 17
Highlighted
Aspirant

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

Hi,

 

I'm having a similar issue (though not as pronounced) since the last update (1 router and 2 satellites). I usually get download/upload around 85mbps and recently the download is maxing out around 40mbps (upload is fine). I know someone posted something about it somewhere, if I somehow find a solution, I will confirm here as well.

 

G.

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 12 of 17
Guide

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

I've got an update on what's been happening: I realized that although I'd done a restore factory defaults from the web interface, I had not yet done a reset directly on the devices themselve. I'll do that shortly.

 

However, I discovered one very odd thing: I decided to check other devices on my network, both wired and wireless, when the issue occurred. Surprisingly, performance on all the devices I tested, both wired or wireless, seemed fine. One thing I found was that my main PC (the one I've been testing with) is plugged into a switch which is connected to the router. I don't believe it's the switch itself (since I haven't touched that), but I've now swapped the cable to my main PC to go directly to the Orbi. I'll give it a day or so and see what happens.

Message 13 of 17
Highlighted
Aspirant

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

Thanks for the feedback.

 

So I played around yesterday (one change at a time) : rebooted the router (seemed to improve the DL a little bit), switched it to AP mode (I had left it in router mode but really it makes more sense to have it in AP) and it might have helped a tiny bit but...the one thing I noticed is that I get different dl/up speed results depending on the internet speed test I use.

 

From the Orbi app and Ookla website, I get around 45 mbps DL and 85-90 up.

When I use Bandwith Place, Fast.com, Testmy.net or the Verizon tester, I get 85-90mbps in DL!

 

Not sure which one to trust now!!

Message 14 of 17
Highlighted
Apprentice

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

I wouldn't think you could compare different speedtest implementations. Even if they use the same technology, they wouldn't likely use the same servers and routes. I don't trust my ISP's speedtest, even though it is Ookla's technology, because they test against one of their own servers. I want to know how fast I can work with servers that are outside my ISP's bulwarks.

 

Message 15 of 17
Highlighted
Aspirant

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

I have exactly same issue with my Orbi setup with one router and two satellites. After reboot the system is fast but slows down quite soon. The discussion in this thread ended couple of months ago but was there any solution to the problem?

Model: RBR50| Orbi AC3000 Tri-band WiFi (Router Only)
Message 16 of 17
Highlighted
Guru

Re: Orbi RB50 periodic slow internet speeds since 2.0.0.74 - fine after reboot

If you have a RBK50 or RBR50 series kits, please try the beta FW:

https://community.netgear.com/t5/Orbi/Orbi-MR-2-1-Update-3-23-18/td-p/1533584/jump-to/first-unread-m...

 

Do a factory reset on both router and Satellite then set up from scratch.

 


@peekkiwrote:

I have exactly same issue with my Orbi setup with one router and two satellites. After reboot the system is fast but slows down quite soon. The discussion in this thread ended couple of months ago but was there any solution to the problem?


 


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK50 v2.7.0.70(AP Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 17 of 17
Top Contributors
Discussion stats
  • 16 replies
  • 5723 views
  • 4 kudos
  • 9 in conversation
Announcements