Reply
Highlighted
Aspirant

Orbi Slow Internet Speed

I have an Orbi now updated to the latest firmware 1.12.0.18 and my internet speed is about 1/2 of my 115MB service. It is the same either with a wireless connection or wired directly to router pod (RBR50). My internet speedtest speed is 115MB when directly connected to my cable modem or when using an older router for testing.

 

Through Orbi system my internet speed is always about 50MB.

 

Any suggestions? I'm now sort of desperate.

 

Is this a firmware upgrade issue? I used to have my full speed on my connection.

 

So far I have worked with QOS and other settings. I have also done a full reset and reloaded everything.

 

I will return the system if it's just me. I may also look into downgrading the firmware version.

Message 1 of 7
Highlighted
Apprentice

Re: Orbi Slow Internet Speed


@rkrigsman wrote:

I have an Orbi now updated to the latest firmware 1.12.0.18 and my internet speed is about 1/2 of my 115MB service. It is the same either with a wireless connection or wired directly to router pod (RBR50). My internet speedtest speed is 115MB when directly connected to my cable modem or when using an older router for testing.

 

Through Orbi system my internet speed is always about 50MB.

 

Any suggestions? I'm now sort of desperate.

 

Is this a firmware upgrade issue? I used to have my full speed on my connection.

 

So far I have worked with QOS and other settings. I have also done a full reset and reloaded everything.

 

I will return the system if it's just me. I may also look into downgrading the firmware version.


You have to check that your device is connecting to the Orbi with the 5GHZ band.  Your speed will be reduced if your device connects with the 2.4.  You can't really control this but I found that enabling Implicit Beamforming and MU-MIMO in the advanced wireless settings helped my devices stay connected to the 5GHZ band and speeds have increased.

Message 2 of 7
Highlighted
Aspirant

Re: Orbi Slow Internet Speed

This speed reduction is when directly connected to the main router or when on WiFi. Same speeds, just about 1/2 of my speed when directly connected or using my old Belkin router.

 

 

Message 3 of 7
Highlighted
Apprentice
Apprentice

Re: Orbi Slow Internet Speed

I had the exact same problem on my RBK50 setup. Rolling back to 1.11 fixed things. It’s a shame that none of the reviews have pointed out the mess that is Netgear’s firmware. 😡

 

 


 

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 4 of 7
Highlighted
Aspirant

Re: Orbi Slow Internet Speed

Great suggestion. I think that this did it. Many thanks! 

 

I downgraded firmware to 1.4.0.34 at the router and redid the speed test and I now have my full internet speed (115MB). 

 

Just an fyi for those that read this, until I went to QOS and redid the speed test there, the satellites didn't reach my full internet speed but the max speed that was in there from previous test. 

 

 

Message 5 of 7
Highlighted
Aspirant

Re: Orbi Slow Internet Speed

Had to roll back to 1.11 myself.  Got my old speed back. You would think they would test updates out before screwing everybody over.

Message 6 of 7
Highlighted
Apprentice
Apprentice

Re: Orbi Slow Internet Speed

I thought that 1.11 had corrected my issues, but I found there were certain spots in my home, mostly in the back yard, where my iPhone would seem to hop back and forth between the router and satellite before deciding that LTE was better. 1.12 fixed that.

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 7200 views
  • 1 kudo
  • 4 in conversation
Announcements