Reply

redirecting Google search page

DZone
Aspirant

redirecting Google search page

I have an Orbi RDR20 at firmware v2.1.4.16 which is apparently redirecting www.google.com to Japan’s www.google.co.jp. This happened after hitting several Japan websites while scheduling a trip. This problem occurs with all my Win and iOS devices, including those not used for years. Swapping the RDR20 with another manufaturer’s router completely solves the problem. Reset to factory settings fails to resolve problem. Is there a location cached in the RDR20? Can it be cleared?
Message 1 of 8
FURRYe38
Guru

Re: redirecting Google search page

Factory reset should clear any possible caches on the router. Use the ERASE feature in the UI or press the reset button until the top led turn on Amber. Then let go. Wait for the top led to pulse WHITE slowly then set up from scratch.

 

Try inputting your ISPs DNS using static DNS entries on the router.

Besure to clear any bowser caches as well.

 

Whats the mfr and model# of the ISP modem the orbi is connected too?

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 2 of 8
DZone
Aspirant

Re: redirecting Google search page

Thanx for responding.

Tried the factory reset several times according to instructions — no joy.

Also, tried static DNS addresses using Orbi dashboard — no joy.

Also tried ipconfig /flushdns and /release,/renew.

tracert shows consistent hops to a Calif Google site, then destination 1st octet mostly 172 but occasionally 216. Regardless, the end screen always is Google Japan.

Modem is Ubee DDM3521(?) from ISP, Spectrum.

Seems strange that a router would cause such a selective problem. ISP seems clear as simply swapping the router resolves the issue. Could culprit be tables at Google itself?
Message 3 of 8
FURRYe38
Guru

Re: redirecting Google search page

Try using the following DNS on the router:

1.1.1.1 and 9.9.9.9

 

@DarrenM

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 4 of 8
DZone
Aspirant

Re: redirecting Google search page

Thanks for the suggest but again, no joy. Tried Quad9 9.9.9.9 (as tribute to 36yr career w/Big Blue’s big iron). But rejected by Big Bro’ ISP (Spectrum).

W/out evidence of Orbi intelligently managing an internal routing table, it seems
more likely that Google is using an algorithm
which flagged my Orbi as belonging to a Japanese national — especially, analyzing website history and using an “arp”-like command to id my router. In these days of customer data mining and profiling, I wouldn’t be surprised.
Message 5 of 8
FURRYe38
Guru

Re: redirecting Google search page

Lets see if a forum moderator can help out...

@DarrenM

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 6 of 8
DZone
Aspirant

Re: redirecting Google search page

All, the problem has resolved without any intervention other than time. This adds to the suspicion that the improper redirect to Google-Japan may have been the result of a profile error at the Google-USA site. If (a big IF) that is true, that profile was associated with the Orbi router device itself since all end-user devices were ok when the Orbi was offline (swapped out or powered off) . Thanks to all for your suggestions and patience.
Message 7 of 8
FURRYe38
Guru

Re: redirecting Google search page

Glad it's working now, enjoy. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1090 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E