× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Gbit Ethernet Flow Control on RN104

HolgerGT86
Guide

Gbit Ethernet Flow Control on RN104

Hello Community,

I have a question to my ReadyNAS RN104 running at FW level 6.10.4.

When I look into the network interface settings, there's no information about flow control for Gbit Ethernet adapters. I cannot figure out if flow control is enabled or disabled. 

Is there a way to find this out? 

I'ld like to disable flow control if it's enabled. Is there a way to disable flow control?

-

I searched in this forum but the only thread I found was mentioning as an aside that flow control is enabled by default on a RN104. Please forbear with me if I did not find the right thread.

-

Thanks and regards, 

Holger

Model: RN104|ReadyNAS 100 Series 4- Bay
Message 1 of 3

Accepted Solutions
StephenB
Guru

Re: Gbit Ethernet Flow Control on RN104


@HolgerGT86 wrote:

I cannot figure out if flow control is enabled or disabled. 

Is there a way to find this out? 

You have to use ssh (ethtool).  I see this on my RN102:

root@RN102:~# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Link detected: yes

This says that pause frames (ethernet flow control) are not supported. FWIW, it is supported  (and enabled) on my x86 ReadyNAS.

View solution in original post

Message 2 of 3

All Replies
StephenB
Guru

Re: Gbit Ethernet Flow Control on RN104


@HolgerGT86 wrote:

I cannot figure out if flow control is enabled or disabled. 

Is there a way to find this out? 

You have to use ssh (ethtool).  I see this on my RN102:

root@RN102:~# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Link detected: yes

This says that pause frames (ethernet flow control) are not supported. FWIW, it is supported  (and enabled) on my x86 ReadyNAS.

Message 2 of 3
HolgerGT86
Guide

Re: Gbit Ethernet Flow Control on RN104

Hi StephenB,

many thanks for your reply and sorry for my delayed response. My RN104 set the RAID5 volume to read only resulting from a filesystem failure and I had to start over and restore from backup. I was tied up by doing the recovery. All good now.

 

Have a great day,

Holger

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 1103 views
  • 1 kudo
  • 2 in conversation
Announcements