Reply

WN2500RP not connecting to internet but connects to router

Southcanuck
Follower

WN2500RP not connecting to internet but connects to router

I recently upgraded my Xfinity Comcast router from 200 MBPS to a new router with 1000 MBPS and I also have Ring doorbells and camers.  The front door is on the Ring doorbell which worked fine before I changed the router.  Between the router and the Ring door bell is a Netgear WN2500RPv2.  

When I check the Netgear WN2500RP on both the 2.4G and 5G both lights are lit up green and when trying to connect to either one of those bands widths on my cell phone it tells me no internet.  When I connect to the router directly wirelessly (without the _2GEXTor _5GEXT) it connec ts no problem.

 

Also have another and newer extender model EX6110 with the same issue as this extender is uded for my Driveway Ring camera and the same issues.

I am getting really frustrated with this so called plug and play that doesn't work.  Netgear want a fee to help toubleshoot which I feel is outrageous and totally ridiculous.  Not sure how this company has survive this long without someone complaining of their support and wanting to make money not only their equipment which is fine but for support that is bad customer relations in my opinion.

I just want my network to simply work.

Can anybody help?

 

Model: WN2500RPv2|N600 WiFi Range Extender
Message 1 of 6
plemans
Guru

Re: WN2500RP not connecting to internet but connects to router

which comcast router is it? 

During install of the extenders, did you setup using WPS? If so, factory reset the extenders and reinstall them using the installation assistant. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 2 of 6
Nippalz
Aspirant

Re: WN2500RP not connecting to internet but connects to router

I have this exact same issue.  Used the installer to connect to the wifi.  Connects and shows zero service.  Any updates?  Firmware is also updated


@plemans wrote:

which comcast router is it? 

During install of the extenders, did you setup using WPS? If so, factory reset the extenders and reinstall them using the installation assistant. 


 

Model: WN2500RP|Universal Dual Band WiFi Range Extender
Message 3 of 6
plemans
Guru

Re: WN2500RP not connecting to internet but connects to router

@Nippalz Please start your own thread instead of jumping in on someone elses and we're happy to help. 

Include the details from your setup and where its failing in the process. The more details the better. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 4 of 6
entfish
Aspirant

Re: WN2500RP not connecting to internet but connects to router

I have the same problem. It's driving me nuts. I'm disgusted that Netgear won't help without payment!

What is the "installation assistant" and how do I access it?

Message 5 of 6
plemans
Guru

Re: WN2500RP not connecting to internet but connects to router

@entfish factory reset your extender. Then starting from stock use the assistant. I linked to the video of how to use it. 

How to Setup your WiFi Range Extender with NETGEAR Installation Assistant - YouTube

 

If that doesn't help, please start your own thread. thanks

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 357 views
  • 1 kudo
  • 4 in conversation
Announcements

Orbi WiFi 6E