× NETGEAR would like to hear from you about specific features so we can improve your experience. To participate in this survey please click HERE.

Wireless connects but no internet


Wireless connects but no internet

It used to work without problem, but not now.

EX7300 worked fine with Netgear router r7000 in the past time until r7000 died. And Paired EX7300 with the new router from ASUS. It worked at the beginning but lost internet connection totally now. 


Factory Reset and reset-up is not helpful at all. It can be found ip (sometimes ip is gone) and can connect to the router, but still no internet. 

Iphone can found its _ext network, but it shows no internet connection whatever how to set up the EX7300.

what is wrong with it?

Model: EX7300|AC2200 Nighthawk X4 Wall-plug Range Extender
Message 1 of 2

Re: Wireless connects but no internet

Hi @aubylife,

                     Try to setup the extender with correct password for your new router. Do modify wireless channel on router if required. Also, check for firmware upgrade for your EX7300.

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation

Orbi WiFi 6E