× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Nighthawk M6 Pro Unlocked Hotspot 5G mmWave
Reply

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

mishref
Tutor

Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

I am testing a IP Passthrough mode on the Netgear M5. It limits the speed of the connection to ~200Mbps when enabled. When I revert to normal (router) mode and double-nat,  the connection speed is 500-800Mbps. 

 

Tests were run over ethernet and the router was factory reset before each test. Is this a device limitation or firmware issue?

 

Device: Nighthawk M5 (MR5200)

Firmware: NTGX55_10.12.05.00

PRI: 02.04

 

 

 

Message 1 of 12
Dalilama
Initiate

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

Strange behavior can you verify if the slower Throughput rate from the MR5 end or the router connected to it.
Message 2 of 12
mishref
Tutor

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

Both - I connected it directly to the ethernet port (of two different devices) for testing.

And after the last firmware update, passthrough mode stopped working altogether.
Message 3 of 12
Dalilama
Initiate

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

Extremely disappointing, they killed the option rather than fixing it. Had high hopes for this 5G router.
Any feedback from support?
Message 4 of 12
Ramesses
Aspirant

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

I’m facing the same issue with MR5100 NTGX55_10.12.05.00 FW from Zain Kuwait. IP Passthrough disables the internet and I gonna return the unit as this is the only reason I got it in the first place.

In router GUI dashboard, it shows that Zain KW(5G) Not connected.

Netgear should fix this ASAP as this is one of the main advantages to make me choose Netgear over Huawei
Message 5 of 12
nmperera
Initiate

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

Although this is a 5g cellular, the router is only 1g. So the input can be 5g, but the output is 1g. Unfortunately this model does not have a 10g lan or sfp+port, so you are limited to getting less than 1g speeds unless you can use wifi. I think, netgear missed the point of having the 5g cellular with 1g ethernet that limit some users who rely on wired connections.

Cheers,

Madura

Message 6 of 12
mishref
Tutor

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

Ethernet connection is fine, I have gotten stable speeds of 800-900mbps over it (which is amazing for 5G). My issue is that passthrough mode (disabling the double-nat) was slow. In the latest update it doesn't work altogether. 

 

Message 7 of 12
Ramesses
Aspirant

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

What I noticed, when you reset the router to factory settings, and directly turn on IP passthrough without changing any other settings, IP passthrough could work, if it doesn’t keep restarting the router till it works.

It worked for me when I was using the battery without connecting the router to any other device through ethernet or wifi. However, if the router restarts, it could go back to disconnected and you have to keep restarting again.

This is not practical at all and not even usable, there should be a software update to fix the issue to be able to use the feature as it supposed to be
Message 8 of 12
alanplum
Aspirant

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

I got my MR5200 EUS today. Immediately upgraded to ntgx55_10.29.10.00

In IP pass though my WAN port flaps up and down.
In router mode (double Nat) it behaves perfectly fine.

Seems there is an issue with ip passthrough.

I had it on my Edgerouter in failover mode, and it pings 8.8.8.8 for the upstream connectivity link. I noticed in IP passthrough it was constantly reachable/unreachable. Flapping. Double NAT it works fine
Message 9 of 12
alanplum
Aspirant

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

I’ve fixed my issue....

So apparently the “flapping” issue is an issue with EdgeRouters. I have an ER-X.

If the LTE WAN IP address is passed with a subnet of 255.255.255.255 then the edgerouter will have issues with IP Passthrough. There is a workaround, but Netgear kindly added an LTE Subnet Mask option on the MR5200.

I changed my MR5200 back to IP Passthrough and changed the LTE Subnet Mask to 255.255.255.0, and boom, everything is working perfectly. Thank you Netgear for adding that option.

The 2 posts that gave me the answer to my problem:
https://community.ui.com/questions/Flaky-network-behaviour-Nighthawk-M1-IP-passthrough/2105499c-bb81...
https://forum.netgate.com/topic/139948/netgear-4g-modem-on-wan-port-weird-ip-address-and-no-internet

Hopefully this will help someone in the future.

It didn’t really affect me as on EE in the UK is CGNAT, but didn’t want to double Nat as well just because it’s not an ideal thing. 5G speed is excellent.
Message 10 of 12
alanplum
Aspirant

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

I can also confirm however that in IP Passthrough mode, WAN speed appears to be throttled to ~200Mbps as per the original post. 

When in router mode with double Nat, I'm getting 300-400Mbps

Message 11 of 12
jangal
Aspirant

Re: Slow internet with ip passthrough mode on MR5200 (M5 - 5G device)

I know this is old, but came here to add to the speed throttling concerns on IP Passthrough.  It's stuck at 150-200mbps no matter what I do.

 

Simply removing IP passthrough increases the speed up to 600mbps.  All the diagnostics like cell ID and channel number are exactly the same.  

 

What gives?

Message 12 of 12
Top Contributors
Discussion stats
  • 11 replies
  • 7131 views
  • 3 kudos
  • 6 in conversation
Announcements

Orbi WiFi 7