× You're Invited! Orbi RBK763 Beta Firmware Testers Needed. To participate in testing this trial firmware, please click HERE.

Raspberry Pi 4 WiFi and ethernet connections stop working a few hours after reboot


Raspberry Pi 4 WiFi and ethernet connections stop working a few hours after reboot

I have recently replaced my old Netgear R6300 WiFi router with a new Netgear Orbi AX4200 router (RBR750, firmware version V3.2.15.25_1.3.15) and 2 satellites (RBS750). I have a Raspberry Pi 4 computer that worked just fine over a WiFi connection to the R6300.


Then I set up the new Orbi with the same SSID and password and verified that the Raspberry Pi connected to the new network just fine.


A day later I noticed my Raspberry Pi go offline when I could no longer access a website running on it. I rebooted it and it started working again, but it went offline after 3 to 5 hours again. I had thought reusing the same SSID may be the problem, but from what I could tell, the only information the Raspberry Pi uses to connect to a network is the SSID and the password I provided it in the /etc/wpa_supplicant/wpa_supplicant.conf file.


When I ran the "ip addr" command on the Raspberry Pi, it still said the connection was up and had the same ip address, but I could not connect to the internet from the Raspberry Pi or connect to the Raspberry pi from another computer. I could not fix the connection issue by resetting the WiFi driver on the Raspberry Pi so I still had to reboot to fix the connection.


I tried connecting the Raspberry Pi to an ethernet switch connected to a WiFi to ethernet bridge and I noticed the same issue on both network interfaces after a few hours of uptime.


I tried updating the Raspberry Pi OS to the latest version of Raspbian GNU/Linux 10 (buster).


Using another router ASUS RT-AC1200 for the Raspberry Pi and connecting the Orbi (still in router mode) to the ASUS fixes the WiFi issue, but seriously degrades internet performance of the devices connected to the Orbi.


I have a feeling it has something to do with layer 3 rather than layer 2 since it is the ethernet interface connected indirectly to the Orbi and not just the WiFi interface directly connected to the Orbi.


How can I fix this issue? Is this an issue with the Orbi or is it a problem with the Raspberry Pi 4?

Message 1 of 2

Re: Raspberry Pi 4 WiFi and ethernet connections stop working a few hours after reboot

Does this Pi4 have any kind of DHCP server running on it? 


Try disabling AX mode? 


Might try updating to v6 FW, factory reset and setup from scratch:


My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX30 Mode Mode  | Wifi Router XR500 and RBK863 Router mode | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX3/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX120v2, RAX50v2, XR450/500/700/1000, EX7500/EX7700

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation

Orbi WiFi 6E