×  Introducing Nighthawk RS700 WiFi 7 (BE) Router. For more details, please visit Nighthawk Tri-Band WiFi 7 Router.

Orbi 2.x Unable to Connect (iPhone 7s, Galaxy S7, S7 Edge & S8+, Samsung KS8500 TV)


Orbi 2.x Unable to Connect (iPhone 7s, Galaxy S7, S7 Edge & S8+, Samsung KS8500 TV)

The following is what I have been able to verify from about 2 weeks of experience and everything happens several times (2-6 times) a day.


When using the firmware 1.x the issue was happening probably 1 time per week, after upgrading to the 2.x it happens several times a day.

Basically the issue is that when I move from one position of the house to another (getting closer to another satellite or the main router) the Samsung Galaxy S7, S7 Edge, S8+ or even the iPhone 7S and the Samsung KS8500 TV all give the same issue in regards to the following errors while trying to connect:


- internet may not be available

- unable to connect

- disconnect/reconnect periodicallly (Samsung TV Mostly by phones do it too)

So they basically can't connect to the wireless satellite/router at some point, nor do they correctly check if there is internet.


Now, all devices were working correctly with an Asus RT5300 and a Asus RT68U that I have (which I will sell since the Orbi basically solves multiples issues for me, except for this issue I am mentioning).


My setup is the RBK50 Router, 1 RB50 Satellite and 1 RB40 Satellite as mentioned in this 2 links from Amazon:






I have turned off, rebooted, factory reset and everything this routers already just to see if that solved the issue but still it is there and it got even worse with the 2.x firmware versions.


If I can be of any help to debug this and test it out with the multiple devices I have, then you can count me in to make sure the whole mesh networks works correctly.


Note that I do get full internet speed around the whole house (100Mbps) which was not possible with both Asus Routers.


I have uploaded an image showing the router and satellites

Screenshot from 2017-10-18 07-29-18.jpg




Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 1 of 8

Re: Orbi 2.x Unable to Connect (iPhone 7s, Galaxy S7, S7 Edge & S8+, Samsung KS8500 TV)

If it helps, I just purchased another RB50 Satellite just in case the RB40 is causing some weird issue, this way everything is RB50 (Just in case). But would be happy to help in testing out any firmware that would solve this.

Message 2 of 8

Re: Orbi 2.x Unable to Connect (iPhone 7s, Galaxy S7, S7 Edge & S8+, Samsung KS8500 TV)

Am adding a couple of test results I found today. Whenever I connect to a satellite on a phone, desktop PC, laptop or TV, the speed goes from 100mbps to around 50mbps. It sometimes jumps to 60mbps but that's it. So connecting to a satellite has a drop rate of 50% of my internet speed.

Along with that, satellite devices do drop the clients from time to time, randomly (about 1 to 2 times per day).
Message 3 of 8

Re: Orbi 2.x Unable to Connect (iPhone 7s, Galaxy S7, S7 Edge & S8+, Samsung KS8500 TV)

I've noticed disconnects on Android phone now with V2.0.0.74 release
Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 4 of 8

Re: Orbi 2.x Unable to Connect (iPhone 7s, Galaxy S7, S7 Edge & S8+, Samsung KS8500 TV)

Yes, still disconnecting for Android and also other devices as mentioned in the original post. I also found that smallnetbuilder had created a https://www.smallnetbuilder.com/tools/rankers/wifi-system/result/3659-netgear-rbk50?testmethod=36 to test Orbi, but based on this, it was using the 1.x versions and they showed working correctly, but on the 2.x they simply dropped 2x to 4x times from the recorded speeds there.

Message 5 of 8

Re: Orbi 2.x Unable to Connect (iPhone 7s, Galaxy S7, S7 Edge & S8+, Samsung KS8500 TV)

Here is my current 2 day test that is working perfectly.


1. Make sure the Router and Satellites are updated to the latest (In this case, the for RBS50/RBR50 or for RBS40) by going to Advanced -> Administration -> Firmware Update as seen here:


Screenshot from 2017-10-21 17-39-07.png

2. After upgrading all the firmware devices, turn them off and factory reset the main Router (This was needed for me to get a maximum speed of 100Mbps again and have all chromecast and chromecast ultra work correctly).


3. Configure the main router again from scratch and let it detect and configure the rest of the satellites. Make sure the satellites do not get the Amber or Purple light since that means they have connection issues with the router.


4. For testing purposes, setup the wireless settings like this:


Screenshot from 2017-10-21 17-24-34.png


As you can see in the image, the Enable Implicit Beamforming, Enable MU-MIMO and Fast Roaming are all disable. This solved the issue with my Samsung TV disconnecting, my iPhone and Android disconnecting, the Chromecast disconnecting or lagging and the achieving maximum internet speed throughout the house instead of the 50% or less speed I was getting before.


As you can also see, both, the 2.4Ghz and 5Ghz are still enabled (by default basically).


4. Position the Satellites in strategic places to make sure you get the best results and take into consideration walls, wall thickness and material, other 2.4Ghz devices near the router / satellite, Bluetooth devices that could interfere if too close to the router / satellite.


This is all I did in my particular case. Now what this solved was (For me):


  • Disconnection from all devices, including Samsung Galaxy S7, S7 Edge, S8, iPhone 7s, Samsung KS8500 4K, Chromecast Devices)
  • Solved a weird issue I was having with several Chromecasts (1 ultra and one normal out of 4 different chromecast) which got disconnected or not detected at all and had to reset or disconnect/connect them every other day.
  • Solved internet speed issues with my TV. Previously it was getting between 35mbps to 55mbps from 100mbps. Now it gets full 100mbps.
  • Solved issue in 2 rooms that were getting between 2-3mbps to 15mbps. Now they get 85mbps to 100mbps (There are 2 thick walls between the satellite and the router and one floor differences)
  • Solved an issue that I was always having the 2 Asus routers (RT5300 and AC68U) with 3 IP Cameras (Loga). Now all cameras simply work, not only that but I can use them in full 1080p.
  • Solved an issue with Netflix disconnecting after 15 to 30 minutes while watching a movie in a laptop on the far right of the house (About 25 Meters away from router, 2 thick walls)
  • Solve really long detection and lag when looking for a chromecast device, using direct wifi or sharing files between devices.

The topology for this is the following:


Cable Modem connects by Cable to main Orbi router. I then position a RBS50 Satellite on the room exactly above the router. From there, it covers a good area but 2 other Satellites (On RBS40 and another RBS50) are positioned evenly around the home where most devices exist.


I had also tested a Nighthawk and the 2 asus mentioned above by mixing them in with the Orbi. This did cover the whole home but it also created so much lag. Final result was to simply use the Orbi alone, no other devices and let the Orbi study and learn from the device usage. Now everything is working for now, but I normally take a month to do a full test. So I will keep this post updated in about 2 weeks to a month.

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 6 of 8

Re: Orbi 2.x Unable to Connect (iPhone 7s, Galaxy S7, S7 Edge & S8+, Samsung KS8500 TV)

After 6 days of testing, I started having issues this morning. The phone simply disconnected or not connect and give me the "There might not be internet" (Or something along those lines) warning for the SSID of the Orbi.


Here is the current settings I tried:


Screenshot from 2017-10-28 11-03-18.png

This time I tested with and without the 20/40 Coexistence. As it turns out, for phones that are connected to the satellite (Not directly to the main router), they ARE affected by this. The testing device was the Samsung S8+ Enabling this option create this game of connecting/disconnecting from the network every 30 seconds to a minute (Tested for 5 minutes). But the moment I disabled this, it connected correctly.


Now when it connected correctly, the internet speed (Which is 100mbps) was capped at 15mbps. To give you an idea, The router is in an office almost below where I was, but next to me was a satellite, so the phone was connecting to the satellite and the satellite to the main orbi router, still I was getting 15mpbs tops. This was all happening while the Daisy Chain was disabled. The moment I enabled Daisy Chain, all satellites jumped to 100mbps. All devices (TV, Phones, Laptops) that I use to test got speeds between 95 to 100mpbs, no matter the distance.


Lastly, I also did test MU-MIMO independently and IMPLICIT BEAMFORMING. Enabling any of this 2 options or both will cripple all devices connected to the satellites. The speeds will be somewhat limited to 20-25mbps but the connections will drop multiple times, to a point of not being able to easily navigate on internet.


That is the reason this options are also disabled and I left everything like in the image above. So everything is working correctly for 6 days and everything simply goes crazy. A good idea would be to ideally manage which satellites should use daisy technology and which ones you want to leave alone, including the option to actually reset/reboot a satellite (not factory reset) just to make sure there is no issue with it (memory leaks or something similar).


Message 7 of 8

Re: Orbi 2.x Unable to Connect (iPhone 7s, Galaxy S7, S7 Edge & S8+, Samsung KS8500 TV)

It's been a week since my last post. After leaving the setting as is but turning all devices off and on, everything has been working correctly now. Tested multiple times every day on each satellite what the maximum internet was for it. On all cases I got my maximum of 100mbps which is correct. I am now able to watch Netflix 4k on 2 devices at the same time while also using plex inside the network on one device. Additionally I can also download from steam without any issues and maintain a meeting call with no issues at all.
Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1 kudo
  • 2 in conversation

Orbi WiFi 6E