Reply

App icons in web interface broken

App icons in web interface broken

really as per the subject - in the web interface all the app icons show as broken

 

It's been broken through the last few releases ( was hoping a new release would fix the issue but.. )

 

ReadNAS 4220 on OS 6.7.5

 

Under the admin ( web ) interface and the apps tab and then either installed or avaiable apps next to the app name would ( usually ) be an icon, in my case all I have is a box where the icon would be and in the middle of that box a small blue square with a question mark within it.

 

I'm guessing it's a symlink gone wrong somewhere? Thoughts?

 

I have a screenshot but can't see here any way to upload that?

 

Rgds,

 

R.

 

 

Model: ReadyNAS-4200|ReadyNAS 4200
Message 1 of 11

Accepted Solutions
metapaso
Apprentice

Re: App icons in web interface broken

I know this is from several months ago but this same "app icons missing or broken" issue has plagued my 316 for more than a year.

 

I finally solved the issue.  

 

It turns out that my apache2 webserver was always booting into "safe" mode.  If you have ssh enabled you can verify by checking the status of apache2 and apache2-safe

systemctl status apache2
systemctl status apache2-safe

In my case, the apache2 status showed "failed", and the reason was because of invalid permissions on the /var/lib/apache2/fastcgi folder.  Specifically the error message was:

FastCgiIpcDir /var/lib/apache2/fastcgi: access for server (uid 98, gid 98) failed: write not allowed by group

The reason is because apache2 is run by user admin, but the fastcgi folder is owned by www-data.

 

I changed the owner of /var/lib/apache2/fastcgi to admin:admin and now apache2 boots fine.

 

I'm not sure if this was the "right" thing to do, or whether perhaps apache2 should be set to run as www-data instead of admin or whether fastcgi should be disabled entirely.

 

One final point:  In "safe" mode, the web interface consistently rebooted anytime I made any settings changes.  I found out that the safe mode was giving this error:

 apache2[24533]: [error] server reached MaxClients setting, consider raising the MaxClients setting

So if your apache2 is indeed not starting correctly and reverting to safe mode, it might be a good idea performance-wise to find the root cause and fix it.

View solution in original post

Message 8 of 11

All Replies
StephenB
Guru

Re: App icons in web interface broken

You need a few more posts before the forum will let you post images.

 

On my systems I am seeing images for everything but the kernelplus app.

 

Are you using http to reach the NAS or https?

Message 2 of 11
JennC
NETGEAR Employee Retired

Re: App icons in web interface broken

Hello NesporBellisRM,

 

Have you tried another web browser or on another computer?

 

To attach an image, the option is the tool bar on top of the message/reply box, it is an icon that has 2 mountains.

 

Welcome to the community!

 

Regards,

JennC
NETGEAR Community Team
Message 3 of 11

Re: App icons in web interface broken

Hi there,

 

yes, I get the same on multiple machines and multiple OS ( and IE, Chrome, Safari ) - https only / no http interface allowed.

 

Thanks for the how to attach image - see attached 🙂

 

Rgds,

 

R.Screen Shot 2017-07-14 at 18.03.37.png

Message 4 of 11
JennC
NETGEAR Employee Retired

Re: App icons in web interface broken

Hello NesporBellisRM,

 

How about rebooting your ReadyNAS?

 

Or reloading the firmware manually on the admin page?

 

Regards,

JennC
NETGEAR Community Team
Message 5 of 11

Re: App icons in web interface broken

Hi,

 

already multiple reboots, and as said firmware upgrades etc.

 

Is there perhaps somewhere better/more appropriate I should post this?

 

Rgds,

 

R.

Message 6 of 11
JennC
NETGEAR Employee Retired

Re: App icons in web interface broken

Hello NesporBellisRM,

 

Sorry I've been away for a week. Are you still getting the same problem on loading the available apps icons?

 

Regards,

JennC
NETGEAR Community Team
Message 7 of 11
metapaso
Apprentice

Re: App icons in web interface broken

I know this is from several months ago but this same "app icons missing or broken" issue has plagued my 316 for more than a year.

 

I finally solved the issue.  

 

It turns out that my apache2 webserver was always booting into "safe" mode.  If you have ssh enabled you can verify by checking the status of apache2 and apache2-safe

systemctl status apache2
systemctl status apache2-safe

In my case, the apache2 status showed "failed", and the reason was because of invalid permissions on the /var/lib/apache2/fastcgi folder.  Specifically the error message was:

FastCgiIpcDir /var/lib/apache2/fastcgi: access for server (uid 98, gid 98) failed: write not allowed by group

The reason is because apache2 is run by user admin, but the fastcgi folder is owned by www-data.

 

I changed the owner of /var/lib/apache2/fastcgi to admin:admin and now apache2 boots fine.

 

I'm not sure if this was the "right" thing to do, or whether perhaps apache2 should be set to run as www-data instead of admin or whether fastcgi should be disabled entirely.

 

One final point:  In "safe" mode, the web interface consistently rebooted anytime I made any settings changes.  I found out that the safe mode was giving this error:

 apache2[24533]: [error] server reached MaxClients setting, consider raising the MaxClients setting

So if your apache2 is indeed not starting correctly and reverting to safe mode, it might be a good idea performance-wise to find the root cause and fix it.

Message 8 of 11
evan2
NETGEAR Expert

Re: App icons in web interface broken

@NesporBellisRM

We saw a same issue once in the past, it back to normal after run "apt-get update",

Please Enable SSH in GUI System-> Settings, then access NAS via SSH (you may use putty tool),

Login user name is root, password is GUI admin login password, 

then run command "apt-get update", 

 

 

Message 9 of 11

Re: App icons in web interface broken

Bingo!

 

Thanks for pointing the way ( to the apache failure )

 

Nov 15 03:43:49 iscsi apache2[31822]: apache2: Syntax error on line 244 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: wrong ELF class: ELFCLASS32

 

was the specific failure in my case - trying to load a 32bit module on a 64bit machine.

 

a quick (re)install of libapache2-mod-php5 has done the trick to put a (correct) 64bit binary in place.

 

apache is now running clean and I have my icons back 🙂

Message 10 of 11
metapaso
Apprentice

Re: App icons in web interface broken

@NesporBellisRM

Glad it worked out!  It's been driving me nuts not having the icons for the past 18 months or more across OS versions 6.4 through 6.8.  Also I think the frontview is now more stable and responsive.  The safe mode was dog slow and crashed a lot.

 

@evan2

Thanks for the tip, though in this case I don't think your solution works.  I've done apt-get update and apt-get upgrade several times over in several OS versions and it's never resolved this icon issue.

 

Specifically the apache2-safe mode was clearly the source of the problem. I can't be sure if I'm even supposed to have fastcgi enabled or if I was monkeying around and enabled it accidentally, but it was certainly the fix for the icons missing and from what I can tell other frontview performance issues.

 

Message 11 of 11
Top Contributors
Discussion stats
  • 10 replies
  • 4404 views
  • 1 kudo
  • 5 in conversation
Announcements