× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: Check for updates not connecting

ummjay
Aspirant

Check for updates not connecting

Hi all,

 

I am suddenly having issues updating my Ready Nas 212. When I'm in the admin page, I click on check for updates, and I get an error: "Operation timeout. Communication error. Check your internet connection, DNS settings or proxy settings". Note, in the past , the update worked just fine.

 

I also tried a suggestion from another post, I clicked on the gear next to the device time, unchecked synchronize device time with an internet server, and tried to re-check, and that also failed. So seems it's somehow having issues connecting to the internet?

 

I did log into my router, and confirmed that static IP I have set for this readynas matches the router config, as it does on the admin page of the readynas.

 

Also, on my Verizon router config, I did a ping test, which was successful:

IPv4 Ping (ICMP Echo)

 

Any ideas on how to get this to work? Much appreciated! 

Model: RN21200|ReadyNAS 212 Series 2- Bay (Diskless)
Message 1 of 5
ummjay
Aspirant

Re: Check for updates not connecting

to Add: I also tried to manually add the time servers, and was unable to connect to the servers. Additionally, I added 8.8.8.8 to my DNS ip4 on the NIC of the ReadyNas, rebooted and still unable to connect.

 

I show it's hired wired via ethernet to my Verizon Fios Router, and my router is seeing it connected.

Message 2 of 5
StephenB
Guru

Re: Check for updates not connecting

I'd enable ssh and connect in that way (using root as the username, with the NAS admin password).  For instance, enter ssh root@nas-ip-address from the windows search bar (or from terminal if you are using a Mac).

 

First see if you can ping 8.8.8.8

If that is successful, see if you can ping dns.google.com

Message 3 of 5
ummjay
Aspirant

Re: Check for updates not connecting

Hi, thanks for your reply. I seemed to have fixed it. Somehow the router settings on the ReadyNas NIC itself said 192.168.4.1. Not sure how that happened. I changed it to 192.168.1.1 and rebooted. I was then able to update the firmware, and set the date/time sync to the internet. Any ideas on how that may have changed like that?

Message 4 of 5
StephenB
Guru

Re: Check for updates not connecting


@ummjay wrote:

Any ideas on how that may have changed like that?


No, I don't.

 

One suggestion is to see if your router lets you reserve IP addresses.  If it does, then I'd switch to DHCP in the NAS, and reserve the IP address in the router.  Then the gateway/router and subnet will be populated automatically (and when the time comes to switch routers, you won't lose connectivity).

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 1249 views
  • 0 kudos
  • 2 in conversation
Announcements