Reply

Re: OS6.2.2 - Service SMB suddenly stopped working, won't st

paalfe
Guide

OS6.2.2 - Service SMB suddenly stopped working, won't start!

PROBLEM IS SOLVED 😄 READ THE REPLIES.

I have a ReadyNAS Ultra 2 and a ReadyNAS Ultra 6.
Both running firmware 6.2.2.
Antivirus is disable on both devices.

Service SMB suddenly stopped working on both devices!
Need help to figure out what's wrong and what to do to fix this!

The last thing I remember doing before the fault was installing several addons, including Plex Media Server.
I have removed all these addons, but did not work. Disabling and removing Plex Media Server did not help!

Both having these services enabled and green in UI:
AFP, UPnP, HTTP, HTTPS, SSH.

Both with these Addons installed and active:
- PHPSysInfo for Readynas v3.1.7 by Poussin.
- Gateone v1.0.2 by Poussin.
- BitTorrent Sync v1.4.103 by BitTorrent Inc.
- Plex Media server v0.9.11.7.803 by Plex, Inc.
- Anti-Virus Plus v2.0.2 by NETGEAR, Inc.
- SMB Plus v1.0.1 by NETGEAR, Inc.

Gets this message when I try to restart and status the SMB service via SSH.

# systemctl restart smb.service
Job failed. See system journal and 'systemctl status' for details.

# systemctl status smb.service
smb.service - Samba SMB Daemon
Loaded: loaded (/lib/systemd/system/smb.service; enabled)
Active: failed (Result: exit-code) since Sun, 01 Feb 2015 15:50:52 +0100; 12s ago
Process: 24036 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=1/FAILURE)
CGroup: name=systemd:/system/smb.service

Same happens with WINS service:

# systemctl restart winbind.service
Job failed. See system journal and 'systemctl status' for details.

# systemctl status winbind.service
winbind.service - Samba Winbind Daemon
Loaded: loaded (/lib/systemd/system/winbind.service; disabled)
Active: failed (Result: core-dump) since Sun, 01 Feb 2015 17:29:50 +0100; 19s ago
Process: 31034 ExecStart=/usr/sbin/winbindd $WINBINDOPTIONS (code=dumped, signal=ABRT)
CGroup: name=systemd:/system/winbind.service
Message 1 of 7
paalfe
Guide

Re: OS6.2.2 - Service SMB suddenly stopped working, won't st

I believe I have a problem with ownership of all folders on both NAS boxes!

From smbd.log

[2015/02/01 17:18:03, 0] ../source3/smbd/server.c:1240(main)
smbd version 4.2.0rc3-UNKNOWN started.
Copyright Andrew Tridgell and the Samba Team 1992-2014
[2015/02/01 17:18:03, 0] ../lib/util/util.c:274(directory_create_or_exist_strict)
invalid ownership on directory /var/cache/samba/lck
[2015/02/01 17:23:35, 0] ../source3/smbd/server.c:1240(main)
smbd version 4.2.0rc3-UNKNOWN started.
Copyright Andrew Tridgell and the Samba Team 1992-2014
[2015/02/01 17:23:35, 0] ../lib/util/util.c:274(directory_create_or_exist_strict)
invalid ownership on directory /var/cache/samba/lck
[2015/02/01 17:23:35, 0] ../lib/util/util.c:274(directory_create_or_exist_strict)
invalid ownership on directory /var/cache/samba/msg
[2015/02/01 17:24:12, 0] ../source3/smbd/server.c:1240(main)
smbd version 4.2.0rc3-UNKNOWN started.
Copyright Andrew Tridgell and the Samba Team 1992-2014
[2015/02/01 17:24:12, 0] ../lib/util/util.c:274(directory_create_or_exist_strict)
invalid ownership on directory /var/cache/samba/lck
[2015/02/01 17:24:12, 0] ../lib/util/util.c:274(directory_create_or_exist_strict)
invalid ownership on directory /var/cache/samba/msg

From winbind.log

[2015/02/01 17:29:50, 0] ../source3/winbindd/winbindd.c:1523(main)
winbindd version 4.2.0rc3-UNKNOWN started.
Copyright Andrew Tridgell and the Samba Team 1992-2014
[2015/02/01 17:29:50, 0] ../lib/util/util.c:274(directory_create_or_exist_strict)
invalid ownership on directory /var/cache/samba/lck
[2015/02/01 17:29:50, 0] ../lib/util/util.c:274(directory_create_or_exist_strict)
invalid ownership on directory /var/cache/samba/msg
[2015/02/01 17:29:50, 0] ../source3/lib/util.c:788(smb_panic_s3)
PANIC (pid 31034): Could not init winbindd's messaging context.

[2015/02/01 17:29:50, 0] ../source3/lib/util.c:899(log_stack_trace)
BACKTRACE: 7 stack frames:
#0 /usr/lib/x86_64-linux-gnu/libsmbconf.so.0(log_stack_trace+0x1a) [0x7fc53b32518a]
#1 /usr/lib/x86_64-linux-gnu/libsmbconf.so.0(smb_panic_s3+0x1a) [0x7fc53b32526a]
#2 /usr/lib/x86_64-linux-gnu/libsamba-util.so.0(smb_panic+0x2f) [0x7fc53ff9d6cf]
#3 /usr/sbin/winbindd(+0x33ac0) [0x7fc54082cac0]
#4 /usr/sbin/winbindd(main+0x390) [0x7fc54081f8e0]
#5 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7fc53895bb45]
#6 /usr/sbin/winbindd(+0x27709) [0x7fc540820709]
[2015/02/01 17:29:50, 0] ../source3/lib/dumpcore.c:318(dump_core)
dumping core in /var/cores

From system.log

Feb 01 17:23:35 nas02 apache_access[28685]: 172.16.10.147 "POST /dbbroker HTTP/1.1" 200
Feb 01 17:23:43 nas02 apache_access[28685]: 172.16.10.147 "GET /apps/smbplus/admin/smbplus.cgi?op=setSmbOplocks&oplocks=1&ms=1422807823675 HTTP/1.1" 200
Feb 01 17:23:49 nas02 apache_access[28685]: 172.16.10.147 "POST /dbbroker HTTP/1.1" 200
Feb 01 17:23:53 nas02 apache_access[28685]: 172.16.10.147 "GET /apps/smbplus/admin/smbplus.cgi?op=setSmbMaxVersion&max-version=SMB2_10&ms=1422807833533 HTTP/1.1" 200
Feb 01 17:23:56 nas02 apache_access[28685]: 172.16.10.147 "POST /dbbroker HTTP/1.1" 200
Feb 01 17:24:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:24:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:24:44 nas02 apache_access[28685]: Suppressed 4 duplicate messages
Feb 01 17:24:44 nas02 apache_access[28685]: 172.16.10.147 "GET /apps/smbplus/admin/smbplus.cgi?op=setSmbMaxVersion&max-version=SMB3_00&ms=1422807884436 HTTP/1.1" 200
Feb 01 17:24:59 nas02 apache_access[28685]: 172.16.10.147 "POST /dbbroker HTTP/1.1" 200
Feb 01 17:25:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:25:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:26:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:26:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:27:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:27:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:28:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:28:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:05 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:06 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:07 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:07 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:07 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:28:07 nas02 dbus[2046]: [system] Activated service 'org.opensuse.Snapper' failed: The permission of the setuid helper is not correct
Feb 01 17:28:07 nas02 dbus[2046]: [system] Activating service name='org.opensuse.Snapper' (using servicehelper)
Feb 01 17:29:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:29:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:30:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:30:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:31:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:31:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:32:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:32:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:33:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:33:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:34:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:34:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:35:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:35:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:36:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:36:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:37:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:37:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:38:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:38:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:39:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:39:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:40:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:40:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:40:38 nas02 connmand[6958]: ntp: time slew +0.024097 s
Feb 01 17:41:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:41:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:42:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:42:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:43:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:43:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:44:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:44:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:45:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:45:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:46:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:46:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:47:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:47:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:48:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:48:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:49:01 nas02 /usr/sbin/cron[2129]: (*system*) WRONG FILE OWNER (/etc/crontab)
Feb 01 17:49:01 nas02 /usr/sbin/cron[2129]: (*system*php5) WRONG FILE OWNER (/etc/cron.d/php5)
Feb 01 17:49:39 nas02 apache_access[28685]: Suppressed 129 duplicate messages
Feb 01 17:49:39 nas02 apache_access[28685]: 172.16.10.147 "GET /favicon.ico HTTP/1.1" 200

Screenshot from one of mine NAS on the left and my friends working normal NAS at the right.
Ownership on my NAS is mostly guest, while I guess it should be root!
Message 2 of 7
mdgm-ntgr
NETGEAR Employee Retired

Re: OS6.2.2 - Service SMB suddenly stopped working, won't st

Looks like you installed the Transmission app? There is a bug in the 3.00.6 version of this app which leads to ownership of / being set to guest recursively. There is a newer version of the app (3.00.8) in super-poussin's Dropbox with a fix for this bug.

Do you have a backup?
Message 3 of 7
paalfe
Guide

Re: OS6.2.2 - Service SMB suddenly stopped working, won't st

You are probably correct, mdgm. Too bad the fixed version don't fix the problem the previous version did. If the addon has a known serious bug, why is it still available to install directly from ReadyNAS UI?!

It is over 10TB so I do not have a backup.
Working on a script for setting the correct permission, user and group...
Message 4 of 7
paalfe
Guide

Re: OS6.2.2 - Service SMB suddenly stopped working, won't st

Script for setting more correctly permissions, users and groups is done.
The script is found here: https://gist.github.com/paalfe/c4c87be63c7519d1dbe8

Used putty with logging "all session output" enabled, SSH into my friends working ReadyNAS with OS6, did an "ls -alhR /" of the filestructure, cleaned up the putty.log, modified it into a bash script, ....., used gedit, sed and libreoffice calc. Got it transferred to one of my ReadyNAS boxes and executed it via SSH, and now everything on that ReadyNAS works again 😄 Had to run "reset permissions" on my shares via UI.

Unfortunately I have lost SSH and HTTP/HTTPS to my second ReadyNAS, "OS Reinstall" did not help! Trying to figure out how I can fix this via Debug Mode - Telnet...
Message 5 of 7
paalfe
Guide

Re: OS6.2.2 - Service SMB suddenly stopped working, won't st

Managed to fix my second ReadyNAS 😄 from debug-mode/tech-support-mode/telnet.
The default telnet login is <REMOVED BY MODERATOR>

- Mounted md0-partition.
echo DEVICE partitions > /etc/mdadm.conf ; 
mdadm --examine --scan >> /etc/mdadm.conf ;
mdadm --assemble --scan ;
mount /dev/md0 /mnt/ ;

Fixed http/https problem. A removed addon's apache-conf-file was preventing apache and UI from starting!
rm /mnt/etc/apache2/sites-enabled/UNISTALLED-ADDON-CONF-FILE.conf

Luckily I managed to tranfer my dirty-fix-script to the NAS before I managed to loose SSH and HTTP/HTTPS access.
Copied my script to /mnt/etc/cron.hourly/

- umounted the md0-partition.
umount /mnt/ ; 

- Powerbutton OFF -> Powerbutton ON -> Boot Normal

HTTP/HTTPS working again 😄

Waited for my script to run via cron, and suddenly was SSH working again 😄
Removed the script from /etc/cron.hourly/

Had to run "reset permissions" on my shares via UI.
Message 6 of 7
gibxxi
Guide

Re: OS6.2.2 - Service SMB suddenly stopped working, won't st

Nice work. Think I may have inadvertently installed that version of Transmission via the app-store, so will try this myself. Have some 3rd party apps that won't be covered by your script because they're not in the app store so I'll possibly need to fix those manually (utorrent being one).

Forgive my ignorance here, but couldn't you of saved yourself a lot of typing by doing a "chown -hR root:root <folder>" on the root folders of each add-on and have the changes applied recursively?
NAS1: Asustor AS-5104T [FW: 2.5.1.RB62] - Drives: 4x WD-Red 68EUZN0 2TB - RAM: 8GB]
NAS2: Netgear Repertoire U4 (Chirpa Special) [FW: 4.2.28 - Drives: 4x WD-Red 68AX9N0 2TB - RAM: 4GB]
Switch (N1): Netgear GS108Tv2 [FW: v5.4.2.19] | Switch (N2): Netgear GS208 over PWRL-1200+
Router: Netgear WNDR4300 [FW: v1.0.2.80] | UPS: APC SMT-1500I, BackUPS ES-700uk]
Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 3681 views
  • 4 kudos
  • 3 in conversation
Announcements