EX3700 Setup Problems - unable to setup


EX3700 Setup Problems - unable to setup

2021-05-22 Please help with setup.

I can't use WPS because my Bell Home 3000 router has no WPS button, so I have to use the Web Browser Route. What I've tried (more or less) so far:

I am using my Win 7 laptop (connected wirelessly) with Firebox browser:

Router, extender and laptop in close proximity (within 2 metres).

1) Plugged-in the device - the light turn amber then green.

2) Laptop: open browser and access the suggested webpage*..

3) I get instructions not relevant to my model. You are not connected...

4) Followed the link for answers.

5) Listed available networks and found "NETGEAR_EXT"..

6) Connected to it - no username or password was asked. Norton pop-up said it is  an unsecured connection. But I am connected anyway.

7) The device light turns green but Firefox cannot find the site anymore.

😎  Reconnect to my regular connection.

9) Followed the guided assistance.

10) It asks questions but after connecting to "NETGEAR_EXT", Firefox cannot find the webpage anymore, so I cannot complete the procedure and have to go back to my regular network and I can see the web again.

11) I tried the suggested web page* on my Android cell phone and I got the same irrelevant instructions and "You are not connected...".

12) When I change the phone's network to "NETGEAR_EXT", I cannot access the web anymore so I have to change it back.


*note: "suggested webpage" is the one printed in the instructions but it is not allowed to be mention in the post.

Please help. I am about to return this unit if there are no suitable answers.


Model: EX3700|AC750 WiFi Range Extender Essentials Edition
Message 1 of 2

Re: EX3700 Setup Problems - unable to setup

Problem solved. I got it working.

One more (Hail Mary) try.
The prescribed entry to the setup page on the printed guide
starts with "www.m..." through the browser.

After connecting my laptop to NETGEAR_EXT, I tried the
prescribed entry URL WITHOUT the "www." and I got in!

I was able to follow the procedure until the page where
I am to connect a wifi device and click "Continue" after...
I connected my cell phone, it works, but after I clicked "Continue",
the display reverted back to the "You are not connected" screen.
The laptop's connection to NETGEAR_EXT disappeared and the NETGEAR_EXT
network also disappeared, but I suppose the setup was already done.
I did not get a "confirmation" or "status" page.
My laptop's connection reverted back to my regular network.

I relocated the extender to where it should be and it still works.

Is the setup guide wrong or is it just me?

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 1 in conversation

Orbi WiFi 6E