Antworten

M5300 L3 Switch verwendet für sämtliche VLANs nur das Default-Gateway von VLAN 1

ipv4
Luminary

M5300 L3 Switch verwendet für sämtliche VLANs nur das Default-Gateway von VLAN 1

Bei Verwendung des Switches als Gateway für Clients erhalte ich keine Verbindung ins Internet.
Der Switch beachtet die zuätzlich eingetragenen Default-Routen nicht, und sendet stets sämtlichen Datenverkehr ins Internet über die Default-Route des VLAN 1.

Netzaufbau:
Internet <-> Lancom Router (192.168.40.1) <-> Netgear M5300 L3 Switch (192.168.40.2) <-> Client (192.168.40.200)

Das Netz ist sowohl im Lancom als auch im Netgear in mehrere VLANs (1-5) mit den Netzen (192.168.10.0 - 192.168.50.0) separiert. Der Lancom ist am Switchport als "tagged" markiert. In der Lancom VLAN-Tabelle sind alle VLANs entsprechend eingetragen.

Verwende ich in den Clients den Lancom als Gateway, funktioniert der Datenverkehr ins Internet reibungslos. Da ich jedoch den Netgear Switch als Gateway benutzen möchte, um nicht sämtliche Daten (insbesondere Verkehr zwischen den VLANs) über den Lancom zu schaufeln, müssen die Clients den Netgear Switch als Gateway erhalten.
Im Switch ist auch für jedes VLAN eine Default-Route zum Lancom Router eingetragen.

Netgear Routing-Table:
Network Address 	Subnet Mask 	Protocol 	Route Type 	Next Hop Interface 	Next Hop Address 	Preference 	Metric
0.0.0.0 	0.0.0.0 	Default 	Static 	vlan 2 	192.168.20.1 	1 	0
0.0.0.0 	0.0.0.0 	Default 	Static 	vlan 3 	192.168.30.1 	2 	0
0.0.0.0 	0.0.0.0 	Default 	Static 	vlan 4 	192.168.40.1 	3 	0
0.0.0.0 	0.0.0.0 	Default 	Static 	vlan 5 	192.168.50.1 	4 	0
0.0.0.0 	0.0.0.0 	Default 	Static 	vlan 1 	192.168.10.1 	254 	1
192.168.10.0 	255.255.255.0 	Local 	Connected 	vlan 1 	192.168.10.2 	0 	1
192.168.20.0 	255.255.255.0 	Local 	Connected 	vlan 2 	192.168.20.2 	0 	1
192.168.30.0 	255.255.255.0 	Local 	Connected 	vlan 3 	192.168.30.2 	0 	1
192.168.40.0 	255.255.255.0 	Local 	Connected 	vlan 4 	192.168.40.2 	0 	1
192.168.50.0 	255.255.255.0 	Local 	Connected 	vlan 5 	192.168.50.2 	0 	1
Model: M5300-28G3 (GSM7328Sv2h2)|ProSafe 24 ports managed L3 gigabit stackable switch
Nachricht 1 von 8
Slas
NETGEAR Employee Retired

Re: M5300 L3 Switch verwendet für sämtliche VLANs nur das Default-Gateway von VLAN 1

Hallo @ipv4

 

und willkommen in der NETGEAR Community.

 

Ich gehe davon aus, dass Lancom ein VLAN-fähiger Router ist?

Funktioniert der Router als DHCP-Server für jedes VLAN?

Ist das VLAN-Routing auf dem M5300 oder Lancom aktiviert?

 

Zwischen Switch und Router besteht eine Port Verbindung, über die der Verkehr für VLANs übertragen wird.

Überprüfe, ob die Ports die den Switch und den Router verbinden, in jedem VLAN getaggt (T) sind.

 

Die statischen Routen werden meistens am Router benötigt, um sicherzustellen, dass der Router weiß, wie der Verkehr zu Geräten in den VLANs geleitet wird.

 

Unten findest du zwei Artikel mit Beispielen:

 

How to configure routing VLANs on a NETGEAR managed switch with shared internet access

 

https://kb.netgear.com/31009/How-to-configure-VLANs-on-a-ProSAFE-S3300-Stackable-Smart-Switch-with-s...

 

Grüße
Slas
NETGEAR Community Team


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 2 von 8
ipv4
Luminary

Re: M5300 L3 Switch verwendet für sämtliche VLANs nur das Default-Gateway von VLAN 1

Ja, der Lancom-Router ist VLAN-fähig, DHCP-Server ist auf dem Lancom aktiviert und funktioniert probemlos. VLAN-Routing ist auf beiden Geräten aktiviert.
Auf dem Switchport an welchem der Lancom-Router angeschlossen ist, sind sämtliche VLANs getaggt (T).

Insoweit funktioniert der Datenverkehr zwischen Lancom-Router und Netgear-Switch innerhalb eines VLANs reibungslos.

Ich habe den Lancom-Router testweise auch gleichzeitig an mehreren Ports des Netgear Switches angeschlossen. Dabei habe ich auf beiden Geräten für die jeweiligen Ports unterschiedliche VLAN-IDs vergeben, um zu prüfen ob der Netgear Switch die Pakete richtigt taggt und somit über den korrekten Port versendet. Dies ist aber leider nicht der Fall.

Zusammenfassend: Sobald ich den Netgear Switch als Gateway in den Clients eintrage, welche bspw. im VLAN 2-5 liegen, werden die eingehenden Datenpakete vom Lancom-Router abgewiesen, weil sie mit dem VLAN Tag 1 markiert sind und somit auf dem falschen Lancom-Port angeliefert werden. Der Netgear Swich routet somit sämtliche Pakete ausgehend mit VLAN Tag 1

Zur Vollständigkeit: Der M5300-28G3 befindet sich in einem Stack mit einem M5300-28G-POE+ (mit aktivierter L3 Lizenz). Verwendete Firmware: 11.0.0.31
Nachricht 3 von 8
Slas
NETGEAR Employee Retired

Re: M5300 L3 Switch verwendet für sämtliche VLANs nur das Default-Gateway von VLAN 1

Hallo @ipv4,

 

hast du auch die statische Routen auf dem Lancom zu jedem VLAN das sich auf dem M5300 befindet, konfiguriert?

Versuche beispielsweise den folgenden Test mit VLAN 3.
Stelle sicher, dass der Port, der den Router und den Switch verbindet, auf beiden Seiten in VLAN 3 als Tagged markiert ist. Füge eine statische Route auf dem Lancom Router in Richtung VLAN 3 Interface hinzu. Versuche dann von einem mit Switch verbundenen PC in VLAN3, den Lancom Router zu pingen.  Der Client sollte in diesem Beispiel als Gateway den VLAN 3 Interface (192.168.30.2) haben.

 

 

Grüße
Slas
NETGEAR Community Team

 


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 4 von 8
ipv4
Luminary

Re: M5300 L3 Switch verwendet für sämtliche VLANs nur das Default-Gateway von VLAN 1

Ich kann den Lancom-Router problemlos aus jedem VLAN Netz anpingen (mit und ohne des VLAN-Interfaces als Gateway).

Eine Route auf dem Lancom-Router habe ich auch mal testweise angelegt, bin mir aber nicht sicher was dies bringen soll. Der Lancom Router wird ja nicht über ein Transfernetz angebunden sondern hängt mit jeweils einer eigenen IP im gleichen Subnetz jedes VLANs.

Bspw.:
VLAN 1: Lancom: 192.168.10.1, Netgear-Switch: 192.168.10.2
VLAN 2: Lancom: 192.168.20.1, Netgear-Switch: 192.168.20.2
usw....

Das Problem ist, dass der Netgear Swich sämtliche Pakete ausgehend mit VLAN Tag 1 an den Lancom-Router schickt. Dieser lehnt dann die Pakete ab, weil sie auf dem falschen Port angeliefert werden.

Lancom Trace:
[Firewall] 2018/11/11 09:02:03,120  Devicetime: 2018/11/11 09:02:05,317
Packet matched rule intruder detection
DstIP: 193.99.144.80, SrcIP: 192.168.30.125, Len: 84, DSCP: CS0/BE (0x00), ECT: 0, CE: 0
Prot.: ICMP (1), echo request, id: 0x1c0c, seq: 0x00f1

Filter info: packet received from invalid interface LAN-1

Und, nein, es liegt nicht an der Lancom-Firewall dass sie das Paket blockt. Es ist zum einen eine Regel vorhanden, welche sämtlichen Verkehr vom betreffenden LAN ins Internet erlaubt. Zum anderen wird auch bei Abschalten der Lancom-Firewall das Paket nicht zugestellt.

Der Fehler liegt eindeutig im falschen Routingverhalten des Netgearswitches. Ohne Verwendung des Switches als Gateway funktionieren die VLANs tadellos.
Nachricht 5 von 8
Slas
NETGEAR Employee Retired

Re: M5300 L3 Switch verwendet für sämtliche VLANs nur das Default-Gateway von VLAN 1

Hallo @ipv4,

 

das scheint ein Konfigurationsproblem zu sein.

Zur weiteren Prüfung könntest du mir die Tech Support-Datei von dem M5300 und Screenshots mit der VLAN Konfiguration von beiden Seiten (Switch und Router) in einer privaten Nachricht zusenden.

Du könntest dich sonst an den Netgear Support wenden, damit die Techniker über eine Remote Verbindung die Switch Einstellungen überprüfen.

 

Um eine Tech- Support File zu erstellen, gehe wie folgt vor:

 

Es wird CLI/Telnet Zugriff benötigt.

 

(M5300)
User:admin
Password:
(M5300) >enable
(M5300) #show tech-support
Please wait while techsupport file is created...

Unter Maintenance kann die Datei über http heruntergeladen werden.

 

Grüße
Slas
NETGEAR Community Team


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 6 von 8
ipv4
Luminary

Re: M5300 L3 Switch verwendet für sämtliche VLANs nur das Default-Gateway von VLAN 1

Leider kann ich in einer privaten Nachricht ausser Bildern keine weiteren Dateien hinzufügen.
Wenn ich das Tech-Support File in der Textnachricht als Code mitsende, wird der maximale Zeichenwert der Nachricht überschritten: "Dieser Wert muss weniger als 60.000 Zeichen enthalten."

Haben Sie eine E-Mail Adresse, an welche ich die Dateien senden kann?
Nachricht 7 von 8
Slas
NETGEAR Employee Retired

Re: M5300 L3 Switch verwendet für sämtliche VLANs nur das Default-Gateway von VLAN 1

Hallo @ipv4,

Könntest Du einen File-Dienst wie Dropbox verwenden, um mir die Dateien zu senden?

Grüße
Slas
NETGEAR Community Team


____
Klicke auf KUDOS, wenn du diesen Beitrag hilfreich findest, und markiere ihn ggf. als AKZEPTIERTE LÖSUNG.

Nachricht 8 von 8
Diskussionsstatistiken
  • 7 Antworten
  • 3132 Aufrufe
  • 0 Kudos
  • 2 in Unterhaltung