Reply
soberwulf
Tutor

Re: XR500 DHCP issue

Can I suggest this may be a hardware related issue. I purchased one of these routers early 2018 and suffered from this issue. After a month or so I returned it to the retailer. I purchased the same model router some months later hoping that a firmware may have fixed the issue. Sure enough I have not experienced the issue since. Yet lots of people on this forum are who are likely using the same firmware as me. I have not set up my network any differently to previous. By no means is this a solid test but worth considering
Model: XR500| Nighthawk Pro Gaming Router
Message 51 of 208
Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

We definitely haven't ruled that out, if we're unable to reproduce a next step would be to test manually in house one of the routers with the issue
Message 52 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

I got my XR450 last August. Have had zero issues with aside the lower 2.4ghz radio. The 450 has same HW as the 500 accept for the 2.4Ghz radio. No issues seen with DHCP on it. 

However I do use a smaller DCHP IP address pool and not default. Also I use 192.168.0.1 instead of 1.1. Smiley Very Happy

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 53 of 208
Slaine80
Tutor

Re: XR500 DHCP issue

I have the same problem as you, I am in version XR500 V2.3.2.40 and my journal is filled with message DHCP !!!
Possible to have a beta version?
there is another solution?

Message 54 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

Set the Default DHCP IP address pool from 192.168.1.1/.254 to 192.168.1.100 to .200.

Try this. Ensure that your using reserved IP addresses for chosen devices ON the router. Ensure that when using Static IP address ON devices that these IP addresses are outside of the default DHCP IP address pool set on the router. 


@Slaine80 wrote:

I have the same problem as you, I am in version XR500 V2.3.2.40 and my journal is filled with message DHCP !!!
Possible to have a beta version?
there is another solution?


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 55 of 208
Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

@slaine are you having any issues from this or just increased log entries?
Message 56 of 208
Slaine80
Tutor

Re: XR500 DHCP issue

@Netduma-Fraser  My log filled with DHCP notification and all my devices are disconnected in chain and for several minutes

Message 57 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

What happens with the suggestion I mentioned? 


@Slaine80 wrote:

@Netduma-Fraser  My log filled with DHCP notification and all my devices are disconnected in chain and for several minutes


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 58 of 208
Slaine80
Tutor

Re: XR500 DHCP issue

@FURRYe38  I made the changes, I am now waiting to see if it works well!

Message 59 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

Ok, let us know. 


@Slaine80 wrote:

@FURRYe38  I made the changes, I am now waiting to see if it works well!


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 60 of 208
LOCKxPerses
Aspirant

Re: XR500 DHCP issue

The wired connection stops after I turn xbox off or disconnect the ethernet cable from the xbox. And it will not reconnect to the internet even though it shows it works. It also kicks me off randomly when I'm playing when its wired.
Message 61 of 208
Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

I'm not sure I understand, other devices are affected by you turning off/unplugging Xbox? What game are you playing? If you disable the Geo-Filter does that prevent the random kicks?
Message 62 of 208
LOCKxPerses
Aspirant

Re: XR500 DHCP issue

Yes I have done all those things I play battlefield, anthem and some other like games the only thing that Is affected is my wired in xbox. The ip address on it is very weird. I'm not sure if that is the issue.
Message 63 of 208
Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

What's the IP address that you're getting? So you do not see buffering/lag on any other devices when it occurs? If you connect directly to the modem does it still happen?
Message 64 of 208
LOCKxPerses
Aspirant

Re: XR500 DHCP issue

It's only wired devices that dont work the IP address I am getting on my xbox is 169.254.69.66 and subnet mask is 255.255.255.0 and gateway is 0.0.0.0. Wireless works perfectly
Message 65 of 208
Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

I see, think you're having the issue others are. Turn off instant on mode on the Xbox and turn it off fully when finished with it, does that prevent the disconnects?
Message 66 of 208
RyanRyan
Aspirant

Re: XR500 DHCP issue

Was anyone able to get the DHCP server working? I purchased the router yesterday (3/21/2019) and am having the DHCP issue. I have tried everything in this thread and am running the latest firmware. Wireless connects then hangs when obtaining an IP address. Some devices connect some do not. Seems random. I will try to get it working for another day or so but will likely be returning it.

 

 

Message 67 of 208
Netduma_Jack
NetDuma Partner

Re: XR500 DHCP issue

Is this on all devices or a specific device?

Message 68 of 208
RyanRyan
Aspirant

Re: XR500 DHCP issue

It is across all devices. Amazon echos, Xbox one, smart TV, phones (android OS and iOS), Bose smart speaker, iPads and a Nintendo Switch. Some will connect and work. The devices show up in the Device Manger as Offline in the "tree view". The devices show up in the table view with the correct name, correct type and MAC Address but have an IP address of N/A. The devices connect to the wireless (both the 2.4 and the 5) fine but cannot get IP addresses on either.

 

While trying to get my phone (Galaxy Note 8) to connect, it would time out several times on getting an IP address. After maybe 5-6 times of trying it would get one. The message dispayled on my phone was Time out. Unable to get IP address.

 

I think I would like this router and would like to keep it if clients could get IP addresses.

 

The log is full of these entires, they don't seem like errors and there aren't any entries which I indicate an error.

 

[DumaOS] Marking device that is marked 192.168.1.124 32 15., Tuesday, April 02, 2019 05:45:35
[DumaOS] DHCP lease change., Tuesday, April 02, 2019 05:45:35
[DumaOS] DHCP new event., Tuesday, April 02, 2019 05:45:35
[DHCP IP: 192.168.1.124] to MAC address a0:c9:a0:1b:c0:8b, Tuesday, April 02, 2019 05:45:35
[DumaOS] DHCP lease change., Tuesday, April 02, 2019 05:45:15
[DumaOS] DHCP new event., Tuesday, April 02, 2019 05:45:15
[DHCP IP: 192.168.1.101] to MAC address 00:51:ed:e8:fb:e1, Tuesday, April 02, 2019 05:45:15
[DumaOS] DHCP lease change., Tuesday, April 02, 2019 05:45:14
[DumaOS] DHCP new event., Tuesday, April 02, 2019 05:45:14
[DHCP IP: 192.168.1.101] to MAC address 00:51:ed:e8:fb:e1, Tuesday, April 02, 2019 05:45:14
[DumaOS] DHCP lease change., Tuesday, April 02, 2019 05:45:12
[DumaOS] DHCP new event., Tuesday, April 02, 2019 05:45:12
[DHCP IP: 192.168.1.101] to MAC address 00:51:ed:e8:fb:e1, Tuesday, April 02, 2019 05:45:12
[DumaOS] DHCP lease change., Tuesday, April 02, 2019 05:45:08
[DumaOS] DHCP new event., Tuesday, April 02, 2019 05:45:08
[DHCP IP: 192.168.1.101] to MAC address 00:51:ed:e8:fb:e1, Tuesday, April 02, 2019 05:45:08
[DumaOS] DHCP lease change., Tuesday, April 02, 2019 05:45:07
[DumaOS] DHCP new event., Tuesday, April 02, 2019 05:45:07
[DHCP IP: 192.168.1.101] to MAC address 00:51:ed:e8:fb:e1, Tuesday, April 02, 2019 05:45:07
[DumaOS] Marking device that is marked 192.168.1.150 37 47., Tuesday, April 02, 2019 05:45:07

Message 69 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

What Firmware is currently loaded?
What is the Mfr and model# of the ISP modem the NG router is connected too?

 

Try setting a smaller IP address pool, 192.168.1.100 to 192.168.1.200. 

Setup IP address reservations as well for each device ON the router. 


@RyanRyan wrote:

Was anyone able to get the DHCP server working? I purchased the router yesterday (3/21/2019) and am having the DHCP issue. I have tried everything in this thread and am running the latest firmware. Wireless connects then hangs when obtaining an IP address. Some devices connect some do not. Seems random. I will try to get it working for another day or so but will likely be returning it.

 

 


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 70 of 208
RyanRyan
Aspirant

Re: XR500 DHCP issue

My Firmware is: XR500 V2.3.2.40

I purchased a Motorola cable modem a few years ago not sure of the model but will check when I get home. It is DOCSIS 3 compatible.


I had already tried using a smaller IP address pool. Set the last octet to 100 - 200.

I have not tried setting IP address reservations for each device on the router. If this is the "fix" it will not work for me. Take for instance one of my kids having a friend over (this happens nearly every day) and they want to connect to the wifi. Someone will need to login to the router and give them a static IP address. That isn't feasible for us. I will try the solution to see if it fixes it but it will not work for our family.

Message 71 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

How was the FW updated? auto update or did you manually apply the update? 

How is the xbox connected? Wired or wireless? 

Besure to disable Instant ON on the xbox.

 

 


@RyanRyan wrote:

My Firmware is: XR500 V2.3.2.40

I purchased a Motorola cable modem a few years ago not sure of the model but will check when I get home. It is DOCSIS 3 compatible.


I had already tried using a smaller IP address pool. Set the last octet to 100 - 200.

I have not tried setting IP address reservations for each device on the router. If this is the "fix" it will not work for me. Take for instance one of my kids having a friend over (this happens nearly every day) and they want to connect to the wifi. Someone will need to login to the router and give them a static IP address. That isn't feasible for us. I will try the solution to see if it fixes it but it will not work for our family.


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 72 of 208
RyanRyan
Aspirant

Re: XR500 DHCP issue

I purhcased the router this weekend. During the setup it automatically did the update. I have since checked to see if there were any updates by going to Administration -> Firmware Update and clicking the "Check" button. Says the router has the latest version.

 

The xbox one is wireless. I will disable Instant ON on the xbox this evening when I get home. Are there things I can try for all the other devices?

 

 

Message 73 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

You might try this, manually download the re-load the v40 FW file. Use FF or Opera to load the file. Then factory reset and setup from scratch. Set a new smaller size pool. Then see if your devices still continue to exhibit DHCP problems. If so, revert to v32 FW. 

 

I don't see this issue on my XR450 router. I have some of my devices set for static IPs on themselves, cameras, printers and NAS out side the IP address pool. Most everything else is Dynamic IP. No connection issues. 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 74 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

I spoke with my ISP after having this issue and it seems the problem is the router is forwarding the DHCP requests to them. Since I am only allowed one IP address it causes a problem. They saw my PS4, Apple TV 4K, and Phillips Hue Hub all requesting an IP from them in addition to my router. Unfortunately I purchased this upon release and am well past the point of return otherwise I sent this crap back.
Message 75 of 208
Top Contributors
Discussion stats
Announcements