Reply

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

Hi.  Over the past week I've noticed the 5G-2 band on my R7900 will drastically drop speed for no noticeable reason.  Last week I change the broadcast channel from 149 to 161, which I thought was the source of the issue.  Router did a soft reset after applying new channel setting and speeds went back to normal.  Fast forward a week and the same drop in speed happened again.  This time I just did a soft reset and left the channel the same.  Speed went right back to normal after reset.  2.4G and 5G-1 bands are never impacted when the 5G-2 band is having these issues.

 

I've tested the speeds with multiple devices ~1 foot away from the router.  I'm using latest firmware (V1.0.1.4_10.0.12). 

 

Any suggestions to fix this issue?

 

Thanks in advance.

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 1 of 12

Accepted Solutions
bigw3260
Star

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

I found the issue and have got a work around for now. I posted the solution to this new thread for anyone who runs into the issue. I believe it is a firmware issue but it can be mitigated until they fix it. Here is the link to the other thread... https://community.netgear.com/t5/Nighthawk-WiFi-Routers/Do-NOT-use-Dynamic-QoS-on-Nighthawk-R7900/td...

 

I wasted enough time on this. Support can read my notes. Unless they want to pay me for my services.

View solution in original post

Message 11 of 12

All Replies

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

Exactly one week since posting this and the problem has happened again, this time on both 5G channels.  The 2.4G channel is fine throughout the issues.  Any help would be appreciated.

Message 2 of 12
JamesGL
Master

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

Hi harryballzanya,

 

1. How many devices are affected?

2. Have you tried to reset the router to factory default? If not yet, please press the reset button at the back of the router until the power light turns amber. Manually reconfigure the router after the reset.

 

JamesGL
Community Team

Message 3 of 12

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

Thanks for the reply and the help!  ALL devices connected to the 5G bands are affected.  I will attempted to reset to factory and reconfigure during low usage period and will report back. Thank you!

Message 4 of 12
JamesGL
Master

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

Hi harryballzanya,

 

Looking forward for your feedback.

 

JamesGL
Community Team

Message 5 of 12
JamesGL
Master

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

Hi harryballzanya,

 

We’d greatly appreciate hearing your feedback letting us know if the information we’ve provided has helped resolve your issue or if you need further assistance.

 

If your issue is now resolved we encourage you to mark the appropriate reply as the “Accepted Solution” so others can be confident in benefiting from the solution. The Netgear community looks forward to hearing from you and being a helpful resource in the future!

 

JamesGL
Community Team

Message 6 of 12

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

Sorry for the late reply.  My issue was actually escalated to Tier 2 support and because of my router's symptoms I was sent a brand new R7900.  I just received it today and will be installing it and sending the old one back.  This will help determine if it's simply a hardware issue or a firmware issue.  I will keep posting as I have new information.

Message 7 of 12
bigw3260
Star

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

I am having the same issue as well with mine. Reboot always corrects the issue for temporally, but then in returns after about 24hrs.  I hope it is a firmware issue.

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 8 of 12
bigw3260
Star

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

I spoke with support and after lots of troubleshooting they said to replace the router. I hav and the brand new one still does the same thing. The 5ghz radio #2 only connects at 54Mbps and so download speeds are horrible. This appears to be a firmware or hardware issue that NETGEAR needs to fix.

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 9 of 12
JamesGL
Master

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

Hi bigw3260,

 

Contact support team again and provide them feedback.

Message 10 of 12
bigw3260
Star

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

I found the issue and have got a work around for now. I posted the solution to this new thread for anyone who runs into the issue. I believe it is a firmware issue but it can be mitigated until they fix it. Here is the link to the other thread... https://community.netgear.com/t5/Nighthawk-WiFi-Routers/Do-NOT-use-Dynamic-QoS-on-Nighthawk-R7900/td...

 

I wasted enough time on this. Support can read my notes. Unless they want to pay me for my services.

View solution in original post

Message 11 of 12
JamesGL
Master

Re: R7900 5G-2 Band Drops Speed from 200mbps to 2mbps

Hi bigw3260,

 

Thank you for your feedback.

Message 12 of 12
Top Contributors
Discussion stats
  • 11 replies
  • 4370 views
  • 1 kudo
  • 3 in conversation
Announcements

Orbi WiFi 6E