Reply

Security risk for all PLEX users on Netgear routers

hiefhuy
Aspirant

Security risk for all PLEX users on Netgear routers

Everyone who uses PLEX version 1.21 or lower is vunerable of getting their Router/PLEX installation being abused to launch reflection/amplification DDoS attacks (source)

 

Seeing that Netgear hasn't issued* any updates for PLEX since Sep 29, 2020 it's clear that Netgear \ Nighthawk users are at risk!

 

* PLEX says I quote "This feature is gated by Netgear so a new public version will not appear until they have approved the release to be enabled on the Nighthawk X10 device." (source)

 

So Netgear, please, when can we expect the long overdue update for PLEX?

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 1 of 4
DarrenM
Sr. NETGEAR Moderator

Re: Security risk for all PLEX users on Netgear routers

I will escalate this to the engineers.

 

Thanks

DarrenM

Message 2 of 4
hiefhuy
Aspirant

Re: Security risk for all PLEX users on Netgear routers

Happy to hear this, hoping this will result in an update soon.

Message 3 of 4
hiefhuy
Aspirant

Re: Security risk for all PLEX users on Netgear routers

Any updates on this matter? 

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 286 views
  • 1 kudo
  • 2 in conversation
Announcements