Reply

Re: Speeds lower than 5Mbps on a new C7800.

Nikasru
Aspirant

Speeds lower than 5Mbps on a new C7800.

I got a new nighthawk x4s to replace my old router but my internet speeds are lower than 5 Mbps and sometimes below 1 Mbps.(This was tested with both ethernet and wifi across multiple devices with https://speedtest.xfinity.com/ and https://www.speedtest.net/)

I already tried to reboot, reset to factory defult and contact my internet provider (xfinity) but everything was fine on their end.

Model: C7800|Nighthawk X4S-AC3200 WiFi Cable Modem Router
Message 1 of 6

Accepted Solutions
plemans
Guru

Re: Speeds lower than 5Mbps on a new C7800.

If you have any splitters, attenuators, or amplifiers in line, remove them. Also directly connect to where the coax enters the home to prevent wiring within the home being an issue.

Then log into the device and get a screen snip of the cable connection page and your logs and post them back here. 

Another thing to check is see if they can re-provision it. I've had them send the wrong provisioning file before and cause issues. 

Also, make sure you're speed testing over a hardwired connection. Its pointless to troubleshoot a connection back to the isp if we're dealing with a wireless issue. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->

View solution in original post

Message 2 of 6

All Replies
plemans
Guru

Re: Speeds lower than 5Mbps on a new C7800.

If you have any splitters, attenuators, or amplifiers in line, remove them. Also directly connect to where the coax enters the home to prevent wiring within the home being an issue.

Then log into the device and get a screen snip of the cable connection page and your logs and post them back here. 

Another thing to check is see if they can re-provision it. I've had them send the wrong provisioning file before and cause issues. 

Also, make sure you're speed testing over a hardwired connection. Its pointless to troubleshoot a connection back to the isp if we're dealing with a wireless issue. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->

View solution in original post

Message 2 of 6
Nikasru
Aspirant

Re: Speeds lower than 5Mbps on a new C7800.

There are no splitters, and wiring within the home is not an issue as my old router worked fine with it and it still can. I am also sure i am speed testing over a wired connection.

Message 3 of 6
plemans
Guru

Re: Speeds lower than 5Mbps on a new C7800.


@Nikasru wrote:

There are no splitters, and wiring within the home is not an issue as my old router worked fine with it and it still can. I am also sure i am speed testing over a wired connection.


Were you only using a router before? 

Who's your isp? 

Reason I ask this is you don't have the modem activated. If you look at your cable connection page, you don't have a single channel locked. the C7800 is a modem/router combo device. 

If your isp isn't a cable operator, the isp wouldn't be compatible with your service. If it IS a cable operator, you need to contact them to activate it. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 4 of 6
Nikasru
Aspirant

Re: Speeds lower than 5Mbps on a new C7800.

It was a 2 in 1 modem-router by xfinity, which is our ISP.

I have already tried to activate the c7800 but i will call my ISP to activate it again.

Message 5 of 6
plemans
Guru

Re: Speeds lower than 5Mbps on a new C7800.

since you marked it solved, I take it you got it working when you called your isp?
Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 555 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 6E