Introducing the Orbi 970 Series Mesh System with WiFi 7 technology. For more information visit the NETGEAR Press Room.


Unable to connect to SRS60 Orbi Pro


Unable to connect to SRS60 Orbi Pro

I used a RSS60 system with a main router and two satellites for two years, 2019-2020, just after the pandemic. Then we left the office for several months and suddenly my Orbi system stop working. I didn't have the time to further investigate the problem, until now. 

I'm not being able to setup the system again: I tried using the Orbi App, nothing; I tried resetting the main device, since I don't need the old settings anymore, but I can't connect with it... I can't see the default wifi network the device is supposed to generate and if I connect directly with an ethernet cable I don't get a proper IP direction form the router DNS so I'm unable to access to the control interface.

After resetting, I got a long solid red light in the power led, followed by a blinking red and then a solid green light. 

I read that a blinking red light means a corrupted firmware. Could it be the problem? I can't check which firmware I have since I can't access the device. Any suggestions? Is there a way to force a firmware reset/upgrade using a trick via an ethernet cable?

Thanks for your help, in advance.

Message 1 of 3

Re: Unable to connect to RSS60 Orbi Pro

Thank you very much for the reply and the suggestion, @schumaku. After contacting Netgear support, they determined that my router was dead but still within warranty, so I applied for a replacement. I have a new router and now everything is working fine. I didn't have the opportunity to try your solution. 

Thanks anyway!

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation