× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Orbi WiFi 7 RBE973
Reply

GS105Ev2 does not get IP address from DHCP

TL7n
Tutor

GS105Ev2 does not get IP address from DHCP

I have a brand new GS105Ev2 (GS105E-200NAS).  It already has the latest firmware as of today, which is V1.6.0.11.  I attached it to the network, and then applied power.  It did automatically get an initial IP address from DHCP.  However, once that initial IP address was assigned, the IP would never change again via DHCP, even after restarts and power down/up.

 

For network appliances and servers, I specifically allocate the IP address in my router by binding the IP address to a MAC address, and I keep such IPs clustered together.  That way the devices are easy to find, and always get the same IP address after restarts, effectively making them act similar to fixed IPs without the trouble of managing fixed IP addresses.  But, for this NETGEAR GS105Ev2 device, it would never take the IP address I had allocated for it in my router.

 

No mater what I did, the device never had the allocated IP address that it was supposed to get via DHCP.  It seems that once an IP address is initially received from DHCP, maybe then GS105Ev2 never gets the IP address via DHCP again; I expect it to obtain the IP address from DHCP after every reboot or power recycle.

 

I did eventually figure out how to make the device change the IP address that was obtained via DHCP.  Factory reset!  After using a needle to hold the factory reset button in for a few seconds, the device did actually obtain the correct IP address that had been allocated to it in the router's DHCP allocation table.  The only problem is I had to reconfigure the device again.

 

Hopefully this post will be helpful to others that have DHCP problems with NETGEAR Gigabit Smart Managed Plus Switches..

 

 

 

Message 1 of 5
schumaku
Guru

Re: GS105Ev2 does not get IP address from DHCP

Hard to believe ... reads more like you have accidentally set a static IP, or the DHCP server does insist to issue the same IP address for the MAC address as before. The Plus switches (at least the models not built on a managed core) don't have the greatest - but workable - dhcpd in place due to the way the IP stack is implemented.

Message 2 of 5
TL7n
Tutor

Re: GS105Ev2 does not get IP address from DHCP

I, too, find it difficult believe that it behaves that way.  But, that does not change the fact that it does!  I would love for some others to confirm with comments to this post if they have seen the same thing:  after getting the initial IP via DHCP, the GS105Ev2 will not get a new IP via DHCP without a factory reset.

 

For several reasons, I don't think the router was reassigning the "old, initial" IP address instead of the "new, allocated" IP each time based on the MAC.

  • I have many devices with allocated IPs in DHCP, and they have all worked flawlessly except for this GS105Ev2.  I suppose it could be a problem for certain kinds of devices that periodically change the MAC for security purposes, but this NETGEAR switch does not do that.
  • Without touching the configuration on the router, holding the factory reset button on the GS105Ev2 did cause it to get the correct IP via DHCP when it booted back up.  How would router even know the factory reset occurred, as opposed to a software reset or power cycle?  All the router knows is that the device is using DHCP to request an IP address.

I don't see how I could have "accidentally" set it to use a static IP via the HTTP interface, unless that interface has underlying bugs.  It's pretty simple:

  • Select via a "DHCP Mode" drop down either "Enable" or "Disable"
  • If DHCP Mode "Disable" is selected, a fixed IP address is used and you can manually enter "IP Address", "Subnet Mask" and "Gateway Address".
  • If DHCP Mode "Enable" is selected, the "IP Address", "Subnet Mask" and "Gateway Address" are disabled.
  • There is a "Refresh" checkbox, which I assume means update the IP when the Apply button is pressed (but could not find a description of what it actually does).  I tried it checked and uncheck -- it did not make a difference immediately or after software Device Reboot or power cycle.
Message 3 of 5
schumaku
Guru

Re: GS105Ev2 does not get IP address from DHCP

Testing using the GS105PE on  V1.6.0.17 and a GS308E on v1.0.11 and just adjusting the DHCP MAC LAN IP reservation address simply ticking the [x] Refresh and [Apply] does does trigger a a DHCP Discover and DHCP Request to bring both DUT to the new defined DHCP reserved LAN IP address. No DHCP ACK because it's not a confirmation of the previously used address.

 

Either way, only ticking the [x] Refresh and [Apply] does trigger a complete DHCP Discover, DHCP Request, and DHCP ACK.

 

Admit, I have no GS105Ev2 at hand. Rather simple to test, Wireshark fired up and listening, just the dhcp filter in - everything you are keen to see is broadcast on 0.0.0.0, the DHCP ACK is broadcasted to the .254 address in the case of the unchanged address. 

 

Changing from DHCP to static does not retain the IP config - it's something I don't do very often. The Web UI will show this:

 

DHCP Mode

Note: Changing the protocol mode will reset the IP configuration.

 

 

Message 4 of 5
TL7n
Tutor

Re: GS105Ev2 does not get IP address from DHCP

I feel so defeated.  I have tried and tried to reproduce this with the same GS105Ev2 switch, but cannot.  If I change the allocated IP in the router and power cycle the switch, the switch now always gets the correct, allocated IP.  I am not sure what changed to make it start working, other than the factory reset on the switch.

 

As an electrical engineer and software engineer that has had to trouble shoot many technical issues reported by end users over the years, I have no choice at this point other than to admit defeat and conclude that it must have somehow been a BTCATK error (Between The Chair And The Keyboard == user error).  I am using VLANs, and I think I entered the exact same VLAN config after the factory reset as the initial VLAN config before the factory reset. But, it seems likely that I could have entered that initial VLAN config incorrectly, and that could have prevented the switch from hitting DHCP.

 

At this point, I am not going to investigate any further because it's working the way I want it to work.

Message 5 of 5
Discussion stats
  • 4 replies
  • 805 views
  • 1 kudo
  • 2 in conversation
Announcements