Reply

ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

mfinney
Guide

ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

I have two ReadyNAS running latest 6.9.5 firmware and ReadyCloud desktop app v1.6 running on both windows and macos machines connected outside my LAN.  Neither will connect and show status 'Online (VPN disconnected)'. Web browser and iOS mobile connectivity works.  

 

I've followed a number of discussion threads, tried a number of things, but can't resolve it:

- Rebooted NAS a number of times

- Turned off readyCloud feature by 'leaving' then rejoining

- Removed & reinstalled both desktop apps

- tried all the above pre NAS upgrade whilst runnign 6.9.4

- tried changing readycloud settings, specifying TCP port 6300,, punching holes in my firewall, 'encryption' on and off...

Nothing works.  Can anyone help - really struggling with this...

 

 

Model: RN31600|ReadyNAS 300 Series 6- Bay (Diskless),RNDP6000-200 |ReadyNAS® Pro 6 |EOL
Message 1 of 12
Marc_V
NETGEAR Employee Retired

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

Hi @mfinney

 

Have you checked your NIC settings? might be good to add DNS servers like google and your router address.

 

Also, if you can send in the logs thru PM I would be able to take a look.

 

 

Regards

 

 

Marc_V
NETGEAR Community Team

It's what you do that defines you
NETGEAR Community User Guidelines
Message 2 of 12
mfinney
Guide

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

Mark, thanks for your response.  I already have the NIC configured for Cloudflare (faster than google public DNS servers) and my local router IP. Any other ideas?

Message 3 of 12
Marc_V
NETGEAR Employee Retired

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

Have you tried connecting to a different network? mobile data or another ISP?

Marc_V
NETGEAR Community Team

It's what you do that defines you
NETGEAR Community User Guidelines
Message 4 of 12
mfinney
Guide

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

Hi Mark, thanks for responding back so quickly.  I've actually tried to connect via 3 different networks, including my mobile phone providers network...

Message 5 of 12
Fisicoloco
Guide

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

Hi @mfinney
Did you solve the issue?
I have the same problem and (as you did) I have tried to fix it making changes and tests for long but without any success.
I can see that Netgear Community has no solution and the support team provides no answer at all when they do not know how to act (my experience with several things that I asked is that I got no solutions; is like the support team avoid to enter in questions that they do not control completely).
If you got a solution, please, tell us about it. I am near madness with this problem.
Thank you.
Message 6 of 12
StephenB
Guru

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

I haven't used ReadyCloud for a long time now, so I can't give much current advice - other than to consider moving to a different solution for remote access - deploying your own VPN.  If you don't have many simultaneous users, you can see if your existing router supports openVPN.  Both Nighthawk and Orbi routers do.

 

I will say that since the ReadyCloud web interface is working, that the problem cannot be on the NAS->ReadyCloud leg.  So playing around with DNS, port forwarding, leaving/rejoining ReadyCloud on the NAS isn't going to be fruitful.  The issue sounds like it has to be the PC->ReadyCloud connection.  I'd be looking at internet security software that might be running on the PCs, and the network setup that the remote folks are using.

Message 7 of 12
Fisicoloco
Guide

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

Thank you @StephenB 

 

It doesn't appear to be the connection between ReadyCLOUD and the PC. In fact, I have two NAS operating in two different cities and I always can connect with one of them (always the same) but the other only connect sometimes and, apparently, there is no reason to connect or not.

 

The situation is as this:
Me (the PC with ReadyCLOUD) and both NAS (call it A [RN21200] and B [RN3138]) are installed in different cities each other (city A, city B and city PC). Three different places.
Both NAS are conneted to the web via fiber.
I am in a mountain with two radio connections (R1 and R2) balanced through a multi-wan router.
I've tried to connect using both radio-links, or cancelling one of the radio-link or cancelling the other (R1 and R2 connected - I try // R1 disconnected - I try again // R2 disconnected - I try once more).
Here is where I say that there is a random connection protocol. Sometimes I get a stable connection. Sometimes I cannot get connected. But I always get connection with one of the two NAS; I always get connection with A but B is connected only sometimes.
I have tried to do it even in several different places with fiber or ADSL connections. I always get the same: A always connect, B connect sometimes yes, sometimes no.
I always use Google DNS and Cloudfare DNS

 

So, I can infere that: The problem are not the ports; the problem is not the PC; the problem is not ReadyCLOUD; the problem is not the connection itself.

 

I'm becoming in mental hospital flesh.

 

By the way, I have tried all the suggested solutions that appear in other threads. The results are the same that I tell above.

 

 

ready cloud 01.jpg

ready cloud 01.jpg

 

Model: RN21200|ReadyNAS 212 Series 2- Bay (Diskless), RN3138|ReadyNAS 3138 Series 4- Bay (Diskless)
Message 8 of 12
StephenB
Guru

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'


@Fisicoloco wrote:

Thank you @StephenB 

 

It doesn't appear to be the connection between ReadyCLOUD and the PC. In fact, I have two NAS operating in two different cities and I always can connect with one of them (always the same) but the other only connect sometimes and, apparently, there is no reason to connect or not.

Your symptoms appear to be very different from @mfinney, and my comment was really aimed at him.  You might want to start your own thread, as it gets confusing when multiple users are sharing a thread, especially when they have different symptoms.

 


@Fisicoloco wrote:


I have tried to do it even in several different places with fiber or ADSL connections. I always get the same: A always connect, B connect sometimes yes, sometimes no.

 


Is there another way you can try to reach site A?  For instance, enable ddns and try using something like gping to keep pinging site A's  edge router?  Another option (maybe better) is to have someone at site A do an outbound gping test to the amazon cloud (which I believe is hosting the ReadyCloud VPN servers).  Leave that running for a day or so, which will give you some idea of the connection quality.

 

Message 9 of 12
mfinney
Guide

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

Hi Fisicoloco, Actually I did solve it for me in the end. Not sure this will work for anyone else... I created another netgear / readycloud account and used these new credentials on the ReadyNAS config page and ReadyCloud app to login, and voila it started to work...

 

I switched back to my original account - same issue, didn't work, so switched back to new and all good.  I went back to Netgear with this info but none of them could work out why their VPN client wouldn't work with my old account...

 

TBH my experience with all of their VPN clients, ReadyNasRemote prior to ReadyCloud, was always poor / unreliable. My feeling is they don't do a thorough job of testing end-to-end.

 

Not sure this is of help... 

Message 10 of 12
Fisicoloco
Guide

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

Thank you @StephenB and @mfinney 

 

As @StephenB says, the symptoms that my problem presents are different from those @mfinney

So if my last test doesn't work, I'll open a new thread.

 

But before doing so, as I say, I am going to try the solution that @mfinney has given.

As soon as I have time to do the test I will tell you the result.

 

Once again, thank you very much.

Message 11 of 12
Fisicoloco
Guide

Re: ReadyCloud Desktop App shows 'ReadyNAS online (VPN Disconnected)'

Hello once again.

After several days of investigation, I've reached a conclusion: The problem is in the bandwith of the connection.

Is quite simple: when I have more than 10 Mb of bandwith it appears not to have any problem (only delay when connecting).

All the connections (several of them have been tested) that have more than that never present problems.

On the other hand, when the bandwith is narrow, the connection behave as I presented in the before posts: completely random.

So, my conclusion is that the problem is a question of bandwith.

Once more, thank you very much for your suggestions and your help.

 

Message 12 of 12
Discussion stats
  • 11 replies
  • 3032 views
  • 3 kudos
  • 4 in conversation
Announcements