× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Microsoft EDGE - Readynas keeps going to password recovery

Zapoteknico
Aspirant

Microsoft EDGE - Readynas keeps going to password recovery

When I try to access my Ready Nass from a Microsoft Surface with EDGE it always go automatically on the Password reset page.

If i try to do the same using Internet Explorer, it works no problem.

The Issue is....they are going to remove Internet Explorer from the Laptop as IE is at the end of life support in June.

Does anyone knows why EDGE always goes on "Password recovery mode" ?

I have no passwords saved in EDGE and I have no passwords saved in Windows 10.

Thank you 

Model: RN10400|ReadyNAS 100 Series 4- Bay (Diskless)
Message 1 of 4
StephenB
Guru

Re: Microsoft EDGE - Readynas keeps going to password recovery


@Zapoteknico wrote:

When I try to access my Ready Nass from a Microsoft Surface with EDGE it always go automatically on the Password reset page.

If i try to do the same using Internet Explorer, it works no problem.

 


Have you tried both https://nasname/admin or https://nasipaddress/admin ? (using the real NAS name and IP address of course).

 

This sounds like Edge might have saved an old or incorrect password.  It would apply that automatically, and if it is wrong you could end up on the password reset screen.  You can test this by opening an inPrivate window, and log in from there.  Or just browse to edge://settings/passwords and look for saved passwords for the NAS there.

Message 2 of 4
Zapoteknico
Aspirant

Re: Microsoft EDGE - Readynas keeps going to password recovery

Thank you. For your answer.
None of the suggestions works and I have no passwords saved, even using private mode i receive the message attached
Message 3 of 4
StephenB
Guru

Re: Microsoft EDGE - Readynas keeps going to password recovery

What model ReadyNAS do you have, and what firmware is it running?

 

You will get a certificate warning (which is what the "your connection isn't private" bit is about).  But usually "advanced" gives you the option to connect anyway - and you aren't seeing that.

 

BTW, there is an IE mode built into Edge that you could try.  But I think we still should try to get Edge to connect w/o it.  More info on IE mode is here: https://docs.microsoft.com/en-us/deployedge/edge-ie-mode-local-site-list

 

 

 

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 1111 views
  • 0 kudos
  • 2 in conversation
Announcements