Reply

RN104 6.2.3 Upgrade Issues: FrontView & Power Button

Siothrun
Aspirant

RN104 6.2.3 Upgrade Issues: FrontView & Power Button

Since upgrading my RN104 to 6.2.3 I'm no longer able to access FrontView and the Power button is unresponsive.
NB: I do still have access to the Shares and via SSH.

This upgrade was of particular interest to me since it fixed an issue where removing certain apps would bring the web interface offline. This previously led to me having to do a Factory Reset, since SSH wasn't enabled at the time. I must admit I find it ironic that in upgrading to avoid an issue that would bring the web interface offline, that the upgrade itself brings the web interface offline.

Symptoms:
1. Multiple attempts to access Frontview using either Chrome or IE indicates that the 'ReadyNas "Admin Page" is offline'.
2. The front LCD panel no longer changes when the Power button is pushed. This means that I can no longer gracefully shutdown the RN104.

Screenshot:
http://imgur.com/GqIXZv8

Actions Taken:
1. The RAIDar-4.3.8 Utility shows two entries for the ReadyNAS 104. The first entries MAC and IP addresses correspond to an OpenVPN connection, where RN104 is the VPN Client. The second entries MAC and IP addresses match the IP address that is statically defined for that MAC address in the router. This is the IP address that I use to access FrontView. Selecting this entry and clicking Setup fails to access FrontView.
2. Rebooted RN104 by removing power cable. (This was necessary because the Power button is unresponsive.)
3. Rebooted Router.
4. RN104 OS-Reinstall.

Customisations:
1. Add-Ons installed: Transmission, Python, MySQL Server & PHPMyAdmin.
2. SSH Enabled.
3. vim installed.
4. Ajenti installed.
5. OpenVPN installed.
6. make installed.
7. SQLite installed.
8. Flexget installed.
9. Crontab modified to start OpenVPN Client on Reboot and run Flexget hourly.

None of the actions taken to date have resolved either of the issues that I am experiencing.
I assume that a Factory Reset will most likely resolve the problem, but I would prefer to go down this path only as a last resort.
I'm posting this in the hope that someone in the community may have a solution or suggestion on how to resolve these issues.

Thanks
Siothrun
Message 1 of 12
ronaldvt
Aspirant

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

Well Sothrun, maybe it's fine to hear that you're not the only one.
I just upgraded the firmware to 6.2.3. on my RN104, and having exactly the same promblems that you encountered.
Let's hope someone can help us both to fix this.

Regards,
Ronald
Message 2 of 12
mdgm-ntgr
NETGEAR Employee Retired

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

Siothrun I have sent you a PM

ronaldvt I see support has replied in your case 25057346
Message 3 of 12
6ril
Aspirant

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

Hi,
it might not be the same problem, but since I updated the frimware 6.2.2 -> 6.2.3, I can't see the APPS installed.
Power button isn't responding (but that was already there, can't get it to work after a while).

Help! please.
Message 4 of 12
avarabyeu
Guide

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

The same problem. Also have OpenVPN installed. Dear NetGear support, could you please help us resolve issue? Is there any way to re-install firmware using ssh (without factory reset)?
Message 5 of 12
mdgm-ntgr
NETGEAR Employee Retired

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

6ril were you able to get the logs I asked you for?

avarbyeu I have sent you a PM.
Message 6 of 12
ReadyNAS2014
Aspirant

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

I am experiencing the same problem.

now get an 'error - could not properly extract'

Ive rebooted several times and always get stuck at this stage.

Would really apreciate any help in reversing this upgrade as was all working fine previously.

thanks in advance
Message 7 of 12
mdgm-ntgr
NETGEAR Employee Retired

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

If you have OpenVPN installed you should be creating a systemd service for it, not trying to start it a different way.
Message 8 of 12
Siothrun
Aspirant

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

Upgrading my RN104 to 6.2.4 resolved my issues.
Many thanks to mdgm!

Regards
Siothrun
Message 9 of 12
elast
Aspirant

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

Hi,
I just upgraded to 6.2.3 and faced the same issue . Everything works except from the frontview connection. It seeems to be the readynasd process that fails to start.
What is the remedy?

root@xxxxxxxx ~# systemctl status readynasd
readynasd.service - ReadyNAS System Daemon
Loaded: loaded (/lib/systemd/system/readynasd.service; enabled)
Active: inactive (dead) (Result: core-dump) since Wed, 20 May 2015 19:16:20 +0200; 25s ago
Process: 4571 ExecStart=/usr/sbin/readynasd -v 3 -t (code=dumped, signal=SEGV)
Status: "Importing DB"
CGroup: name=systemd:/system/readynasd.service
Message 10 of 12
mdgm-ntgr
NETGEAR Employee Retired

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

elast, I just sent you a PM.
Message 11 of 12
bypo
Aspirant

Re: RN104 6.2.3 Upgrade Issues: FrontView & Power Button

Just having the same issue.
Readynasd not starting. Stuck on "Importing DB".

Any hints?
Message 12 of 12
Top Contributors
Discussion stats
  • 11 replies
  • 2140 views
  • 0 kudos
  • 8 in conversation
Announcements